New to the forums? Click here to read the How To guide. -- Developers click here.

Google Earth VR Error code 0. Function ovr_CreateTextureSwapChainGL

bryalcbryalc Posts: 1
NerveGear
Hello, 

I can't seem to find a clear answer to this online. I just got a new computer and it is oculus certified. I am connected to my graphics card's HDMI port, however, I have a TV plugged into the top panel of the PC.  I am trying to start Google Earth VR and get this error message - "Google Earth VR Error code 0. Function ovr_CreateTextureSwapChainGL"

I found this answer online: 

> the bottom is where your graphics card goes. it should be that what you are using for all your display devices. if you are using the ones at the top, then they are running on your onboard graphics and that's not supported <

This does not make sense to me, how does the PC monitor relate to the Oculus working? I can turn the TV off and I'd expect the Oculus to still work. So I am still trying to figure out how to get Google Earth - all my other apps work so far. I really want this to work because I love exploring with regular Google Earth and can't wait to try it in VR. 
Tagged:

Comments

  • LZoltowskiLZoltowski Posts: 6,429 Volunteer Moderator
    Both the Display and the Rift have to be plugged into the same graphics card due to the way things work.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • TvVlietTvVliet Posts: 7
    NerveGear
    [SOLVED] I've been trying to fix this for weeks but i've finally done it:

    I went into Nvidia Control Panel -> manage 3d settings -> select earth VR (or other) -> change CUDA to main GPU, OPENGL to main GPU and Power to maximum



Sign In or Register to comment.