Stutter with Nvidia drivers since 388 and beyond — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Stutter with Nvidia drivers since 388 and beyond

lightmare361lightmare361 Posts: 14
NerveGear
This has been issue for me since November. Rollbacking to the 384 builds has fixed the issue. What is going on since then? We are in build 391 now and it's still not resolved.

I do not use or have f.lux
Ive disabled Nvidia Share
I am up to date on all drivers and windows updates
I have no monitoring programs in the background
All usb ports are working fine and are optimal
I have reinstalled Oculus Home and software
I have done a clean reinstall of gpu drivers
I do not have heating issues
I do not have sensor issues or head unit issues

This hitching and stutter when panning to the left or right is a software and driver issue. Ever since 388 it has been a nightmare.

My system requirements

Intel i7 7700 HQ 2.8ghz
Geforce GTX 1060 6gb
32gb Memory
1tb SSD M.2

Its been months... Im about ready to hang up the towel. When I was able to use the 384 nvidia driver builds it fixed everything. That isnt an option anymore.

What else can I do?



Comments

  • RedRizlaRedRizla Posts: 5,813 Valuable Player
    edited April 2018
    No stutter for me with the latest Nvidia driver, if it is an Oculus software issue wouldn't it be the same for everyone? Are you using Super Sampling? Also have you disabled background programs?
  • dburnedburne Posts: 1,982 Valuable Player
    No problem with the latest drivers for me either, no stuttering at all.

    Fwiw, I only ever install the actual driver and PhysX. None of that other stuff.

    Might be worth a short to uninstall drivers  with DDU ( Display Driver Uninstaller) in safe mode, reboot and then install the latest drivers installing only the driver and PhysX. Then set your power plan to " maximum performance", and in Nvidia Control Panel set power to "prefer maximum performance".

    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • lightmare361lightmare361 Posts: 14
    NerveGear
    edited April 2018
    Its the compositor frame drops that create that micro stutter. With the newest nvidia drivers for the 1060 even with AWS disabled and Supersampling disabled, it has a performance head of 5% - 7% even in oculus home. So as VR ready as my rig was advertised, that is no longer the case.

    I have DDU my gpu drivers along with a fresh install of oculus firmware, and set it to maximum performance in the Nvidia control but no dice, still the same issue. Ive also tried my wife's rig which is the exact same hardware specs as mine and the same issue persists and same debugtool performance results.

    Im assuming the hardware requirement has increased for oculus with the newest oculus firmware and latest nvidia drivers. Its using more gpu than ever before. This is with all background applications, overlays, and 3rd party programs closed.

    Ever since 388.00+ drivers for my 1060 the performance head is at 5%-7% but on the 384 drivers back in the day, it was at 30-50% using the same rig and hardware.
  • SimonSays28SimonSays28 Posts: 578
    Neo
    I am running the following system with the latest drivers and no stuttering issues:

    Intel Core i7-6700 Skylake 6th Gen up to 4.0GHz
    Kingston 16GB HyperX FURY DDR4 (2x8GB)
    Zotac nVidia GeForce GTX 970 4GB GDDR5
    Seagate 2TB Barracuda 7200RPM SATA 6Gb/s
    Check out my band at http://theheavyjack3.bandcamp.com/ - our entire discography has been released for free download.

  • lightmare361lightmare361 Posts: 14
    NerveGear
    Yea I have no idea, Im completely stumped. I dont know what else to do.
  • SimonSays28SimonSays28 Posts: 578
    Neo
    Have you tried a full system reinstall - I know it sucks (I have done one on my current system, and many in the past on other systems) but sometimes a fresh Windows install can be what is needed.
    Check out my band at http://theheavyjack3.bandcamp.com/ - our entire discography has been released for free download.

  • RedRizlaRedRizla Posts: 5,813 Valuable Player
    Its the compositor frame drops that create that micro stutter. With the newest nvidia drivers for the 1060 even with AWS disabled and Supersampling disabled, it has a performance head of 5% - 7% even in oculus home. So as VR ready as my rig was advertised, that is no longer the case.

    I have DDU my gpu drivers along with a fresh install of oculus firmware, and set it to maximum performance in the Nvidia control but no dice, still the same issue. Ive also tried my wife's rig which is the exact same hardware specs as mine and the same issue persists and same debugtool performance results.

    Im assuming the hardware requirement has increased for oculus with the newest oculus firmware and latest nvidia drivers. Its using more gpu than ever before. This is with all background applications, overlays, and 3rd party programs closed.

    Ever since 388.00+ drivers for my 1060 the performance head is at 5%-7% but on the 384 drivers back in the day, it was at 30-50% using the same rig and hardware.

    Have you contacted Oculus support with this information to see what they say?
  • MAC_MAN86MAC_MAN86 Posts: 1,633
    3Jane
    edited April 2018
    Many users have this issue including me since last week. It really must be either Oculus Firmware Updates or bad Win Update. I checked my Win History and it could be anything there.
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    I had the exact same issue and opened a thread with my observations here:
    https://forums.oculusvr.com/community/discussion/62663/how-nvidia-ruins-the-oculus-rift-experience

    Just like you, I could fix it by sticking to 384 drivers... but yea, this can't be a solution, as modern games require up-to-date drivers. However, NVIDIA doesn't care. That's the simple (yet sad) truth.
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • MAC_MAN86MAC_MAN86 Posts: 1,633
    3Jane
    edited April 2018
    Advised from NVIDIA: -
    http://www.guru3d.com/files-get/display-driver-uninstaller-download,20.html

    You need to download DDU tool then extract to desktop in new folder then look for DDU.exe program

    https://youtu.be/P_BZRSdeT1E 

    I'll try this after I rolled back from latest 391.35 back to 388.59. It saved it in the past. Gonna try 384.94

  • MAC_MAN86MAC_MAN86 Posts: 1,633
    3Jane
    OK I finally fixed my Judder problems which began around 4th April. There was no Driver Update to cause it but something triggered it, possibly Renesas USB3 Driver Update (Microsoft) or a Mediatech Update which installed a driver for Andoid Phones knowing you connected one already. Plus the Oculus Firmware and generally things expanding and using more system memory.

    *Used latest DDU Driver Uninstall in Safe Mode - although about 7 ways to get in Safe Mode it for Win10 was not so simple when it tries to find ISO of OS to revert to as 1st auto step! I used HOLD SHIFT whilst selecting RESTART in START MENU to get there. Cancalled the ISO search, Advanced, it reboots, gives you several options, Select Safe Mode number 4. Use DDU (not connected to net & not to install driver upon boot). From here I found the Driver 384.94 also on the DDU website and installed using Microsoft method of Updating Driver in Device Panel rather than using the daft package with Experience. 
    *It went well but there was no Nvidia Panel on Right-Click until I rebooted yet again as is normal for drivers to work properly. Then to config the FULL DYNAMIC RANGE as this gets your black the most black. I also altered DSR=ON and checked all boxes just in case it required this. (???)
    *E:D running Max but Shadows to High as a compromise and OculusDebugTool PD= 1.85 and it runs fine. On 1.9 I get slight stutters. On 2 I get it ok everywhere except in Stations at times it goes crazy so I take it that is bottlenecking, heat, and memory all at once. My EVGA Precision-X fan control & overclock takes 44MB and I maybe better without it (???). Otherwise, I got it working fine and super smooth on PD=1.85 and happy.
    *It also installed the daft 3D Driver so I removed that and I already Disable the standard driver for my Monitor so it didn't put Nvidia Audio on either. It did put on PhysX which hardly any games use now plus VulkanRT (excellent) and this I read made LONE ECHO work again for one user so I may try this again. Although I had many hard crashes when I tried it last time to no avail and it could have been the cause. That is severely bad of them to add SSE4.2 check in a game. It installs but can not run past the menu.
  • MAC_MAN86MAC_MAN86 Posts: 1,633
    3Jane
    edited April 2018
    However, I have finished my testing for Judders I had in E:D now solved.
    RESULT: It was EVGA PrecisionXOC which makes use of the Pascal power of my GTX1080
    This is my overclock/fan control monitor. I had actually been using this in full KBOOST mode always because in my understanding since earlier versions I needed this program open to get my fans to run properly rather than my old GTX970 sat idle too much before over heating. e.g. E:D used to crash when exiting from H-Jumps to Stars without this program running a Custom Fan Profile to get the fans running earlier. In my mind I thought I had to select KBOOST to get the Factory Preset OC2 speeds/settings. Actually, (it does now say in tips) this button it ONLY for Benchmark Stress Testing as it puts the card in overdrive mode at max.
    If I use the older PrecisionX16 it no longer lets me access this tiny button the size of this "." and the program is merely a monitor and fan controller. If I use the latest PrecisionXOC which makes use of the Pascal power of my GTX1080, even with KBOOST=OFF, it still will make E:D goes all crazy glitching but only within the Stations. So with E:D I must not use this program which is a monitor in my use anyways. I simply thought it was a need to have it running due to experience of the old GTX970 which the firmware had a slow startup for fans from idle. The new cards are fine to not require Custom Fan Profiles and if they are Factory Overclocked then that is their new default to not require KBOOST. That button is way too easy to think you need use it!!!
Sign In or Register to comment.