New to the forums? Click here to read the How To guide. -- Developers click here.

occasionally stutter / judder - Please help

markusrisehansenmarkusrisehansen Posts: 3
NerveGear
Hi

I have recently bought an Oculus rift and I'm having perfomance issues..

When I play, I occasionally experience "hickups" and stutter, especially when i look around..

I'm currently playing the Climb to test it but I have experienced the same issues in multiple games. I't also seems that my PC stutters, when I'm taking the HMD off - but only when the HMD is connected..

It doesen't seems to be effected wether it's high or low settings

I sometimes get the message "Poor tracking quality, and "too many lost IMU Samples"

I therefore suspect that it is a USB-bandwith issue..   

I have an Oculus Rift HMD, 2 sensors and 2 touch controllers, 1 keyboard and 1 mouse connected..

I do not experience any performance issues in "normal" games where I play games like PUBG or BF1 on ultra settings..

I have the following system:

* ASUS PRIME Z 370 Motherboard.
* INTEL CORE I5 8400 @ 2.81 GHz
* ASUS ROG STRIX GTX 1080
* 16 GB DDR4 RAM
* WIN10 64 BIT
* SAMSUNG EVO 250 GB SSD

I have tried the following:

* Complete reinstall of WIN10
* Reinstall of Oculus Home
* Disabling/removal of software like MSI afterburner
* Disabling all in game overlays
* Switching USB ports
* Connecting a powered USB hub

I do not have software like flux or any Asus motherboard related software. My GPU and system drivers are fully updated. My GPU usage is around 50-70% and my CPU Usage is around 30-40%.

When I'm running the debug tool the game usually runns around 90 FPS, and around 20-30% headroom, except when the stutter appears - then both the FPS and headroom will drop..

I have seen on forums that you sometimes recommend people to buy an PCI usb HUB, but the thing is that I have seen forums where people have the same motherboard as me, but have no issues...

Please help me I don't know what else I could do.. :-(

Best Regards
Markus
 

Answers

  • MAC_MAN86MAC_MAN86 Posts: 1,063
    Neo
    edited April 15
    I get this too and my system has Judders since the beginning of this month.
    I've tried allsorts including moving around USB slots and re-installing C++ Redist 2012 & 2013 and does not seem to be these. All my Oculus gear got Firmware Updates recently also but I could not connect it to that. Win10 got Updates and it now constantly sets my Power Management to High Performance. I had been using Home Beta 1.25 when this later crept in. So I resorted to the 1.24 Release. I was using Nvidia 388.59 so tried the latest then rolled back again and uninstalling Nvidia 3D as it put that back on. I have my monitor's sound Disabled to never need Nvidia Audio added.

    This is my next step to work through APPs 1 by 1 with  CLEAN BOOT: -
    https://support.microsoft.com/en-gb/help/929135/how-to-perform-a-clean-boot-in-windows
    "This will boot your system into a state where only the base Windows processes are running and may well resolve the problem for you if it was being caused by a third party application. :)

    Otherwise, please send us a dxdiag report and we'll be happy to provide further assistance.

    Click the "Start" menu
    Type/Search for "dxdiag" and open it.
    In the new window, click on the button labelled "Save all information"
    A "Save As.." dialogue box appears. Choose a handy destination and click "Save"."
    --------------------------
    > from E:D Support but it's not only Elite. It is improved with PixelDensity at 2 but still there on big objects when rolling. On faster machines I'd say it is masked.
    https://forums.frontier.co.uk/showthread.php/421686-why-is-it-with-EVERY-Nvidia-update-or-FD-update-I

    * DELL T5400
    * INTEL CORE XEON QUAD DUO E5450 @ 3.0 GHz
    * EVGA GTX 1080 SC
    * 16 GB DDR3 RAM
    * WIN10 64 BIT PRO
    * SEAGATE 4TB HYBRID SSHD

  • MAC_MAN86MAC_MAN86 Posts: 1,063
    Neo
    edited April 15
  • DranuDranu Posts: 10
    NerveGear
    I've been having the same issues lately even with a 1080ti.  It seems like some sort of tracking issue to me since its hard to tell whether a frame is freezing or it stops tracking for a microsecond or two occasionally.
  • markusrisehansenmarkusrisehansen Posts: 3
    NerveGear
    Thank you all for your answers - It is nice to know that I'm not the only person to experience the issues.. 

    I refuse to roll back the nvidia drivers and to make major changes in my system because my system runs great and I use my desktop a lot to play other games than VR...

    I Guess I will have to wait for an Oculus Firmware update, or I might try to buy an extra PCI USB card to increase the bandwith .... 

    Do you guys also experience stutter and short freezes in windows, when your HMD and sensors are connected and Oculus home is running?  
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    I refuse to roll back the nvidia drivers and to make major changes in my system because my system runs great and I use my desktop a lot to play other games than VR.
    It appears to be the only option though, as NVIDIA refuses to provide a fix for their high-end GPUs for several months now (actually since August 2017).

    https://forums.oculusvr.com/community/discussion/62663/how-nvidia-ruins-the-oculus-rift-experience
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • MAC_MAN86MAC_MAN86 Posts: 1,063
    Neo
    edited April 16
    Advised from NVIDIA: -
    http://www.guru3d.com/files-get/display-driver-uninstaller-download,20.html

    You need to download DDU tool then extract to desktop in new folder then look for DDU.exe program

    https://youtu.be/P_BZRSdeT1E 

    I'll try this after I rolled back from latest 391.35 back to 388.59. It saved it in the past. Gonna try 384.94
  • markusrisehansenmarkusrisehansen Posts: 3
    NerveGear
    Again thank you for your answers, I will try to Roll back my drivers and see the if that helps - I will try it this weekend..

    I hope i will work, if it does I can at least confirm that it isn’t a hardware issue...


  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    MAC_MAN86 said:
    I'll try this after I rolled back from latest 391.35 back to 388.59. It saved it in the past. Gonna try 384.94
    384.94 did the trick for us, but it doesn't run with Oculus core 2.0 anymore. So it's not really an option for the future to stick to that driver (unfortunately).
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • MAC_MAN86MAC_MAN86 Posts: 1,063
    Neo
    OK I finally fixed my Judder problems which began around 4th April. There was no Driver Update to cause it but something triggered it, possibly Renesas USB3 Driver Update (Microsoft) or a Mediatech Update which installed a driver for Andoid Phones knowing you connected one already. Plus the Oculus Firmware and generally things expanding and using more system memory.

    *Used latest DDU Driver Uninstall in Safe Mode - although about 7 ways to get in Safe Mode it for Win10 was not so simple when it tries to find ISO of OS to revert to as 1st auto step! I used HOLD SHIFT whilst selecting RESTART in START MENU to get there. Cancalled the ISO search, Advanced, it reboots, gives you several options, Select Safe Mode number 4. Use DDU (not connected to net & not to install driver upon boot). From here I found the Driver 384.94 also on the DDU website and installed using Microsoft method of Updating Driver in Device Panel rather than using the daft package with Experience. 
    *It went well but there was no Nvidia Panel on Right-Click until I rebooted yet again as is normal for drivers to work properly. Then to config the FULL DYNAMIC RANGE as this gets your black the most black. I also altered DSR=ON and checked all boxes just in case it required this. (???)
    *E:D running Max but Shadows to High as a compromise and OculusDebugTool PD= 1.85 and it runs fine. On 1.9 I get slight stutters. On 2 I get it ok everywhere except in Stations at times it goes crazy so I take it that is bottlenecking, heat, and memory all at once. My EVGA Precision-X fan control & overclock takes 44MB and I maybe better without it (???). Otherwise, I got it working fine and super smooth on PD=1.85 and happy.
    *It also installed the daft 3D Driver so I removed that and I already Disable the standard driver for my Monitor so it didn't put Nvidia Audio on either. It did put on PhysX which hardly any games use now plus VulkanRT (excellent) and this I read made LONE ECHO work again for one user so I may try this again. Although I had many hard crashes when I tried it last time to no avail and it could have been the cause. That is severely bad of them to add SSE4.2 check in a game. It installs but can not run past the menu.
  • MAC_MAN86MAC_MAN86 Posts: 1,063
    Neo
    It came back when using EVGA PrecisionOCX but is totally gone not running this. However, I had not fully uninstalled previous versions of that so I will either try again or revert back to using the older PrecisionX16. It just means I can't overclock but it's a GTX1080 and at just 40% usage anyways even on PD=2.
    Perhaps the new Pascal commands are too demand and my Xeon Quad Duo may not be using those extra functions.
  • MAC_MAN86MAC_MAN86 Posts: 1,063
    Neo
    edited April 19
    However, I have finished my testing for Judders I had in E:D now solved.
    RESULT: It was EVGA PrecisionXOC which makes use of the Pascal power of my GTX1080
    This is my overclock/fan control monitor. I had actually been using this in full KBOOST mode always because in my understanding since earlier versions I needed this program open to get my fans to run properly rather than my old GTX970 sat idle too much before over heating. e.g. E:D used to crash when exiting from H-Jumps to Stars without this program running a Custom Fan Profile to get the fans running earlier. In my mind I thought I had to select KBOOST to get the Factory Preset OC2 speeds/settings. Actually, (it does now say in tips) this button it ONLY for Benchmark Stress Testing as it puts the card in overdrive mode at max.
    If I use the older PrecisionX16 it no longer lets me access this tiny button the size of this "." and the program is merely a monitor and fan controller. If I use the latest PrecisionXOC which makes use of the Pascal power of my GTX1080, even with KBOOST=OFF, it still will make E:D goes all crazy glitching but only within the Stations. So with E:D I must not use this program which is a monitor in my use anyways. I simply thought it was a need to have it running due to experience of the old GTX970 which the firmware had a slow startup for fans from idle. The new cards are fine to not require Custom Fan Profiles and if they are Factory Overclocked then that is their new default to not require KBOOST. That button is way too easy to think you need use it!!!
Sign In or Register to comment.