New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

No HDMI connection, but I have a screen

dombom88dombom88 Posts: 4
NerveGear
edited April 16 in Support
Hi all,

I got my Oculus rift cv1 and I struggle to get it running.
Everything seems to be okay, except for the HDMI connection.
The Oculus software says that it is not connected, but I have a screen in the headset.
I watched already a VR video and it worked just fine, but neither Steam VR nor the Oculus software works.
It tells me that my Oculus is not ready to to display any VR experiences.
I updated the video drivers to Nvidias 391.35.
Windows detects the Oculus as PnP monitor and I can choose where I want to display the monitor.
I have no other video output, only HDMI. I don't know what else I can do. I have audio and screen.
By the way, the software also reports: "Encountered an error. Please restart your computer or contact.... " I did restart of course several times.
My Graphic card is a GTX950m, which is below the requirements, but I have the screen. Unfortunately I can't lunch any VR stuff except for videos.
It would be great to get some support to make it work.

Looking forward for any idea.

Edit: I run the Diagnostic program and got:
[Service_2018-04-16_21.01.13.txt] 16/04 21:01:13.201 {!ERROR!} [Kernel:Default] Windows 10 system doesn't appear to have RiftDisplay.inf installed. Cannot use DXGI 2 path successfully.
[Service_2018-04-16_21.01.13.txt] 16/04 21:01:13.205 {!ERROR!} [Kernel:Default] [DisplayManager] ERROR:  No suitable VR display system found.
[Service_2018-04-16_21.01.13.txt] 16/04 21:01:13.205 {!ERROR!} [Kernel:Default] [DisplayManager] Reason: Failed during detection of DXGI 2 Preview

I attached the full log to this post.

UPDATE:
I finally managed to install the RiftDisplay.inf
Now my screen is gone and it is black + orange light...

New error log is:
[Service_2018-04-16_23.36.56.txt] 16/04 23:40:27.714 {!ERROR!} [VRAudioDevice] Unable to set input device for SDK: Failed to convert from utf8: The parameter is incorrect.
[Service_2018-04-16_23.51.49.txt] 16/04 23:52:05.157 {!ERROR!} [OAF ERROR] C:\cygwin\data\sandcastle\boxes\trunk-hg-ovrsource-pc-sdk\Software\OculusSDK\PC\OAF\liboaf\os\file.cpp(609) : Windows encountered an error: Access is denied. (1971052)
[Service_2018-04-16_23.51.49.txt] 16/04 23:52:05.157 {!ERROR!} [Session] Failed to rm user data directory on logout: Windows encountered an error: Access is denied.
[Service_2018-04-16_23.52.10.txt] 16/04 23:52:10.531 {!ERROR!} [Kernel:Default] [DisplayManager] ERROR:  No suitable VR display system found.
[Service_2018-04-16_23.52.10.txt] 16/04 23:52:10.531 {!ERROR!} [Kernel:Default] [DisplayManager] Reason: Failed during detection of DXGI 2 Preview

Comments

  • cyberealitycybereality Posts: 25,667 Oculus Staff
    Laptop mobile graphics can be problematic, especially if you have Optimus. In general, you should prefer using a desktop machine for VR. Not saying for sure that's your issue, but it's likely.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • dombom88dombom88 Posts: 4
    NerveGear
    Hi cybereality,

    I was suspecting something like this. Thinking about to buy a new computer now, however it has to be a notebook.
    A VR ready notebook should be fine I guess?
    What is strange is, that I had screen in the beginning. Now the screen is simply black.
    Anyway, I will check for a new VR ready notebook.
  • dombom88dombom88 Posts: 4
    NerveGear
    edited April 17
    Ordered the ROG GR8 II from Asus. It is a Oculus Ready PC and should have no trouble to run my Oculus!
    I hope that at least, don't wanna spend 2000$ on something which isn't working after all.
Sign In or Register to comment.