New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Update: Found the Fix and possible reasons Oculus Go's will not connect to PCs for file transfer

2»

Answers

  • ozgruntozgrunt Posts: 1
    NerveGear
    The method to upload an app is quite different. After creating your build in the platform of your choice (ie Unity) you use the adb cli command to upload it.

    For Unity instructions click here

  • geebee666geebee666 Posts: 220
    Nexus 6
    Just something that I ran into that will stop you being able to use the Go on a PC, if you have a Rift and the Oculus Windows app is open my Go will not allow you to do anything on your PC, shut down the Oculus software reconnect Go and everything works as normal.
  • NoxhilNoxhil Posts: 1
    NerveGear
    Hey I read a good bit of the comments and assume this is no longer an issue. However, I do wish to post how I fixed on mine in case it wasn't already posted and people are still having this issue. 
    I had this issue this morning after having connected once prior. 

    Ok so I connected, prompt came up on Go, I accepted, all good.

    I activated developer mode and tried to connect to no avail.

    I deleted the driver, turned off Developer on app. restarted Go, left it connected to the computer. On startup it reinstalled the drivers, still no prompt in Go. 
    I then unplugged the Go from the computer and re plugged it back in. In WINDOWS I told it to do nothing when this device was plugged in. I checked Go, and the prompt was now there. 

    Thank you prior comments for the fix. This is just a bump for anyone still having issues.
    Thank you and happy VR'ing!
  • peternrgpeternrg Posts: 17
    NerveGear
    I just received 4 new Oculus Go sets, and after the initial setup with the lastest OS updates, it seems that I can't connect to any of these devices....  Not via PC, and not via the Android File Transfer app on Mac.   The USB devices shows up in the list of usb devices, but they do not show up in the file managers, and there is also no prompt within the Oculus Gos...   It seems that the latest update broke file access again!    Anyone else experiencing this?
  • DKFDKF Posts: 1
    NerveGear
    VMC said:
    I found this workaround that works pretty consistently for me:
    1. In the Oculus app on your phone go to Settings
    2. Select Oculus Go XXXXXXXXXXXXXXX (serial number)
    3. Select More Settings
    4. Select Developer Mode
    5. Toggle Developer Mode Off (Windows Explorer should now see your Oculus Go, but you won't be able to navigate any folders)
    6. Toggle Developer Mode On (Windows Explorer will no longer see your Oculus Go)
    7. Put on your Oculus Go and accept the device connection confirmation (Windows Explorer should see your Oculus Go again, and you'll be able to navigate folders).
    So it appears that somewhere between Windows 10 and the Oculus Go, when the Go is disconnected or powered off, the Developer Mode authentication is forgotten and needs to be reconnected. Not sure if this is a feature or a bug, but it is confusing.
    Hope this helps others.

    Thanks, had the same problem and have done this workaround and now it's working this way...
    I've to this all the time now when I want to connect via USB, the authentication should remain forever or until we disabled.
    They should fix this "feature"... Thanks VMC the workaround works meanwhile.
  • sadxspamsadxspam Posts: 1
    NerveGear
    Is this still an issue for some people??? I've had to revert my headset back to factory settings like five times over the past month in order for the headset to recognize that it's plugged into a computer and give me the "allow connection?" prompt... How has this not been fixed yet???
  • oculus128oculus128 Posts: 1
    NerveGear
    Some usb cables won't work, I would suggest trying a different one.
  • juani.pinxeljuani.pinxel Posts: 1
    NerveGear
    HI GUYS! maybe some people had the same problem as me, and it was I couldn't get to authorize my headset so I could install my apk at all. What was stopping me was that my pc had a key from another headset installed in the registry, with this instructions i got to fix it, deleting it and letting the adb to create the new one for the different headset: http://martint86.github.io/refresh-adb-keys/
    I hope this help all of you, since I've been a long quantity of time trying to solve this, and I don't want anyone to be in this situation EVER lol, cheers, Juani


  • TrejkazTrejkaz Posts: 2
    NerveGear
    I had the same problem and factory reset didn't even work. So at this point it seems like it's impossible to get the data off using my PC.

    It does work using the Mac though, with the exact same cable. Go figure.
  • philiplhphiliplh Posts: 1
    NerveGear
    I am having a slightly different problem. When I plug my oculus go into the computer I get an empty headset folder as I should and I get a screen in the oculus asking me to accept access to the pc. all good so far, but as soon as I accept access the folder disappears on the PC so I have no access to any files on the oculus go.
Sign In or Register to comment.