New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

android file transfer fails oculus go not showing up or prompting

hairycoconut25hairycoconut25 Posts: 2
NerveGear
 i followed your instructions exactly on downloading android file transfer to move files from my two of my macs ( macbook air and macbook pro) to the oculus go.

[To transfer photos and videos from your computer to your Oculus Go headset:

  1. Connect the included USB 2.0 cable to your computer and Oculus Go headset.
  2. Put on your headset and select to confirm you want to allow the computer access files on the headset, in VR.
    • On Windows, Oculus Go will automatically appear as a drive on your computer.
    • On Mac, you'll need to install Android File Transfer to successfully transfer files between your Oculus go and computer.
  3. Click and drag files to and from your Oculus Go headset on your computer.]

Even after I plug in the usb from the Oculus to go my mac, the Android file transfer program says "no android device found. please connect your android device with a usb cable to get started." there is no prompt inside the headset that asks me to allow the connection. I also connected my oculus go to my PC running windows 10 and it doesn't show up either or ask for a prompt. Any recommendations? i tried this with two different oculus go and there is never a prompt inside the headset asking to allow the connection.  Developer mode is enabled via the oculus app.  my macbooks both run high sierra.

Please help.  thanks.  

Comments

  • rogerawongrogerawong Posts: 9
    NerveGear
    Are you using the USB cable that came with the Oculus Go, or are you using a different cable?  Some USB cables are only for charging and can't carry data. Or, sometimes they can damaged.

    Try a different cable.
  • hairycoconut25hairycoconut25 Posts: 2
    NerveGear
    hi.  i am using the USB cable that came with my Oculus Go.  i also tried other USB cables and they didn't work either.  
  • FutureTronFutureTron Posts: 10
    NerveGear
    hi.  i am using the USB cable that came with my Oculus Go.  i also tried other USB cables and they didn't work either.  
    Tried to side load a movie I bought from iTunes. After multiple attempts of unplugging/plugging/granting access, was able to copy-drag the 5GB movie file to the Movies folder on my Go in the Android File app. When I visit the Go’s Gallery, where I’m guessing the movie should be, it said I had nothing there. There was no confirmation screen or progress bar when I did the transfer. The file appeared too quickly in the Movies folder, even though I gave it plenty of time to transfer too. Perhaps it’s an iTunes DRM issue? In any event, it seems like more trouble than it’s worth. I’m either going to try with Plex (also seems like more work) or wait until Vudu or Movies Anywhere launches a native Go app. That’ll solve my problem if those platforms launch apps.  Haven’t tried Vudu in the web browser. Maybe that’ll work. I don’t know. 

  • peternrgpeternrg Posts: 9
    NerveGear
    Did you get this working?   Android file transfer (on MacOS) worked until today: No Android device found.  Using same USB cable as before.   Is there any preset I have to reset?


  • YerbaBuenaVRYerbaBuenaVR Posts: 5
    NerveGear
    edited May 18
    We're facing this issue as well now. Maybe it was some sort of update that broke this? Observed en 3 different Win10 machines
  • YerbaBuenaVRYerbaBuenaVR Posts: 5
    NerveGear
    Update from our end, inspired (although not quite following) by this other thread  ,we tried setting dev mode off and restart the Go, after reboot, file transfer was working again

    it seems like some sort of bug with the driver when the device is in dev mode
  • SamyannSamyann Posts: 7
    NerveGear
    I’ve a 64 Go and have a Mac. The Android file transfer is fine. The unit is showing 17gb of space left. But, I cannot see how the unit has used so much space. Which directory contains the actual game files, so I know which ones are using all the space? Is there some setting to allow this view?
  • talkingdogtalkingdog Posts: 2
    NerveGear
    We've experienced this problem as well. When dev mode is on you can't connect to Android File Transfer.  It's annoying to have to go back and forth between settings to do various testing.
  • chettawanchettawan Posts: 76
    Hiro Protagonist
    I plug OG to my Chromebook last night and can transfer file flawlessly.
  • hurriedvolehurriedvole Posts: 1
    NerveGear

    Installing ADB on a Mac allowed me to use Android File Transfer in developer mode. With homebrew:

    brew install android-platform-tools
  • GadgetChannelGadgetChannel Posts: 9
    NerveGear
    File transfer should still work when Developer Mode is enabled, but you need to activate it in a different way. You need to run the "adb devices" command from the Terminal to ensure that the adb daemon is running (and trust the computer for debugging from the Oculus Go if you haven't already). This actually has an advantage over enabling file transfer without Developer mode, as you can permanently trust a particular computer so you don't get a prompt every time you connect it.
  • TimeScienceTimeScience Posts: 17
    NerveGear
    Also note that the Go has the annoying habit of turning off immediately as soon as you take it off, which seems to drop the USB connection. This is very confusing, because if you click ok to file transfer in the headset and then take it off to switch to your pc, the connection drops immediately giving the impression the connection failed. If you leave it on your head after you ok the file connection, the headset will remain in your browser on windows.
  • cyberealitycybereality Posts: 25,400 Oculus Staff
    That doesn't sound right. As long as the USB cable stays connected, it should not matter if you remove the headset from your face. It does not turn off, simple goes into a stand-by mode.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.