New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

[SOLVED] Charging Light Will not Turn On, No Response to On Button - Oculus Go

cslivacsliva Posts: 3
NerveGear
edited May 2018 in Support

Just got my new headset, used it for about 15-20 mins and then plugged it in to charge while heading out for the night (charging light was on).

Came home last night and the charging light was off, with the power button not responding to anything.

Tested the Charger and Micro USB with other devices, which all charge other devices, just not the Oculus GO.

Any thoughts, ideas, tips here?

Thanks!

Comments

  • LZoltowskiLZoltowski Posts: 6,617 Volunteer Moderator
    This sounds like a hardware issue, please contact Oculus Support through a support ticket and they will be able to assist you.
    https://tickets.oculusvr.com/hc/en-us/requests/new
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • cslivacsliva Posts: 3
    NerveGear
    Thanks! Have a Ticket Open (545782), but cross posted here to see if there was a quick fix, or if I just got a bad unit.

    Connor
  • cslivacsliva Posts: 3
    NerveGear
    Boom. That did it. Thanks! @geebee666
  • LZoltowskiLZoltowski Posts: 6,617 Volunteer Moderator
    edited May 2018
    Awesome, I'm going to add [SOLVED] to the tile to help others if they have the same issue.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Rajesh.PradhanRajesh.Pradhan Posts: 1
    NerveGear
    I'm facing the same issue. Hold power button 20 second didn't work for me.
    Any other solution which i can try. 
  • TomCgcmfcTomCgcmfc Posts: 690
    Neo
    Maybe try doing the same (20-30 sec) with the battery charger connected.  You may have let your battery levels get too low.  Otherwise, start a support ticket and I'm sure this will get sorted out.
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!

    Also have a 64gb Oculus Go which I love for travel and quick VR Fixes.  Looking forward to the Quest!
  • uziizuuziizu Posts: 2
    NerveGear
    My Oculus Go doesn’t charge at all. No LEDs on. I have tried 4 different USB cables and Chargers.
  • stef07stef07 Posts: 3
    NerveGear
    Same here, 2 month old Go.  It shut down after second battery warning (battery level very low) as it should and had many times before, but now all of a sudden no lights when I plug in the charger. Tried the 20/30 second power button thingy, no luck. 
  • paridionblueparidionblue Posts: 3
    NerveGear
    My Oculas go will not charge or turn on, orange light blinks sometimes....
    The battery was dead, so the device shut down, now it won't boot up, or even charge. I know others are having the same issue, but it seems as though no solution was given, what's happening? can you help me?
  • OcuNerd_666OcuNerd_666 Posts: 1
    NerveGear
    Just to add to the solutions, pressing the power and volume down buttons simultaneously and then choosing restart worked for me. 
  • hei.t.gaohei.t.gao Posts: 1
    NerveGear
    Oculus go reseted is not working.  won't turn on .help!
  • julien.champagne.35julien.champagne.35 Posts: 1
    NerveGear
    I always have the loading logo ! I try to restart it but it comes back!
  • JamesthechipmunkJamesthechipmunk Posts: 1
    NerveGear
    Hey, I was playing my oculus for too long I guess and it died. So I charged it waited 20-30 minutes. Then I tried to turn it on, it didn't work. So I plugged in the charger tried to turn it on, it didn't really turn on, the oculus logo popped up for a few seconds and then it went black. I've tried all the solutions on here, but I just can't turn it on

  • Postmoderno2Postmoderno2 Posts: 1
    NerveGear
    edited January 8
    Hi all , 
    Same issue here , it looks like to me like some missbehabiour with the internet connection/oculus go android app.
    I delete from android app the internet connection and start the oculus go.


  • Alicia_WonderlandAlicia_Wonderland Posts: 4
    NerveGear
    edited January 16
    Mine has stopped charging too. But sometimes I get a red light, sometimes flashing, sometimes solid, instead of the orange light but it’s not charging. Amazon is replacing it luckily because it’s still within 30 days of purchase. This is really bad that there are so many faulty units! 
  • curtis.r.heltoncurtis.r.helton Posts: 1
    NerveGear
    csliva said:

    Just got my new headset, used it for about 15-20 mins and then plugged it in to charge while heading out for the night (charging light was on).

    Came home last night and the charging light was off, with the power button not responding to anything.

    Tested the Charger and Micro USB with other devices, which all charge other devices, just not the Oculus GO.

    Any thoughts, ideas, tips here?

    Thanks!

    I was having the same issue. No charging, just a blinking red light. Then the light would stop, and nothing. So, I unplugged it and plugged it back in. While the light is still blinking, I held down the power button. Next thing I know, the light turns solid orange, and it started charging! I hope this works for you! I've only had mine 2 weeks. I hope this isn't a consistent issue. The lesson that I learned, part attention to the battery warning. Don't let it die while you're using it.
  • simon.pilkingtonsimon.pilkington Posts: 1
    NerveGear
    I have the same issue. Won't turn on again no matter what length/combination of button presses and charger attachement.
  • enjoyit360bcnenjoyit360bcn Posts: 1
    NerveGear
    20 sec solve to me.
Sign In or Register to comment.