Oculus setup installation failing - No common solutions have worked — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus setup installation failing - No common solutions have worked

kcarbonekcarbone Posts: 3
NerveGear
Hi all, 

So I've been trying to get Oculus setup to run successfully for the better part of a day now. Most of that time was spent waiting for it to re-download the setup files which I've done countless times. I've scoured google/the forums here and tried literally every solution I could find. Including, but not limited to:
  • Uninstalling/deleting everything related to previous setup attempts (files, registry settings, etc)
  • Completely disabling Windows Defender (I have no other antivirus on this system)
  • Disabling Windows Firewall
  • Disabling everything that isn't absolutely necessary for windows to run
  • Uninstalling/reinstalling every version of the .NET distributable runtime I know of
  • Uninstalling/reinstalling DirectX
  • Moving the installer exe to C:\ and running it from there
  • Running the installer as adminstrator
  • Not running the installer as administrator
  • Creating a brand new local admin account and running it from there
Each time, I've completely deleted the setup file cache and checked the OculusSetup log to see what went wrong. I've attached the latest one here. The error varies but it usually has something to do with a file being "missing or invalid". This latest one I've gotten several times now:
[Error] [5/19/2018 2:03:22 PM] File 'Home2\Content\Paks\Home2-WindowsNoEditor.pak' is missing or invalid.
[Error] [5/19/2018 2:03:22 PM] Uncaught exception!
Daybreak.OVRLibraryService.Libraries.LibrarianException: Package oculus-worlds failed verification
   at Dawn.Setup.InstallChunkedPackagesStep.InstallApplication(Nullable`1 transaction, Application app, CancellationToken cancellationToken, String installDirectory, String manifestDirectory, String downloadCache)
   at Dawn.Setup.InstallChunkedPackagesStep.InstallImpl()
   at Dawn.Mixins.SafeCallMixin(Func`1 func, String title, String caller)
[Debug] [5/19/2018 2:03:22 PM] Install 'Dawn.Setup.InstallChunkedPackagesStep' failed.
[Warning] [5/19/2018 2:03:22 PM] Rolling back installation.
At this point I'm completely out of ideas. Any thoughts or suggestions are appreciated. 

Answers

  • kcarbonekcarbone Posts: 3
    NerveGear
    Sorry, file attachment didn't work. See log here
  • SundaygloomSundaygloom Posts: 32
    Brain Burst
    I just went through this too. Same errors. My issue turned out to be a faulty ram stick. I had 2x8gb. I pulled the faulty one out and everything was fine after that. The windows memory check tested it fine, but then I ran memtest86 and it found the issue. 
    It might not be your issue but it's worth looking into. 
  • YoeyYutchYoeyYutch Posts: 13
    NerveGear
    In the Services, did you stop the "Windows Defender Firewall" services and disable it? That is what worked for me. It did not work to just stop the service, or to turn it off in the Security Center settings.  So if you haven't tried this I would definitely do so. Stop, disable, restart, install.
  • kcarbonekcarbone Posts: 3
    NerveGear
    Thanks for the suggestions. Unfortunately still no luck. I ran memtest86 and got a 100% clean result. And my "Windows Defender" has been disabled at the local policy level. It won't even start if I try to start it manually. 

    I also noticed that sometimes the error is about a file being "currently in use by another process". Not sure if there's some weird multithreading thing going on... I definitely only start the installer once (after a fresh boot). 
  • oldie2018oldie2018 Posts: 7
    NerveGear
    to get oculus software to fully install go to windows defender and turn off windows defender firewall notifications also real time protection and cloud delivered protection and automatic sample submission and most important one of all controlled folder access oculus will 100% install now unless you have other virus software then disable them first
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    edited May 2018
    Have you tried the Runtime 1.3 SSE4.2 Hack Setup? It is the only one which works for me being a Xeon Quad Duo 3GHz.
    2nd post in first dropbox here: -
    https://www.reddit.com/r/oculus/comments/4qjmju/installer_hack_bypassing_sse_42_support_on_dk2/
    Don't install as Run As Admin but do switch off Windows Defender and keep on Firewall.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    That looks like file corruption to me. Which means either something is wrong with your network connection, or on the system (I've heard of this before with failing RAM). You may want to try a different internet connection (such as with a phone hotspot) or swapping out RAM sticks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    Yes on SSD/HDD drives we can get many corruptions which don't get repaired nor even picked up on even with drive checking. Best right now to have a fresh clean install of WIN10.
  • bazookhajoebazookhajoe Posts: 2
    NerveGear
    Uninstall the app.  Go to setting.  Go to all app.  And uninstall anything that has to do with occulus.  There's a few like 6 or so.  Unsinstall them.  Then put ur phone back into the vr and follow the instruction.  Ta.  Dah
      
Sign In or Register to comment.