New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

I was having a problem with downloads so I tried to run the repair Oculus program. Now I'm stuck

ShreddedzombieShreddedzombie Posts: 2
NerveGear
My Oculus downloads froze and I read online that repairing Oculus could help remove the issue. After waiting a day for it to repair (Bad internet) it said that the repair errored and that I should try again. Now when I launch the Oculus setup, it just tries to install it new instead of repairing and says that it needs 15g of storage to install. I don't have enough space since oculus IS installed and is taking up that space. I tried removing enough files but could only get 7g free without deleting my system files basically. Is there any way to tell oculus that it is already installed and to repair itself again rather than try to install from scratch? I'm very stuck. Any help would be appreciated! Thank you

Comments

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    If the repair fails or is cancelled early, it may leave the install in an incomplete state. In which case, you probably have to full uninstall and then install fresh. It sounds like free hard drive space may be an issue. You will need about 40GB free on your Oculus drive and 120GB free on the game drive in order to install. Try to free up space or install on a drive when enough space.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JD-UKJD-UK Posts: 2,357 Valuable Player
    Something similar happened to me, but in my case I simply cancelled the repair because I hadn't realised it was going to download the 5+GB and didn't have time for that (Oculus note: warn users first!). I ran the installer on my next session intending to run repair, but it didn't even recognise my Oculus installation (so the repair option was gone).

    So I simply ran the installer, making sure I pointed it at the previous install folder and let it install over the top of the previous version.

    After installing, it listed every game and app I had installed via Home as needing an update. This also passed off without issue and when it had finished everything was okay again.




  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    If you get it working there is an easy way to get back all installed games by deleting/renaming a file in AppData and means no downloads. It's the _oaf file.
  • ShreddedzombieShreddedzombie Posts: 2
    NerveGear
    Thanks for the replies! So I'm probably going to try to do a complete uninstall and re-install since my games directory is on another drive so I don't have to back it up. The only problem is that the uninstaller disappeared. Should I just delete the Oculus folder in the program files and then just run the installer again? It would clear up just the right amount of space to run the installer after deleting the Oculus folder. Thanks for all the help!
  • JD-UKJD-UK Posts: 2,357 Valuable Player
    I would just run the installer and point it to the same place you did on the original install - but that's me, I'm a daredevil! B)




Sign In or Register to comment.