Touch Controllers not working — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Touch Controllers not working

AwesomeFury21AwesomeFury21 Posts: 1
NerveGear
Recently I've started experiencing an issue where my touch controllers aren't showing up in game or in Oculus Home. In the Oculus app, under devices, it shows both right and left as being off, even after turning the controllers on. Both controllers were working fine yesterday. I tried replacing the batteries, though that doesn't seem like it is the problem since I replaced the one in the left touch only 2 days ago. There may be an issue with the inner workings of the controllers, although it seems unlikely that both would break at the same time. The problem may also lie in the sensors, though they are detecting the headset just fine. Those three seem like the only possibilities I can think of. All in all, I'm just baffled, especially considering that I have not been able to find anybody experiencing the same as I am. If anyone could let me know if they have had a similar issue, or if they know a solution or a thread where I can find on, that would be great. (Btw it wouldn't let me select support as the category so I just chose General)

Comments

  • Techy111Techy111 Posts: 6,263 Volunteer Moderator
    Have you tried running the full setup again mate ?
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.

  • BrokenSymmetryBrokenSymmetry Posts: 250
    Nexus 6
    Try pressing A and the Oculus button together. Hold them until the indicator on your touch controller blinks. If that helped, do so with the X and the Menu button on the other controller. Good luck.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    I would try a Oculus repair install. Download the Oculus setup installer again and choose Repair. You can also go through the full setup again in Settings -> Devices -> Configure Rift -> Full Setup. Otherwise, please submit a support ticket, thanks. https://support.oculus.com/
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • TheSilverDukeTheSilverDuke Posts: 2
    NerveGear
    I fixed this same issue by removing the controller batteries, waiting a few seconds then reinserting them. Controllers must have crashed somehow.
Sign In or Register to comment.