New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Realtek audio in Oculus Desktop continually gets higher in pitch

Firestorm185Firestorm185 Posts: 78
Hiro Protagonist
edited July 2018 in Oculus Rift + Touch
Hi Oculus team! I just wanted to post a bug here I've been experiencing ever since Home 2.0 came out with Dash and Oculus Desktop. Once I was able to display my screen in my Rift I obviously tried right away to play some music in the background, however when I started it (youtube, soundcloud, vlcmediaplayer) they all started instantly getting higher in pitch as the songs went, to the point where I kept having to shut the screens down. I have Realtek HD audio on my PC, which is pretty standard, so I'm not quite sure what's going on. If I set Oculus as the default device, then the sounds from my desktop come through just fine, but I can't hear those sounds in my desktop's speakers anymore, so I know it's probably some problem between the sound drivers and Dash, I'm just not sure how to fix it. Thx!
------------------------------
PC specs - GTX 1070 (MSI AERO); 16GB Corsair Vengeance DDR3; intel i5-4590, MSI motherboard (don't remember but it was a combo deal) and an EVGA Supernova 750W semi-modular.

Comments

  • nroskonrosko Posts: 922
    Neo
    sound like maybe an issue with sample rate, is your realtek in 44hz? 
  • Firestorm185Firestorm185 Posts: 78
    Hiro Protagonist
    I had it at the highest audio setting, does Desktop only support the lowest? (which is what 44 shows up as in my settings)
    ------------------------------
    PC specs - GTX 1070 (MSI AERO); 16GB Corsair Vengeance DDR3; intel i5-4590, MSI motherboard (don't remember but it was a combo deal) and an EVGA Supernova 750W semi-modular.
  • IlIfadeIlIIlIfadeIlI Posts: 28
    Brain Burst
    Think it has to be 16 bits 44hz.  Another solution is to use the audio switcher with oculus tray tool to set rift audio as default while using oculus or you can do that manually each time.  I use OTT as I don't want to lower the audio quality and find it useless to hear the audio on my pc speakers while on the rift.
  • Firestorm185Firestorm185 Posts: 78
    Hiro Protagonist
    Yeah, I'm not sure, I've tried it at that setting too and it still doesn't work right. Maybe I need to restart my pc after changing that setting...
    ------------------------------
    PC specs - GTX 1070 (MSI AERO); 16GB Corsair Vengeance DDR3; intel i5-4590, MSI motherboard (don't remember but it was a combo deal) and an EVGA Supernova 750W semi-modular.
  • elliotgraythoelliotgraytho Posts: 4
    NerveGear
    Hey Rave did you ever find a solution to this?  I have the same issue with my creative sound card.
  • LZoltowskiLZoltowski Posts: 6,535 Volunteer Moderator
    Hey Rave did you ever find a solution to this?  I have the same issue with my creative sound card.
    Hey, when you tried it before, did you restart your machine after changing the bit rate?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Firestorm185Firestorm185 Posts: 78
    Hiro Protagonist
    I believe I did, still with no luck. the best solution I've found so far is to enable stereo mode in Windows and then set the stereo device to be the Rift, but then it plays ALL windows sounds, whether I'm in game or not.
    ------------------------------
    PC specs - GTX 1070 (MSI AERO); 16GB Corsair Vengeance DDR3; intel i5-4590, MSI motherboard (don't remember but it was a combo deal) and an EVGA Supernova 750W semi-modular.
  • nroskonrosko Posts: 922
    Neo
    Bit rate shouldn't affect anything, sample rate will affect the pitch though. It should be set to 44hz in windows. The only time really to have it higher is for playing wave files that are higher than 44hz. 
Sign In or Register to comment.