New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Oculus Go ADB

devin.garcia.988373devin.garcia.988373 Posts: 2
NerveGear
Hi everyone I'm a bit new to the scene here but I keep running into an issue with the Oculus Go. I'm trying to use adb on the oculus from my windows computer but when I run the command "adb devices" no device at all shows up and I know that it's supposed to show up with unauthorized next to it. I've used the 2.0 drivers and samsung ones too (which apparently is supposed to be a fix) but it still won't work. Also worth noting is that whenever I turn on developer settings from my phone the Oculus Go will continue showing storage on my computer but if I take out the usb and plug it back in or if I turn off and turn on the Oculus Go the storage won't show up but in device manager it will show up under oculus devices. I've spent 2 days trying to find results online but no one seems to have a solution that worked or even came to a conclusion. Also I don't know if it was bad but I made a discussion post instead? Hopefully that was't anything too bad

Answers

  • cyberealitycybereality Posts: 26,101 Oculus Staff
    Can you try a different USB cable? Can you remove your lock pattern?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • devin.garcia.988373devin.garcia.988373 Posts: 2
    NerveGear
    edited July 20
    cybereality said:
    Can you try a different USB cable? Can you remove your lock pattern?
    I can try a different usb cable although it works with my phone whenever I turn on usb debugging and I don't have pattern lock on
    Just tried a different cable, it didn't work
  • NormarkNormark Posts: 10
    NerveGear
    I had the same problem. The Oculus Go device will bee seen from the PC when it it not in dev mode, but when you switch to developer mode it doesn´t.
    I solved it by installing the Oculus Go drivers for windows on the PC. ( seems it doesn´t need the drivers when the Go is not in developer mode, but then you can´t sideload anything to the device)
    The drivers can be downloaded from Oculus. I had to manually install the drivers.
    Drivers can be downloaded here: https://developer.oculus.com/downloads/package/oculus-go-adb-drivers/


Sign In or Register to comment.