New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Need your help. Support are not doing a good job. No Mic in Elite:Dangerous

MAC_MAN86MAC_MAN86 Posts: 975
Neo
edited August 9 in Support
I have had no use of my mic within Elite:Dangerous since mid April.
OK so I use the SSE4.2 hack to allow my Xeon to "Install" Oculus Runtime as it nor any game except LONE ECHO uses those extra commands but that game even has it's own SSE4.2 check anyways so we are being forced to buy new systems and waste what works very well already!
My mic shows it's meter readings in settings and can provide Listen To This Device as a foldback to check it AND works in all other games in VR.
It went off after I had been using the Run As Admin method for OculusVR.exe to bypass Home which I gather no longer works which did make the fps feel like reality!
I performed a fresh OS install using USB Media Tool back in April and it worked but Steam had my Mic & Soundcard wrong way around by id.
I tried fresh OS again without any USB devices attached (still with cards inside) and around this time it was getting the Win1803 update plus the May Update to that.
I tried another 4 OS installs and this last one was with my cards removed as well as USB and I just want to clear up the state of this fresh install. Elite is also deleted again from my 2nd drive to clear any connection to previous installs. A new install of that had failed to get the mic to work plus installing the desktop version on the C: drive failed it too.

So due to Oculus Support just doing as little as they can (as ever!) I do not want cue cards to check simple things and then hear "check your Oculus on a compatible computer" when I know for a fact this should be working as it did prior the April updates to both Windows and Oculus.
By the way it is NOT the easy fix of checking Allow Access to Mic in Privacy Settings and I have no Special Effects added in audio settings.



1. What I need to check from you please is are these pics the same as yours right now?

Users have managed to get theirs to work again by simply selecting 44.1Hz in the drop down menu for their mic. Mine is greyed out. I installed OS fresh with no cards/cables attached. Rebooted with HMD via HMDI>DisplayPort adapter (only way VR works for me) attached & Oculus USB which is found once running Oculus Setup. Moving the USB to other slots does no different. This looks like it could be asking Elite:Dangerous too high definition to be able to send! Or would disabling UPNP be the trick?



2. Is this the same as yours in Devices>Sound>Rift Audio>Driver? (It seems obviously old to me! I did not complete a Setup within the Home installation yet)




3. Is this the same as yours in Devices>Audio In/Out>Microphone (Rift)>Driver?




4. Is this the same as yours in Devices>USB Controllers>(Windows default Renesas for StarTech USB3 card) however the other motherboard USB2 do not change the drop down menu for Rift Mic either.




5. Is this the same as yours in DXdiag which the OCULUS119B.SYS is not digitally signed?




If I run the Oculus Driver again it will force a new ID for the Rift and VoiceAttack reports it so I had wondered if any Firmware Updates had done similar which Elite had not been programmed to find by name, however I am now trying Elite again on this last fresh install and re-download and with only the Rift connected which has just had latest 1.29 Firmware yesterday before this.

(so right now I have not changed Rift ID as is seen above in DXdiag)
Thank you!

Comments

  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    I am wondering if my Elite Audio buffer settings need increased. They added a method to edit this at the trade off for performance. I will test.

  • KNP54KNP54 Posts: 215
    Art3mis
    It might be or not related, but a long time ago, I had no sound in Oculus Headphones and I fixed it by selecting CD-Quality (44.1KHz) instead of the default DVD Quality (48KHz). Might be worth a try. (Set in your first screenshot)
  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    edited August 10
    KNP54 said:
    It might be or not related, but a long time ago, I had no sound in Oculus Headphones and I fixed it by selecting CD-Quality (44.1KHz) instead of the default DVD Quality (48KHz). Might be worth a try. (Set in your first screenshot)
    This is my problem as you see it is greyed out. It's as though it hasn't got an updated Driver or is not properly installed due to a Windows Update. Oculus Support are hopeless!
  • kojackkojack Posts: 4,533 Volunteer Moderator
    I have never tried using the rift mic in Elite, so no idea if it works for me. But there's a couple of differences in your settings to mine.
    I also can't change the format, it's greyed out, so the same there.
    My rift audio Digital Signer is "Microsoft Windows Hardware Compatibility Publisher". Yours is C-MEDIA ELECTRONICS INC."
    My DXDIAG WHQLLogo'd is yes, yours is no.
    My DXDIAG Notes is "No problems found". Yours is the thing about not being signed.
    Otherwise all of the driver dates and versions match mine.

    (Didn't look at the usb controller, since I don't have a startech car, I'm using my motherboard's controller (Taichi Threadripper board).


    The Rift uses the C-Media CM119BN audio chip.
    Interesting that your driver is signed by C-Media but mine isn't (and I don't get dxdiag complain about the signing).




  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    Thanks @kojack, I think I need access to the supported Driver which is not the one in my package.
    As I noted that any re-run of Driver Setup will alter the ID then any software may again be best installed again too which uses it outside of MS Apps.
  • cyberealitycybereality Posts: 25,862 Oculus Staff
    Mine says it's using Microsoft drivers.


    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • kojackkojack Posts: 4,533 Volunteer Moderator
    That's the headphone properties (different to the ones Mac showed above).
    Mine for that is also signed by Microsoft Windows, but it's version 10.0.17134.1 dated 11/04/2018.

  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    edited August 10
    I am on the verge of solving this issue now. It has worked with 2 players tonight for long periods but did struggle keeping connections to 2 Crew yet did allow 3 of us to communicate briefly.
    I am running my PC with the bare bones system (no added cards/USB devices). I now gather to perform a fresh install these must all be removed prior to avoid any conflicts.
    I made my Virtual Memory 1.5x my 16GB RAM so it is set at 24GB although I actually think this is not the issue.
    I used to run Oculus Debug Tool SS=2 prior April but I believe the figure was not real (there was no way the in game SS could get anywhere near x2) The real figures were around 1.5x but Oculus has become more demanding with updates. Although I can run Elite at 1.5x it will add some audio pops in stations slightly and not be so smooth as 1.4x runs. It could be that the PC can not cope to adding the mic (be it 48k or whatever it really is) at these high SuperSampling figures. It seemed to work ok at 1.25x in Oculus Debug Tool for those that could connect long enough due to the bad instancing in Multi-Crew.

    Another point I noticed was Skype is pre-installed and it popped up a Notification that it was "alive" during the time a player crashed out. I had not setup any account and Windows sets one up automatically for you using your email. Skype has problems closing down fully as it runs in the background even if you switch it not to! The only way to stop these programs hogging your mic is to use the Terminate button in Apps&Features>(app)>Uninstall>Advanced>Terminate. I think this could also be part to blame. And yes all MS Apps were switched to OFF for Mic Access in Privacy Settings already.

    Also I did not need to set VoiceAttack to Run As Admin as it suggests in case it does not respond. Doing this would possibly lower the chances of the mic working by a priority. Which is also possibly similar to maybe requiring unselect Allow Applications To Take Exclusive Control Of This Device in the Rift's mic setting. For me I had no luck here as it seems my PC was already bottlenecking to work the mic in Elite anyways. Obviously any Special Effects you add will up the memory for the mic too.

    It's all adding up to the available RAM and why in Elite? Because that's the only game I personally choose my own SS using Oculus Debug Tool.

    Do any of you set Virtual RAM to anything other than Allow PC to Manage?

    Another thing I wonder about is I only just started using a T16000 + TWCS HOTAS for a week, I haven't had it working to allow the mic on the throttle's middle joystick up (button 7) binding but did work as mentioned on button 2 (my pinky). I have not installed any Thrustmaster software just the drivers in Windows. Also no buttons can be triggered into VoiceAttack binds oddly. Any ideas on these?
  • kojackkojack Posts: 4,533 Volunteer Moderator
    MAC_MAN86 said:

    I used to run Oculus Debug Tool SS=2 prior April but I believe the figure was not real (there was no way the in game SS could get anywhere near x2) The real figures were around 1.5x but Oculus has become more demanding with updates.
    I think I've worked out what this is. The Debug Tool has changed it's meaning.

    Pixel Density probably confused a lot of people. They think 1 means panel resolution (1080x1200 per eye) and 2 means double that (2160x2400). That's what super sampling in a normal game would do. But on the rift pixel density is the ratio of texels to pixels in the centre of your eye when viewed through the lens. (Texel is a texture element, it's what's rendered by the game and given to the oculus sdk. Pixel is the dot on the panel you see). So 2 means there's two rendered texels for each visible pixel, but only in the centre of the lens. To achieve that you need a way higher res. 2 actually requires around 2688x3200 per eye, and 1 is 1344x1600. We need higher res to counteract the distortion effect. Native panel res is actually around 0.82 (which distortion will make look worse than native).
    A normal game renders at monitor resolution. A VR game should never render at CV1 resolution, they need 1.25x that to counteract the lenses. (The DK1 needed about 1.7x, DK2 was about 1.5x).

    Now how these numbers are used: Oculus sdk has a function called ovr_GetFovTextureSize. You tell it the pixel density you want and it tells you the resolution to use. You can ignore it or never call it, pixel density can't be forced on a game that ignores it. What the Debug Tool did was force the ovr_GetFovTextureSize function to ignore what the game says it wants and use your number for density instead when it calculates the texture size required. It's not a multiplier, it just overwrites the value.

    BUT, checking now, the Debug Tool has changed the meaning. In the past if you set 2 it made the density 2 (2688x3200). But now if you set it to 2, it makes the density 1.6, which is results in roughly 2 times the panel resolution, NOT a pixel density of 2 like before.

    The ovr_GetFovTextureSize is still the same. I have my one C++ vr demo from over a year ago, it sets 2 for the density and gets 2688x3200. Elite Dangerous has it's own built in density you should be using (don't use the debug tool), it also correctly uses density of 2 if you set 2. It's just the debug tool that is changing the meaning from the true value to a friendlier value.



    Long story short: Putting a density of 2 in the debug tool now is the same as putting 1.6 in the tool in the past. You now need to put 2.5 in the tool to get what the old version called 2.

    But as I said above, just let Elite do it. In the quality settings there's an option of HMD Image Quality with options up to 2. That does the same as the old debug tool. Don't use the super sampling option in there, that's different (for non-vr people).





  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    edited August 11
    Spot on. The early Elite HMD SS was inferior to ODT and many opted for it instead.
    I had kept up with the ODT updates and one around Home 1.24(?) had to use another ODT update too as the previous version would not run with it. Following on from this they added a very large blank area to its window which I hated and the task memory was getting bigger. So I reverted to using ODT 1.13 which is much smaller and helped improve performance as much as bypassing Home was. Although can anyone confirm that method RUN AS ADMIN (OculusVR.exe) still works? So I really should have been using SS in ODT=1.25 to be safe OR just use the ingame HMD as you suggest. 

    I'll do more mic checking soon. Any word on the Virtual Memory size or Joystick Throttle binds for mic?
  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    edited August 12
    Testing completed and only using the ingame HMD SS at even 1.5x works fine to all wings. Even if the older ODT 1.13 can work at lower numbers fine it does take up resources too. I haven't tried the latest ODT which substitutes higher figures but I don't need it.
    Many thanks for this @kojack !!!
    I now know my other button on the Throttle can also work as I prefer to Push Talk with my thumb.
  • MAC_MAN86MAC_MAN86 Posts: 975
    Neo
    OK that was not my issue with the mic. Instead it was a Music Recording Studio card I had and it's WDM driver takes all available streams due to it not being continued after Win7 Drivers. I solved this by simply Disabling the Driver for WDM which does not interfere with my recording audio via the external audio box. Happy to be able to tell people NOT TO USE GUNNER once again.
    Why don't Frontier understand what players want - it's truly unforgivable not including a Gunner Role Switch!
Sign In or Register to comment.