S8+/Gear: When launching any VR shows a black screen then goes to settings — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

S8+/Gear: When launching any VR shows a black screen then goes to settings

rich.nevesrich.neves Posts: 1
NerveGear

I have an S8+ and Gear. It was working great for several months, then about 2 months ago when I tried to launch the SamsungVR app, it would crash. The phone also had issues with Bixby and Cloud Agent constantly stopping, but not wanting to do a reset at the time I just found a new app, MoonPlayer, which worked great until yesterday.

Yesterday I was having all kinds of problems with the phone sending text messages. Since I had time (and a current backup) I decided to do a factory reset. While that seems to have fixed the crashing CloudAgent and Bixby issue, it has brought about another one with the GearVR.

Whenever I put the phone in the Gear headset it brings up the home page like normal. But as soon as I click on anything (Samsung VR app, Samsung Gallery, any video presented on the home page, or MoonPlayer) that tries to launch a VR video the screen will go black for 1-2 seconds, the circle will appear as if you clicked the Home button, and then it goes to the Settings screen.

I have tried the following:

  • Another factory reset, but reinstalling all the apps instead of restoring from backup
  • Re-installing all the VR apps
  • Force stop Oculus Home and clear cache.

Here are the details of the phone:

  • Samsung Galaxy S8+
  • Android 8.0.0
  • Samsung experience: 9.0
  • Kernel Version: 4.4.78-12795462
  • GearVR Service v 2.9.30
  • GearVR System v1.6.02
  • Oculus Honme v3.48.16
  • GearVR Headset SM-R324 201703

Thanks in advance for any help y'all can give me to get this working again!

Answers

  • PAaltoPAalto Posts: 81 Oculus Start Member
    edited September 2018
    I have the exact same problem on Samsung Galaxy S6. It worked fine a couple of weeks ago, now suddenly this problem appeared.
    Edit: Ah, seems to be related to the Oculus Controller. When I removed a battery from it, and used a game pad instead, everything worked fine.
Sign In or Register to comment.