New to the forums? Click here to read the How To guide. -- Developers click here.

How do I disable autostart of Oculus software?

The autostart I am referring to is when you close the oculus program on your desktop and it instantly launches again. I have switched the services to manual via task manager and it worked until my PC was restarted. I doubled checked and they are still set to manual. Even stopping the programs via taskmanager they still relaunch! This should really be a setting in the oculus app and is one of the most stupid things I have even seen on a software. I should be able to close a program when not using. I am a Streamer and I don't want the extra drain on my PC. Oculus support if you see this please ask your devs to add this as a option in the settings to disable all autostarts. Thats why we have clickable shortcuts....

Power of the Beard Gaming
Mixer.com/daedric_angel
Tagged:

Answers

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    The Oculus app should stay closed. The service still runs in the background, but the app itself does not need to be running. If it is, something is wrong with your system somewhere. I would recommend downloading the Oculus setup installer and choosing Repair. Be sure to NOT run as administrator. 
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    v1.31 the exact same happening to me, this is after a complete uninstall and reinstall of the Software and nothing over the Rift HMD Sensor "thinking someones using it". The Home just starts up, I close it and it re-starts, this did not happen with v1.30.

    Yet another issue with v1.31....this list is growing
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    I have tried altering the Windows Services for Oculus to MANUAL instead of AUTOMATIC but this now gives an Error when trying to start the Oculus Software manually
    @cybereality Is this a known issue with v1.31 or would you/Oculus like yet another Support Ticket? FYI this is a complete fresh installation and another Repair doesn't fix it, I'm getting really fed up with this update as you can probably imagine! Thanks
  • TomCgcmfcTomCgcmfc Posts: 501
    Neo
    Mine only restarts if the headset is close by and I move it soon after closing it down.  If I remove my headset and move it off to the side like I normally do it stays off no problem.
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!

    Also have a 64gb Oculus Go which I love for travel and quick VR Fixes.  Looking forward to the Quest!
  • TaomynTaomyn Posts: 23
    Brain Burst
    As above, the only time it re-starts for me (except that time when one beta broke something) is when the headset thinks it's being worn and normally because the VR cover I have has moved slightly covering the sensor.
    ---
    AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | EVGA GTX980Ti ACX 2.0+ GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    edited October 12
    That's exactly what I was doing pre v1.31 and it remained "off", now it just auto-restarts every time and nothing I'm doing has changed.
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    I've had to resort to unplugging the HDMI cable!
  • LuluViBritanniaLuluViBritannia Posts: 371
    Trinity
    Hey guys,
    Go into : C:\Program Files\Oculus\Support\oculus-runtime (the location of the Oculus Service launcher).
    Make sure OVRServiceLauncher.exe is set to run as an administrator.
    Previous VR face :


    My current config : HP Omen laptop, 8 GB RAM, Intel i5-7300HQ @2.5GHz + Nvidia GTX 1050 (2GB VRAM).

    Currently plays on :

    - Beat Saber.
    - Windlands.
    - Skyrim VR.

    I use VR for :
    - Games.
    - Art Software (Tilt Brush, Oculus Medium, Mocu Mocu Dance).
    - Cinema VR (Oculus Desktop or Virtual Desktop).

    "You are allowed to kill only if you are prepared to die."
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    Hey guys,
    Go into : C:\Program Files\Oculus\Support\oculus-runtime (the location of the Oculus Service launcher).
    Make sure OVRServiceLauncher.exe is set to run as an administrator.
    Nope not difference for me, same issues as above :( tried changing the servics.msc to Manual again but it fails to load Oculus
  • LuluViBritanniaLuluViBritannia Posts: 371
    Trinity
    Bummer... What about oculus-driver.exe in an adjacent folder? Does it solve it if it is set as "run as admin"?
    Previous VR face :


    My current config : HP Omen laptop, 8 GB RAM, Intel i5-7300HQ @2.5GHz + Nvidia GTX 1050 (2GB VRAM).

    Currently plays on :

    - Beat Saber.
    - Windlands.
    - Skyrim VR.

    I use VR for :
    - Games.
    - Art Software (Tilt Brush, Oculus Medium, Mocu Mocu Dance).
    - Cinema VR (Oculus Desktop or Virtual Desktop).

    "You are allowed to kill only if you are prepared to die."
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    Bummer... What about oculus-driver.exe in an adjacent folder? Does it solve it if it is set as "run as admin"?
    Again same as before it still runs, changing to MANUAL in Services and I get the error about "We're having trouble..."
  • LZoltowskiLZoltowski Posts: 6,429 Volunteer Moderator
    OculusClinet.exe (desktop app Store/Sensor Config/Setup reset/Guardian Setup/Library)
    OVRServer (service) (core service related to tracking etc)
    Oculus Runtime Platform (core service related to runtimes)
    OculusDash (core service for interfacing with Oculus/Store/Home/Settings/Recentering/Volume adjustment while in VR)

    Are ESSENTIAL services and cannot be disabled. They all depend on each other, at the moment.

    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    OculusClinet.exe (desktop app Store/Sensor Config/Setup reset/Guardian Setup/Library)
    OVRServer (service) (core service related to tracking etc)
    Oculus Runtime Platform (core service related to runtimes)
    OculusDash (core service for interfacing with Oculus/Store/Home/Settings/Recentering/Volume adjustment while in VR)

    Are ESSENTIAL services and cannot be disabled. They all depend on each other, at the moment.

    I'm not trying to disable anything I just want to set the Programs as MANUAL so that Oculus Home starts when I want it too not when *it* wants it too, having to unplug the HDMI is not the solution to an ongoing issue that pre-v1.31 was working perfectly fine.
  • vr_marcovr_marco Posts: 37 Oculus Start Member
    edited October 13
    Marc-G said:
    OculusClinet.exe (desktop app Store/Sensor Config/Setup reset/Guardian Setup/Library)
    OVRServer (service) (core service related to tracking etc)
    Oculus Runtime Platform (core service related to runtimes)
    OculusDash (core service for interfacing with Oculus/Store/Home/Settings/Recentering/Volume adjustment while in VR)

    Are ESSENTIAL services and cannot be disabled. They all depend on each other, at the moment.

    I'm not trying to disable anything I just want to set the Programs as MANUAL so that Oculus Home starts when I want it too not when *it* wants it too, having to unplug the HDMI is not the solution to an ongoing issue that pre-v1.31 was working perfectly fine.
    Click on Windows, type "Services" + Enter, this opens the Services manager. Scroll down until you find Oculus Runtime VR Services, right click and choose Stop.
    This service has a startup of type Automatic. If you were to set it to Manual, no Oculus software will be loaded at startup. But then to use your Rift you will have to manually start this service. If need be, you can always create a batch (cmd) file for it.
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    vr_marco said:
    Marc-G said:
    OculusClinet.exe (desktop app Store/Sensor Config/Setup reset/Guardian Setup/Library)
    OVRServer (service) (core service related to tracking etc)
    Oculus Runtime Platform (core service related to runtimes)
    OculusDash (core service for interfacing with Oculus/Store/Home/Settings/Recentering/Volume adjustment while in VR)

    Are ESSENTIAL services and cannot be disabled. They all depend on each other, at the moment.

    I'm not trying to disable anything I just want to set the Programs as MANUAL so that Oculus Home starts when I want it too not when *it* wants it too, having to unplug the HDMI is not the solution to an ongoing issue that pre-v1.31 was working perfectly fine.
    Click on Windows, type "Services" + Enter, this opens the Services manager. Scroll down until you find Oculus Runtime VR Services, right click and choose Stop.
    This service has a startup of type Automatic. If you were to set it to Manual, no Oculus software will be loaded at startup. But then to use your Rift you will have to manually start this service. If need be, you can always create a batch (cmd) file for it.
    If you had read my posts above you would see that's exactly what I have been doing but it does not work with v1.31...I'm getting tired of repeating myself here.
  • vr_marcovr_marco Posts: 37 Oculus Start Member
    Marc-G said:
    vr_marco said:
    Marc-G said:
    OculusClinet.exe (desktop app Store/Sensor Config/Setup reset/Guardian Setup/Library)
    OVRServer (service) (core service related to tracking etc)
    Oculus Runtime Platform (core service related to runtimes)
    OculusDash (core service for interfacing with Oculus/Store/Home/Settings/Recentering/Volume adjustment while in VR)

    Are ESSENTIAL services and cannot be disabled. They all depend on each other, at the moment.

    I'm not trying to disable anything I just want to set the Programs as MANUAL so that Oculus Home starts when I want it too not when *it* wants it too, having to unplug the HDMI is not the solution to an ongoing issue that pre-v1.31 was working perfectly fine.
    Click on Windows, type "Services" + Enter, this opens the Services manager. Scroll down until you find Oculus Runtime VR Services, right click and choose Stop.
    This service has a startup of type Automatic. If you were to set it to Manual, no Oculus software will be loaded at startup. But then to use your Rift you will have to manually start this service. If need be, you can always create a batch (cmd) file for it.
    If you had read my posts above you would see that's exactly what I have been doing but it does not work with v1.31...I'm getting tired of repeating myself here.
    I tried this with 1.31 and it works, meaning there is no longer any Oculus software running on your PC until you manually start the main Oculus Service. At that point you launch the Oculus Client and everything is back to normal. Close Client, stop the main service and the Oculus stack is gone again.
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    vr_marco said:
    Marc-G said:
    vr_marco said:
    Marc-G said:
    OculusClinet.exe (desktop app Store/Sensor Config/Setup reset/Guardian Setup/Library)
    OVRServer (service) (core service related to tracking etc)
    Oculus Runtime Platform (core service related to runtimes)
    OculusDash (core service for interfacing with Oculus/Store/Home/Settings/Recentering/Volume adjustment while in VR)

    Are ESSENTIAL services and cannot be disabled. They all depend on each other, at the moment.

    I'm not trying to disable anything I just want to set the Programs as MANUAL so that Oculus Home starts when I want it too not when *it* wants it too, having to unplug the HDMI is not the solution to an ongoing issue that pre-v1.31 was working perfectly fine.
    Click on Windows, type "Services" + Enter, this opens the Services manager. Scroll down until you find Oculus Runtime VR Services, right click and choose Stop.
    This service has a startup of type Automatic. If you were to set it to Manual, no Oculus software will be loaded at startup. But then to use your Rift you will have to manually start this service. If need be, you can always create a batch (cmd) file for it.
    If you had read my posts above you would see that's exactly what I have been doing but it does not work with v1.31...I'm getting tired of repeating myself here.
    I tried this with 1.31 and it works, meaning there is no longer any Oculus software running on your PC until you manually start the main Oculus Service. At that point you launch the Oculus Client and everything is back to normal. Close Client, stop the main service and the Oculus stack is gone again.
    Ok that does not work on my end, this is after a fresh installation and Repair.
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    This is the error I'm met with when making the Service MANUAL


  • AussieStigAussieStig Posts: 210
    Art3mis
    I have the same issue, pre 1.31, I could just close the DT app and the light on the HMD would go to orange and that's it. Now the app is perpetually re-starting itself when I try to close it. The only way I can close the app is to power down the HMD. Has anyone found a solution to this annoying issue? Cheers, AussieStig
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    I guess I'll have to make a ticket regarding this issue as Oculus don't seem to frequent these forums bar the Moderators who are no doubt sending them messages but not being heard at all, the v1.31 update is a total mess and the silence from Oculus regarding the main issues is deafening.
  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    Update: Currently in dialogue with Support, problem persists after 3 uses of DDU to clear GPU drivers.
  • 1Jobe1Jobe Posts: 24
    Brain Burst
    edited October 22
    Happens so often I wonder.


  • Marc-GMarc-G Posts: 58
    Hiro Protagonist
    No response for two days, having to use OTT to manually STOP and START the Service, hardly a user friendly approach but it does the job for now.
  • blanesblanes Posts: 1,067 Poster of the Week
    Well at least your Rift is working,  mine is totally black screen and DDU followed by fresh install of Nvidia 399 or latest 416 drivers does not fix the problem. I do have an amber and sometimes white light and I can hear sound and see that the tracking is working in games shown on monitor screen, just cannot play anything on the Rift.
Sign In or Register to comment.