New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Having Oculus Rift Setup issues? The ultimate guide.

LZoltowskiLZoltowski Posts: 6,537 Volunteer Moderator
edited September 2018 in Support

Heya, so after a few years on this forum and helping what must be a hundred people now with their issues I have compiled a few checklists and tips on how to get your Oculus Rift installed and working. This list is by no means exhaustive but might help.


Pre-Installation checklist:

Disable Antivirus/Anti Malware

Although not every antivirus program will block the setup, many like BullGuard and MalwareBytes are very sensitive to any system changes, remember, this is not like installing a game. The app needs to create services, a special windows user, firewall rules, permissions etc to function properly.

Bullguard is also known to block the setup’s ability to connect to Oculus servers. Unless you know how to properly configure inbound/outbound rules and other settings, disable or uninstall the antivirus during the main setup. I know it's a pain but it accounts for 90% of setup issues. Some users have reported that only by completely uninstalling Bullguard the setup will complete.

Also to note BullGuard is known to prevent the proper operation of the Oculus App after setup, it can prevent games from installing, even if added to the exceptions list.

If you don’t have antivirus installed you are probably using windows built in Defender, disable that temporarily during setup (including protected folders)

Make sure you have at least 60GB free on the system drive and that the drive is NOT a dynamic drive

Although after installation the Oculus App measures at roughly 11GB, it needs the extra space to complete setup procedures, such as uncompressing of files. So even though 14 is recommeneded by the setup, let's be on the safe side.

If you wish to install to a drive other than the setup drive please follow these instructions

Note: As with most software setups on windows, installing to a drive other than C will still result in some data being installed on C, esp in either Document and AppData folder.

Unplug any non-essential USB devices during setup

The Rift can draw quite a bit of power over USB, to avoid any issues with no image during setup unplug any USB devices that are not necessary, basically keep everything to a minimum. See some troubleshooting tips below. 

Make sure you are running as clean session of windows as possible

Some people experience issues during setup while windows is running background applications such as:

  • Motherboard Utilities eg Asus AI
  • GPU tweakers
  • Any CPU/GPU monitoring apps (these are also known to cause micro stutters while in VR)
  • SSD Utilities such as Samsung magician
  • Any third party windows explorer shells
  • Third party utilities like keyboard app etc
  • If you have Windows User Policies set up make sure there aren't any restrictions for the current user
Basically absolute minimum (a sort of Windows Safe mode but not, actual Windows Safe mode will not work)


Make sure you are up to date!

Make sure you have all the updates installed such as:

Some ISP’s cache the setup files

Some ISP’s are known to cache the setup files the software is trying to download, this can cause the “chunks” to become corrupted and prevent the setup from completing. I have seen this in New Zeland and Australia, in such a case using a VPN and connecting to a country next to you solves the issue.


Do not run the setup file by forcing it AS ADMIN, this will cause issues


Common workarounds:

What if nothing works and I cannot get Setup to start the “Setting up your Rift” portion?

Several users have found out that their Windows User profile is the culprit, as an experiment, it is a good idea to create a new admin windows user, make sure it is a LOCAL user, not one associated with your Microsoft cloud login and try and run the setup from there.

I have followed ALL the checklists but the setup gets stuck at the end
If you REALLLLLLLLLLY did all the checklists and still no go, you may try this method several users have found to work

What if my Rift is not being recognised or I am not seeing an image (but I get sound) during setup:

Try moving the USB connections around, for example, move the sensors to USB 2.0 ports and leave the Rift in USB 3.0 .. you might not have enough power coming in through your USB ports.

Try plugging the rift via a DisplayPort using a dongle.

Unplug any secondary monitors you have.

Make sure you are not running any screen streamers or remote desktop software in the background

Try a downgraded version of the GPU drivers such as:


For Laptops: Many laptops are incompatible with the rift, this is because the HDMI port is wired to the Intel CPU, and not to the GPU and/or not enough power is being delivered through the USB ports.

Known possible workarounds are:

  • Use a DisplayPort to HDMI 1.4b adapter, make sure it’s HDMI 1.4b or above so there is enough bandwidth.
  • Setting “Preffer discreet graphics” in Nvidia control Panel
  • Some users have reported that using a Vive Linkbox helps
    This may be due to the fact that the link box acts as an Active Powered hub and helps deliver more power into the ports.
    Here is a short tutorial vid made by a really smart young man on how to use the Vive Box: 

Getting more help:

If you have tried all the above and are still unable to install please contact Official Oculus support:

It may be a good idea to collect your logs and attach them to your ticket.
Here is how to do it:

If you have any more to add please do so bellow and ill compile them in.

Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

Be kind to one another :)


  • italoschiochetitaloschiochet Posts: 11
    these is my problema. i reinstall , sensors, touch, ok, usb ok, but no hdmi conection? I paid a lot of money , and now dont have solutions for this problem? im from Brazil. What i do?
  • jsteamidjsteamid Posts: 17
    edited October 2018
    I just bought a new SSD 500gb and migrated everything successfully, since my Oculus installation was on my other drive I want to reinstall it to my new SSD, then I uninstalled Oculus, but when I try to reinstall it says :
    Sorry, we encountered an erroor during installation. Please restart your computer and try running Oculus Setup again. bla bla bla...


    Turned out it's my fault, C:\Program Files\Oculus was junctioned to drive D , deleted the junction and it's installing fine.
  • LuVille89LuVille89 Posts: 1

    Hi, good afternoon, I’m having trouble starting the oculus.exe, since the Rift Core 2.0 beta has been installed (before the oculus was working perfect), I get the message “OVRServer_x64 … has stopped working”, and if I attempt to start the program I get “We’re having trouble starting oculus” error. I have tried repair and uninstall the software but that doesn’t solve the problem. Do you have any ideas what is causing this? By the way I have windows 7.

    Many thanks in advance.

  • RahotepRahotep Posts: 29
    Brain Burst
    I am unable to launch the Oculus Suite. I just installed for the second time. Fresh. Deleted all references to Oculus Home and Dash in my users data folder.

    Rift Senors can be found in the HW list
    HMD is not being seen
    HMD Audio is OK
    HMD orange light is on
    HMD is being recognized when launching SteamVR and tracking is working. LED turns white, but no video is being displays. HMD remains dark
    NVIDIA Control Panel does not see the VRDesktop. It used to have one before I repaired the Oculus Suite
    Oculus Home stays on the loading screen, turning and turning

    Meanwhile I deleted the Oculus Apps from the Apps drive too 250 GB gone

    Any different? No

    Cannot load the software piece any more nor log in

  • MAC_MAN86MAC_MAN86 Posts: 1,219
    Install Issue - OCULUS UPDATE 1.32 BLOCKED MY XEON which is more than capable.
    This is corruption!
  • KNP54KNP54 Posts: 235
    Nexus 6
    edited December 2018
    This is a bit technical, but interesting read:
    Basically it says that if you're out of HDMI ports and have Rift + Multiple Monitors, you probably need an ACTIVE Display Port to HDMI for your setup to work!
  • elijah.seleniuselijah.selenius Posts: 2
    these is my problema. i reinstall , sensors, touch, ok, usb ok, but no hdmi conection? I paid a lot of money , and now dont have solutions for this problem? im from Brazil. What i do?
    i have the same issue but i cant find any help
  • sford52sford52 Posts: 91
    Hiro Protagonist
    edited December 2018
    Thank you @LZoltowski , this is an extremely useful thread. I would like to offer some unasked for and possibly unwanted suggestions:
    If you are having issues, please don't append them to this thread, rather start a different thread with regards to your specific issue.
    If you are having issues, please be sure to include details about your computer: desktop/laptop, brand and part number, mobo, cpu, gpu, OS, GPU version
    It's really really hard to help folks resolve computer issues without knowing about their computer.

    Specific issues:
    1) Regarding SLI: I dont think Oculus works in systems with multiple GPU's.
    2) I dont think Oculus works with Win 7 anymore.  It may be only Win 10.
    If you had and issue and have resolved it, please append your solution to this thread
    ASUS ROG Strix GL702VS-AH73 17.3" Laptop.  I7-7700HQ, GTX1070, 12 GB DDR4 RAM, 500 EVO 970 GB SSD, VS 2017, Oculus rift, Windows 10 home
  • tjwestietjwestie Posts: 3

  • Frostyest85Frostyest85 Posts: 5
    tjwestie said:

    Same issue :neutral:
  • wonderingswonderings Posts: 13
    Did a clean install today after not using my Rift for a while. I loaded the software on my second drive with no problems... after researching how. Somehow it knows my account when opening for the first time. Not sure if it is connected with the serial # of my Rift and controllers or if there is something else in my computer that was not deleted or removed when I uninstalled it. Anyways The Oculus app (running in Windows 10 Home all updated) wanted to do an update. I said ok. I got a message saying "Sorry, we're having trouble updating Oculus. Please make sure you have at least 12 GB of disk space free, or visit Oculus Support to get help."

    I have 20 gigs free on the main drive over over 100 gigs free on the 2nd drive where the application is installed. I have no way of trying to update again, I uninstalled Oculus and installed again, same thing had my info there already as well as my headset and all that connected. How do I get this update to work? There is a blue bar across the top that I cannot get rid of. Why does this software not have an option to run or check for updates manually???

    Also none of my games or applications that I have purchased are there despite it showing me logged in. I see the games through he website but not in the app. This software is seriously frustrating and wish Oculus would get the basic stuff sorted out before doing anything else. 
Sign In or Register to comment.