New to the forums? Click here to read the How To guide. -- Developers click here.

Oculus Desktop closes 2-3 seconds after I open it when SteamVR is active

keltriverakeltrivera Posts: 1
NerveGear
After certain oculus software update around September, 13 or slightly before Oculus Desktop app started to close almost everytime after 2-3 seconds or slightly more while SteamVR is active. Without SteamVR running it works as expected. I've tried clean install of different Nvidia drivers, new and old ones, using SteamVR normal, beta and old beta, PTC and non PTC Oculus software, reinstalling SteamVR while cleaning all the folders and registry enters left, clean reinstallation of Oculus software after uninstalling it and removing all the files, folders and registry entries which mentioned Oculus. I'm running Win 10 x64 with latest update available, My MB is asus rog z370-f, CPU is I7-8700k, GPU is evga 1080 ti ftw3 hybrid. Pretty much no idea what causes this. Any help would be greatly appreciated

Comments

  • cleanupdisccleanupdisc Posts: 210
    Nexus 6
    In the settings on oculus do you have “allow 3rd party apps or software to use this device” checkmarked? (Or something to that effect). 

    Just make sure you have that setting on to allow steam vr to work with your oculus rift.
  • Benny1994okyoBenny1994okyo Posts: 1
    NerveGear
    cleanupdisc I have the same problem and unfortunately turning the "allow 3rd pary apps or software to use this device" box on or off does nothing to fix it. keltrivera please let me know if you found a fix to this problem. 
  • TomCgcmfcTomCgcmfc Posts: 530
    Neo
    Well for sure you need the allow 3rd party apps enabled.

    I have not had any problems, nor have many others.  So I suggest it is a win10 system thing, a PC port problem, or a faulty hdmi cable.  Who knows?  Probably best to try to work this all out though with Oculus Support imho.

    Maybe make sure your USB's in win10 device manager all have the usb power saving/suspend option off (you can also do this in your win10 power plan settings.  Not sure, but you may need to do a win10 reinstall (hope not!).

    Good luck sorting this out mate.
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!

    Also have a 64gb Oculus Go which I love for travel and quick VR Fixes.  Looking forward to the Quest!
  • F1R3CL0UDF1R3CL0UD Posts: 1
    NerveGear
    I am have this issue also. This feature worked fine over the beta before the 2.0 update. But now I cant find a fix or a workaround. Has anyone found a fix yet? Please help.
  • Darkmaster2110Darkmaster2110 Posts: 1
    NerveGear
    Been having the same issue for a while, still haven't found a proper fix.
Sign In or Register to comment.