New to the forums? Click here to read the How To guide. -- Developers click here.

Oculus 2.0 Home/Store no audio from RIft headphones

deftwaredeftware Posts: 77
Hiro Protagonist
This has been the case since I bought my Rift in January, and I specifically made it a point to *not* use Core 2.0 beta because of the audio problem. Now I have to use it because there's no alternative. Audio worked fine with the original Oculus Home, as it does with all the games I play. Why does Oculus Home/Store 2.0 audio come from my system headphones instead of my Rift headphones where I have it configured to play from?

Comments

  • LuluViBritanniaLuluViBritannia Posts: 363
    Trinity
    When you have the headset plugged-in, go in the desktop app, in "Device" tab. Click on the headset, you should find some audio options. Hopefully it helped!
    Previous VR face :


    My current config : HP Omen laptop, 8 GB RAM, Intel i5-7300HQ @2.5GHz + Nvidia GTX 1050 (2GB VRAM).

    Currently plays on :

    - Beat Saber.
    - Windlands.
    - Skyrim VR.

    I use VR for :
    - Games.
    - Art Software (Tilt Brush, Oculus Medium, Mocu Mocu Dance).
    - Cinema VR (Oculus Desktop or Virtual Desktop).

    "You are allowed to kill only if you are prepared to die."
  • Coldsnap500Coldsnap500 Posts: 17
    NerveGear
    edited October 12
    I have this same problem. Changing the settings in the desktop app fixed it for SOME games, changing settings in Dash did nothing. The Dash/Menu sound effects are also played through my desktop speakers regardless of my settings.

  • deftwaredeftware Posts: 77
    Hiro Protagonist
    When you have the headset plugged-in, go in the desktop app, in "Device" tab. Click on the headset, you should find some audio options. Hopefully it helped!
    Thanks for the reply. Unfortunately that's not the problem: it doesn't matter if it's configured to Rift Audio or Windows Default, the audio for Home/Store in Core 2.0 only comes from my desktop headphones - in spite of the audio from games and Dash itself coming out of the Rift headphones (when Oculus device settings have audio output configured to Rift Audio).

    This has been an ongoing problem since I bought my Rift in January, with Core 2.0, which is why I opted out and used the old Home/Store up until Oculus got rid of it a few days ago, because the audio worked as one would expect.
  • YoLolo69YoLolo69 Posts: 1,059
    Wintermute
    And what if you select "Rift" as default audio output in the (usually) bottom right of the taskbar with the Windows speaker icon? Did you try that already (sound obvious I know)?

    “Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

    "Be careful, if you are killed in real life you die in VR too." - TD_4242

    I7 3770K OC 4.6GHz, GTX1080 OC 10%, 16GB DDR3 2448  OC, Oculus Rift CV1

  • LuluViBritanniaLuluViBritannia Posts: 363
    Trinity
    What YoLolo69 said. Also, you should upgrade your audio drivers from Windows device manager ^^.
    Previous VR face :


    My current config : HP Omen laptop, 8 GB RAM, Intel i5-7300HQ @2.5GHz + Nvidia GTX 1050 (2GB VRAM).

    Currently plays on :

    - Beat Saber.
    - Windlands.
    - Skyrim VR.

    I use VR for :
    - Games.
    - Art Software (Tilt Brush, Oculus Medium, Mocu Mocu Dance).
    - Cinema VR (Oculus Desktop or Virtual Desktop).

    "You are allowed to kill only if you are prepared to die."
  • deftwaredeftware Posts: 77
    Hiro Protagonist
    YoLolo69 said:
    And what if you select "Rift" as default audio output in the (usually) bottom right of the taskbar with the Windows speaker icon? Did you try that already (sound obvious I know)?
    Yes, that has always been the only way that it 'works'. But I didn't have to do that with the old Home and shouldn't have to do it now. Games and Dash work just fine via the headset's earphones without setting Rift Audio as my default Windows audio device - they respect the audio output setting I have configured in the Oculus desktop program.
  • YoLolo69YoLolo69 Posts: 1,059
    Wintermute
    Ok, so it work when it's set to the default Windows audio output?, no real drama here? I thought it was a no-go ;)

    I suggest to create a support ticket and investigate with the Oculus team, that will help you and all others persons having the same issue.

    “Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

    "Be careful, if you are killed in real life you die in VR too." - TD_4242

    I7 3770K OC 4.6GHz, GTX1080 OC 10%, 16GB DDR3 2448  OC, Oculus Rift CV1

Sign In or Register to comment.