New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Google Earth VR not working / Crashing / Errors [SOLVED]

TvVlietTvVliet Posts: 7
NerveGear
edited October 2018 in Support
I've been trying to fix this for weeks but I've finally done it and just want to share it for the troubleshooting googlers out there.

Sometimes it would load and crash at 13 percent loading.
It wouldn't load via Oculus, not via steam, not anywhere.

Errors I had (some of them):
"OpenVR failed to initialize with the given error:VRInitError_Init_PathRegistryNotFound"
Error code 0
Function ovr_CreateTextureSwapChainGL"


SOLUTION

I went into Nvidia Control Panel -> manage 3d settings -> select earth VR (or other) -> change CUDA to main GPU, OPENGL to main GPU and Power to maximum

I also set my audio default to windows as default, as some user suggested to do that as well. but this didn't help me to solve it, but maybe it will help you.
Also, make sure to plug your hdmi of the rift in the same GPU as your main monitor screen.

I also had 2 videocards which explains my problem of earth VR having trouble deciding which card to use. The Nvidia solution solved that.



Comments

Sign In or Register to comment.