New to the forums? Click here to read the How To guide. -- Developers click here.

No Video in Headset on Laptop

Mani_47Mani_47 Posts: 8
NerveGear
I just bought Oculus Rift and i am having same issue of no video on headset during setup.
I am using Dell G7000 laptop, 7th gen, 8Gb ram and 1050 nvidia card. Windows 10 64 bit. Only have 1 HDMI and 3 USB ports.
Please help me set up

Comments

  • Mani_47Mani_47 Posts: 8
    NerveGear
    Okay so after i updated my Nvidia drivers to 416.16, i started the rift and got video for few minutes, controllers were working, i got homepage. but then again my video went black, again i restarted the laptop, got the homepage for few secs and then black, since then multiple restart, beta restart, still getting black screen in headset.
  • TaintFistTaintFist Posts: 179
    Art3mis
    Nvidia just rolled out another driver update, 416.36.  Can update it now, here is hoping it solves your issue.  Good luck.  If that doesn't work, best to put in a support ticket and get some one-on-one assistance.


  • LuluViBritanniaLuluViBritannia Posts: 371
    Trinity
    Instead of upgrading the drivers, I would try downgrading to the 398 version (unless that was the one you had before).
    Previous VR face :


    My current config : HP Omen laptop, 8 GB RAM, Intel i5-7300HQ @2.5GHz + Nvidia GTX 1050 (2GB VRAM).

    Currently plays on :

    - Beat Saber.
    - Windlands.
    - Skyrim VR.

    I use VR for :
    - Games.
    - Art Software (Tilt Brush, Oculus Medium, Mocu Mocu Dance).
    - Cinema VR (Oculus Desktop or Virtual Desktop).

    "You are allowed to kill only if you are prepared to die."
  • LZoltowskiLZoltowski Posts: 6,429 Volunteer Moderator
    Please also make sure you have set "prefer maximum performance" and changed the "Preferred graphics processor"

    Image result for nvidia prefer discrete graphics
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Mani_47Mani_47 Posts: 8
    NerveGear
    Please also make sure you have set "prefer maximum performance" and changed the "Preferred graphics processor"

    Image result for nvidia prefer discrete graphics
    I tried your advice and set the setting to Highperformance. due to that i got the video on headset, but after some time it got flickering (on and off) if i tilt my head down, it would turn on, but at normal level again black screen, after about 30 secs i got black screen again. Then i unplugged the VR from laptop and replug it, i got a white flash screen and again black screen. is there something wrong with my headset?

  • Mani_47Mani_47 Posts: 8
    NerveGear
    TaintFist said:
    Nvidia just rolled out another driver update, 416.36.  Can update it now, here is hoping it solves your issue.  Good luck.  If that doesn't work, best to put in a support ticket and get some one-on-one assistance.
    I just checked driver and it actually is 416.34, not 16 and that is the latest driver that is available
  • Mani_47Mani_47 Posts: 8
    NerveGear
    Instead of upgrading the drivers, I would try downgrading to the 398 version (unless that was the one you had before).
    How can i downgrade it?
  • Mani_47Mani_47 Posts: 8
    NerveGear
    TaintFist said:
    Nvidia just rolled out another driver update, 416.36.  Can update it now, here is hoping it solves your issue.  Good luck.  If that doesn't work, best to put in a support ticket and get some one-on-one assistance.
    I did contacted support but they said that my laptop is not Oculus Ready certified and they cant help me unless i buy oculus ready pc.
  • LZoltowskiLZoltowski Posts: 6,429 Volunteer Moderator
    edited October 12
    Mani_47 said:
    TaintFist said:
    Nvidia just rolled out another driver update, 416.36.  Can update it now, here is hoping it solves your issue.  Good luck.  If that doesn't work, best to put in a support ticket and get some one-on-one assistance.
    I did contacted support but they said that my laptop is not Oculus Ready certified and they cant help me unless i buy oculus ready pc.
    You can search for Nvidia Drivers here:
    https://www.nvidia.co.uk/Download/Find.aspx?lang=en-uk

    You can also try disabling USB power management for ALL USB hubs

    First, in your Power profile settings make sure Selective suspend is set to off:


    Then in device settings make sure sensors and all of your USB hubs have this option set to off (right click on each one and go to properties)




    make sure this box is unticked:



    Just double check you have "prefer maximum performance" set too

    Image result for nvidia prefer maximum performance
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • Mani_47Mani_47 Posts: 8
    NerveGear
    Mani_47 said:
    TaintFist said:
    Nvidia just rolled out another driver update, 416.36.  Can update it now, here is hoping it solves your issue.  Good luck.  If that doesn't work, best to put in a support ticket and get some one-on-one assistance.
    I did contacted support but they said that my laptop is not Oculus Ready certified and they cant help me unless i buy oculus ready pc.
    You can search for Nvidia Drivers here:
    https://www.nvidia.co.uk/Download/Find.aspx?lang=en-uk

    You can also try disabling USB power management for ALL USB hubs

    First, in your Power profile settings make sure Selective suspend is set to off:


    Then in device settings make sure sensors and all of your USB hubs have this option set to off (right click on each one and go to properties)




    make sure this box is unticked:



    Just double check you have "prefer maximum performance" set too

    Image result for nvidia prefer maximum performance
    Okay the steps you told me did worked. But now i am getting the video in headset in pieces. and when i checked the status of the device, it says "Poor Tracking Quality" , and after sometime i get the black screen again. even when i am standing right in front of sensors.
    When contacted the support, they said that the problem is that my Laptop is not Oculus Ready
    How to resolve this one?
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited October 17
    Poor tracking quality is usually a USB issue. Do you have different USB ports you can try?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Mani_47Mani_47 Posts: 8
    NerveGear
    Poor tracking quality is usually a USB issue. Do you have different USB ports you can try?
    Only 3 USB ports, 2 3.0 and 1 2.0.
    Support guy advises me to not use any USB hubs
  • TomCgcmfcTomCgcmfc Posts: 501
    Neo
    If I were you I would try a Powered usb 3.0 hub.  Run it through one of your laptop USB 3.0 ports.  Then plug your sensors into the hub and your headset into the other laptop usb 3.0
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!

    Also have a 64gb Oculus Go which I love for travel and quick VR Fixes.  Looking forward to the Quest!
Sign In or Register to comment.