New to the forums? Click here to read the How To guide. -- Developers click here.

Oculus Setup can't connect - BadImageFormatException error?

TheFergatronTheFergatron Posts: 1
NerveGear
Hello lovelies. Bit of an issue. I'm trying to install the Oculus software on my Windows 10 machine, and it fails with the "Can't connect - check your connection" error. I've done all the standard deal, checking that I have enough disk space and that my drivers are up-to-date, checked that I've run the setup as administrator and made sure it's not being blocked by any firewall or anti-virus. When I look into my oculussetup.log, this is what I see:

[Debug] [28/10/2018 18:35:36] Starting preflight checks.
[Debug] [28/10/2018 18:35:36] RunCheck 'Dawn.Preflight.ConfigInitialisedCheck' failed.
[Error] [28/10/2018 18:35:36] Aborting installation due to failed preflight check.
[Error] [28/10/2018 18:35:44] Uncaught setup task exception!
System.BadImageFormatException: Could not load file or assembly 'System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. Index not found. (Exception from HRESULT: 0x80131124)
File name: 'System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'

I've done a search round these forums and I can't find any reference to this particular error. I've logged a ticket with Oculus, but I wanted to see if anyone's got any ideas in case I just get pointed towards a troubleshooting page or something.

Thanks people.
Sign In or Register to comment.