Fix for Herobound: spirit champion crash / not loading, OVRPlugin.dll needs downgraded — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Fix for Herobound: spirit champion crash / not loading, OVRPlugin.dll needs downgraded

shrimp24201shrimp24201 Posts: 2
NerveGear
The story:
Sometime this summer 2018 after an Oculus software update our Herobound spirit champion software started crashing on startup with an error dump and no real useful information on the crash.  I thought it was the video drivers and went back and forth to no avail.  After emailing the devs multiple times with no response I took a deeper look as this is one of our favorite games.  After many days and weeks of trial and error I can finally post what fixed it on our machine!

The fix: I figured it must be some new file causing the issue as it used to run flawlessly.  So I tried looking through the files and found the plugins folder.  I compared many of these files to some other Oculus apps / sw on my machine and found that the culprit was OVRPlugin.dll.  When replacing the newer 2018 ver with an older one it worked again!.  I wanted to give back to the Oculus community and I have attached the older version.  Simply make a backup of your existing plugin -> rename to OVRPlugin.old to be safe and then unzip OVRPlugin.dll and replace with the attached in the following folder.
<Your drive>\<Your directory>\Oculus\Software\gunfire-games-llc-herobound-spirit-champion\HeroBound2_PC_Data\Plugins
I hope this helps you get the game working again if you are having the same crash condition!  If it does please leave some feedback as this is my first post. 

Comments

  • rh_galaxyrh_galaxy Posts: 70 Oculus Start Member
    edited December 2018
    Yes, it works with your DLL, thank you. Since it is in the game directory it must come from an update of the game, and not from an Oculus Home update, or maybe an Oculus Home update broke this one from working... Probably the later since there is no reason to update an old working game.

    Miss the ability to see dates for last update in OH.
  • KNP54KNP54 Posts: 258
    Nexus 6
    Yeah the game works again finally.
    Although, if you don't trust downloading the file from Mr. NobodyFromTheInternet (no offense @shrimp24201), I tried several OVRPlugin.dll from various games I have installed and I found that the one that comes with Colonist A514 (free app from the store) works!
    Specs: Delidded i7-8086k @ 5.0 GHz all cores, NZXT X52 cooler, 32GB G.Skill 3200MHz, ASRock Z370 Gaming-ITX/ac, Asus GTX 1080 Strix, Corsair SF600 platinum, Samsung 970 EVO M.2 NVMe 1TB, Samgung 850 EVO 500GB + 840 EVO 500GB in raid0, Seagate Desktop HDD 4TB, Louqe Ghost S1, Asus PB287Q 3840x2160 @ 60Hz, Samsung SyncMaster 226BW 1680x1050 @ 60Hz. Oculus Rift CV1.
Sign In or Register to comment.