New to the forums? Click here to read the How To guide. -- Developers click here.

Elite Dangerous wont run from Oculus but DOES run through steamVR.

McJesusMcJesus Posts: 7
NerveGear
I REALLY want to run Elite dangerous through Oculus home. It's way more convenient. But unfortunately when I try to run Elite, it sits at this loading screen in VR while the game loads up in 2D on the desktop. When I load the game through Steam, Oculus home is started and Elite is run and the game functions in VR as it should. I have filed a ticket with Frontier to see if it's something they can help with but now I am asking on the Oculus forums to see if anyone here has experienced something similar.

Things i have tried: 
Uninstalling and reinstalling Elite Dangerous
Uninstalling and reinstalling Oculus software(all of it drivers and everything)
Ensured the "Unknown Sources" box is checked
Uninstalling and reinstalling graphics drivers(Nvidia versions: 398.82, 416.34, 417.01)

None of these things have helped.

Comments

  • RattyUKRattyUK Posts: 472
    Trinity
    Do you have the Oculus complimentary key from Frontier?  This gives you ED as a 'native' app in your Oculus library.
    The key can be obtained from your Frontier account - just in case.
    PC info: AMD Ryzen 7 2700X, Asus ROG Crosshair VII Hero, 16GB Tforce Pro Dark DDR4 3200, Gigabyte GTX 1080, Samsung 850 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Corsair Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD 3K screen)
  • Frontier_SupportFrontier_Support Posts: 90 Oculus Partner
    Thanks for making a ticket! Hopefully we'll be able to help out as soon as possible. 

    In the meantime if you haven't already, please try temporarily turning off your antivirus and see whether this allows the game to launch successfully through OH. 

    -Vulcan
  • onclebkonclebk Posts: 4
    NerveGear
    Opposite problem... I never managed to run the game from SteamVR... Black screen and then everything stops... If anyone had the same problem ?
  • McJesusMcJesus Posts: 7
    NerveGear
    Hey RattyUK,
    I think its native in oculus home as I installed it from within oculus home. However, I will double check and make sure the key is present. 

    Vulcan from Frontier support, I have tried turning off antivirus (avast) it did not help. 
  • RattyUKRattyUK Posts: 472
    Trinity
    edited November 28
    McJesus said:
    Hey RattyUK,
    I think its native in oculus home as I installed it from within oculus home. However, I will double check and make sure the key is present. 

    Vulcan from Frontier support, I have tried turning off antivirus (avast) it did not help. 
    Thanks for the mention B)

    If it runs OK through steam it is odd for it not to direct from Oculus (I launch ED through whichever environment I'm in at the time with no issues) which is why I asked the (possibly unneeded!) question.  I do remember having to get the Oculus key from Frontier as I'd bought the Steam version.  Hope you do get it sorted out :)
    PC info: AMD Ryzen 7 2700X, Asus ROG Crosshair VII Hero, 16GB Tforce Pro Dark DDR4 3200, Gigabyte GTX 1080, Samsung 850 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Corsair Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD 3K screen)
  • McJesusMcJesus Posts: 7
    NerveGear
    Sadly the Oculus Key was indeed a part of my account but that didnt allow OH to run Elite within VR. It still thinks it should run 2d. I wonder if some kind of software/drivers arent being run when the game starts. With steam, I need to start the SteamVR application before I try to run the game. When I do, in steam, it runs fine. but you would think the same thing would happen, that the oculus software/drivers to be running when OH is running. Elite doesnt seem to know that it should run in VR when run from OH. I will continue to try things hopefully Oculus or Frontier will help out in some way.
  • RattyUKRattyUK Posts: 472
    Trinity
    @McJesus ; - do you have ED in your Library in Oculus?  See below:


    On the screenie you can see the (native) ED highlighted and below & to the right is the Steam version added to the library by running in VR.
    PC info: AMD Ryzen 7 2700X, Asus ROG Crosshair VII Hero, 16GB Tforce Pro Dark DDR4 3200, Gigabyte GTX 1080, Samsung 850 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Corsair Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD 3K screen)
  • McJesusMcJesus Posts: 7
    NerveGear
    Yes, I made sure it was downloaded right from the Oculus store and I made sure to try and run it using "Start in VR" option.
    What comes up is this
    Frontier has even asked me to try putting My graphics card in debug mode but alas that didnt work either. They have asked to "ensure that Desktop mode is not enabled for Elite Dangerous" but im not sure of an option that does this. Or at least I cant find where it is.

    I tried running Arizona Sunshine just to be sure vr is indeed working and it is.
  • RattyUKRattyUK Posts: 472
    Trinity
    That is strange indeed!  I don't know if dropping a ticket to Oculus support would be any more fruitful...  What is odd is that ED works through Steam for you!
    Sorry I couldn't be more helpful.
    PC info: AMD Ryzen 7 2700X, Asus ROG Crosshair VII Hero, 16GB Tforce Pro Dark DDR4 3200, Gigabyte GTX 1080, Samsung 850 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Corsair Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD 3K screen)
  • Frontier_SupportFrontier_Support Posts: 90 Oculus Partner
    Sorry to hear that this problem persists, if Oculus support aren't able to help, please do send us a ticket via: https://support.frontier.co.uk/topic.php

    -Vulcan
  • McJesusMcJesus Posts: 7
    NerveGear
    No worries, thanks for trying. I will put in a ticket to Oculus support to see if they can offer any suggestions. If no one can figure it out I guess ill have to run the game from Steam but i'll have to turn down the graphics settings because its too choppy othewise.
  • Rattenbury84Rattenbury84 Posts: 2
    NerveGear
    I've had the same issue with the Beyond update as well. It updated automatically like usual.  I start up Elite through the Oculus home and it loads up the 2D version on my desktop. It just shows the white void in the headset.
  • McJesusMcJesus Posts: 7
    NerveGear
    That sucks Rattenbury. Ok so its not just me. Sadly, I have resorted to running it with SteamVR. It's a few more steps to get it running and a little confusing but I can manage. 
  • TaomynTaomyn Posts: 23
    Brain Burst
    I've had the same issue with the Beyond update as well. It updated automatically like usual.  I start up Elite through the Oculus home and it loads up the 2D version on my desktop. It just shows the white void in the headset.
    Apparently they messed up the manifest files, so we'll need to wait for a patch or apparently you can fix it yourself

    you go to "C:\Program Files\Oculus\Software\Manifests" open the Elite json and the mini and edit this "launchParameters": "ED /vr /autoquit"


    ---
    AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | EVGA GTX980Ti ACX 2.0+ GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • Rattenbury84Rattenbury84 Posts: 2
    NerveGear
    I tried using the "start in VR Mode" option from the three dot drop down menu, and it still doesn't display in the Rift Headset. I will try your suggestion with the "launchParameters", Taomyn
  • TaomynTaomyn Posts: 23
    Brain Burst
    I also find out you either need to reboot or restart the Oculus service as the previous setting is cached until then, but it did work for me.
    ---
    AMD Ryzen 7 2700X CPU | Asus RoG Strix X470-I Gaming Motherboard | Corsair Vengeance RGB 32GB DDR4-3200 RAM | EVGA GTX980Ti ACX 2.0+ GPU | Corsair Force MP500 M.2 120GB SSD | Samsung 860 EVO 1TB SDD | Corsair H100i v2 Cooler | Corsair 250D Case | Corsair RMx 750 80+ Gold PSU


  • OmegaM4NOmegaM4N Posts: 241
    Nexus 6
    edited December 15
    Do you have two version of the game installed, one for Steam in the steam folder and one for Oculus in the Oculus folder?
    I also recently wanted to run the game also from my Oculus account, but did not want to dl it again, so i started to download it from the rift store, then paused it, closed down Rift, found the rift store folder that Rift was DL the game into, then went to my steam version install folder and copied ED over into the Rift folder, and then started up rift and continued the install, and it found the full ED game, checked it and that was it, game now runs from my OC account without steam being started or having to DL it again for the Rift store.  :)

    Oh and make sure Oculus is looking at the correct library locatiosn for these games in the settin/ general option.
  • McJesusMcJesus Posts: 7
    NerveGear
    Taomyn, Ill try that config option. OmegaMan, I do have both versions installed. one for oculus and one for steam. 
Sign In or Register to comment.