Web video playback with Firefox not working since Rift Core 2.0 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Web video playback with Firefox not working since Rift Core 2.0

jjj_programmerjjj_programmer Posts: 3
NerveGear
Since the 2.0 update, I've been unable to launch WebVR content directly from Firefox.  

Take for example some videos like this aircraft takeoff:
https://playcanv.as/p/G0d8FneG/

Or this Hellblade trailer:
https://delight-vr.com/video/

Hitting the "Enter VR" button makes the head tracking start working, but the view from inside the rift doesn't switch over to the video.  It remains on the home 2.0.  This used to work with Firefox and 1.0 Rift software, but I haven't been able to get it to kick the video on in the rift since 2.0.  Any suggestions?

Comments

  • FirfFirf Posts: 10
    NerveGear
    edited January 25
    Same problem.  Any updates on this?

    Also, if not obvious, I'm using a Rift.
  • LuluViBritanniaLuluViBritannia Posts: 453
    Trinity
    edited January 28
    Hey there,
    I used to have this problem as well (tracking works but no display in the headset), it was because the browser app would not use the discrete graphics card. So make sure Firefox does use the good graphics card ^^.
    If you have an Nvidia graphics card, go into the NVidia Control Panel and change the preferred setting for your browser.
    Hopefully that helped!
    Current VR results imo:
    - Great small apps. Great ports of bigger games.
    - Great VR-specific features. Not enough showcased!!!
    - Too many actors in the industry, the market is totally broken.


    My hopes for VR next gen:

    - Better ratio between visual quality and power needs. No more godrays and less SDE.
    - Full Body Tracking.


    "If you don't mind, do you want me to take you there? Where dreams come true."
  • FirfFirf Posts: 10
    NerveGear
    Lulu,

    Thanks for the reply.  The solution you provided is normally for PCs that have more than one graphics card (e.g. onboard / motherboard intel graphics (integrated) and a separate and distinct graphics card.  Because I do not have integrated graphics, I do not even have the option to select a discreet processor, it only provides that option if you are setup with an onboard and graphics card.

    I do appreciate the the response as that are often hard to come by on the Oculus forums.

    Have a great day!

    Jordan
  • FirfFirf Posts: 10
    NerveGear
    I figured out a solution.  I had to download a fresh version of FireFox (either Nightly or Quantum, both worked) and use a fresh profile.  Although my about:config files look identical, there must be something different in the profiles preventing WebVR from working properly.  Now I simply keep a copy of Nightly for WebVR and Quantum for standard browsing.  Not the best solution, but works.  Each using their own profile.
  • rupertrupert Posts: 46
    Brain Burst
    Hey there,
    I used to have this problem as well (tracking works but no display in the headset), it was because the browser app would not use the discrete graphics card. So make sure Firefox does use the good graphics card ^^.
    If you have an Nvidia graphics card, go into the NVidia Control Panel and change the preferred setting for your browser.
    Hopefully that helped!
    This solved the problem for me as well. I would get a "Loading..." message in the headset, but it would never actually load. I forced Firefox to use the Nvidia card (instead of Intel built-in) and it started working. For anyone searching, I'm using a Razer Gaming Laptop with Nvidia 1060 graphics.
Sign In or Register to comment.