New to the forums? Click here to read the How To guide. -- Developers click here.

Oculus Medium 2.2!!

naomi.cornmannaomi.cornman Posts: 159 Oculus Staff
edited December 2018 in Oculus Medium


We’re celebrating the end of the year with our 2.2 Release! We’ve listened to your feedback and worked to improve Medium as a powerful object editor.

Accidently moved the mirror tool? We’ve added Node Lock! Scene Graph confusing you? Check out the new Node Settings menu! Unintentionally changed your stamp orientation? We’ve swapped the tool size shortcut and applicator transform! Find yourself constantly revising your settings? Most tool settings now save across sessions. To top it off, we’ve added 10 new languages.


Medium Ver. 2.2 Release Notes

New Features:

  • Node lock is in! Lock scene objects to prevent accidental moves, or lock your layers to freeze clay editing.

  • Tool settings - except for constraints, color, stamp, and the size slider - now save across sessions. Scene settings still save across sculpts.

  • The scene graph is now organized in a much less cluttered format, making hierarchy editing faster and more understandable with the new Node Settings menu.

  • We’ve added a toggle to turn custom stamp color on or off in the stamps menu. It defaults to “Off.”

  • Move tool: Double clicking in Move Tool now toggles between default and elastic move, and strength in both modes has been tuned to incorporate more stiffness parameters.

  • You can now change the tool applicator transform of all tools, including raycast tools.

  • New languages available! Change your language in Skyline to access Medium in Danish, Dutch, Finnish, French, German, Italian, Norwegian, Spanish, Swedish, or Japanese.

    • As part of the localization push, we now allow the import and reading of assets named with special characters.

    • We also fixed the long standing bug where users with special characters in their Windows username were unable to start.

  • We’ve swapped the tool size shortcut and applicator transform to minimize the amount of mistaken applicator changes.

    • Push the tool hand thumbstick to the left or right for the shortcut to change your tool size, which is now also more accurate.

    • Depress the tool hand thumbstick to change the applicator transform.

  • We’ve updated our Manual to reflect some of the current changes. Visit our manual by navigating to the top black bar at www.oculus.com/medium, or going straight to www.oculus.com/medium/manual.


Bug Fixes:

  • The move tool respects grid snap constraints.

  • Required confirmation when deleting assets in the asset browser.

  • When you select a scene object, its node in the Scene Graph will scroll into view.

  • Clay surface artifacts fix. This was showing up mostly when using the move tool repeatedly.

  • Default file names when saving or exporting are back, and dictating a library is not required before saving.

  • Steady stroke with raycast tools have been re-tuned.

  • Stamps no longer rearrange order within their collection every time the app restart - they will stay alphabetical.

  • Bloom is no longer enabled at launch if option is set to off.

  • Improved video capture quality using the in-Medium capture on NVIDIA machines.

  • Export folders now reliably and automatically generate.

  • The export transform is now the scene origin.

  • Move tool preview now consistently updates when pressing the alt tool or around the scene graph.

  • Repeatedly looking at tooltip videos over time doesn’t cause graphical corruption.

  • Fixed existing ASW implementation ahead of ASW 2.0 release. 


Known Problems:

  • Video quality using the in-Medium capture on AMD machines is still fairly low quality.


CL 134541584

Comments

  • abydosanabydosan Posts: 14
    NerveGear
    edited December 2018
    Lock, ASW 2.0, no more accidently moved mirror and lot of more  

  • Henri1970Henri1970 Posts: 109
    Art3mis
    WAAAAAAAAAAAAAAAAAAA! THIS.IS.GREAT!!!!!!!!!!!!!!!!!!! 
  • yanhaoartyanhaoart Posts: 42
    Brain Burst
    edited December 2018
    Yes! Great update, but i'm having this issue of the stamps not being able to reset to the default position, despite clicking on reset applicator tool D:

    Edit: I restarted the app and it worked fine after that!
  • neueneue Posts: 5
    NerveGear
    Solid update, looking forward to trying it.
  • kt-firedrakekt-firedrake Posts: 5
    NerveGear
    edited December 2018
    Medium now now longer loads :(
    It just sits on the loading screen forever

    OS Name Microsoft Windows 10 Home
    Version 10.0.17134 Build 17134
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name DESKTOP-QGANAGN
    System Manufacturer Gigabyte Technology Co., Ltd.
    System Model AB350M-Gaming 3
    System Type x64-based PC
    System SKU Default string
    Processor AMD Ryzen 5 1600 Six-Core Processor, 3200 Mhz, 6 Core(s), 12 Logical Processor(s)
    BIOS Version/Date American Megatrends Inc. F22b, 13/02/2018
    SMBIOS Version 3.1
    Embedded Controller Version 255.255
    BIOS Mode UEFI
    BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
    BaseBoard Model Not Available
    BaseBoard Name Base Board
    Platform Role Desktop
    Secure Boot State Off
    PCR7 Configuration Binding Not Possible
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume2
    Locale United Kingdom
    Hardware Abstraction Layer Version = "10.0.17134.471"
    Username DESKTOP-QGANAGN\User
    Time Zone GMT Standard Time
    Installed Physical Memory (RAM) 16.0 GB
    Total Physical Memory 16.0 GB
    Available Physical Memory 11.4 GB
    Total Virtual Memory 25.5 GB
    Available Virtual Memory 19.4 GB
    Page File Space 9.50 GB
    Page File C:\pagefile.sys
    Kernel DMA Protection Off
    Virtualisation-based security Not enabled
    Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and the device is not InstantGo, Un-allowed DMA-capable bus/device(s) detected, TPM is not usable
    Hyper-V - VM Monitor Mode Extensions Yes
    Hyper-V - Second Level Address Translation Extensions Yes
    Hyper-V - Virtualisation Enabled in Firmware No
    Hyper-V - Data Execution Protection Yes


  • jessicazetajessicazeta Posts: 139 Oculus Staff
    @kt-firedrake, can you try deleting your Preferences folder? Can you also include your GPU, and perhaps even logs from C:\Users\username\AppData\LocalLow\Oculus\Medium\log?
  • kt-firedrakekt-firedrake Posts: 5
    NerveGear
    Nvidea GEforce 1060 6GB
    I am running 2 monitors although medium did load fine earlier tonight before the update
  • kt-firedrakekt-firedrake Posts: 5
    NerveGear
    Oh and deleting preferences didn't work
  • kt-firedrakekt-firedrake Posts: 5
    NerveGear
    I just tried uninstalling and re-installing Medium, still then same just stuck on the loading screen.
  • DreamShaperDreamShaper Posts: 623
    Neo
    edited December 2018
    Finally found some time to try out some of the features.  Locking is really nice! This is going to be really useful!  Also quite pleased to see the return of working video recording, and the turntable seems much easier to control.  

    Low res inflate is a bit inconsistent across mirror sides, but overall mirroring appears better.  I don't really have the hang of re-centering stamps yet, so jumping out to reread the instructions.  Will just have to go through everything as soon as possible.

    Overall is impressive so far, I like the way the palletes got stacked.  Very intuitive.  Definitely moving in the right direction! Going to have to get a few days in before I form deeper opinions about it.  Looking forward to checking out the changes to the other features.

    Edit:  Checked out the angle/grid snap improvements.  Definitely some things to explore there.  Interesting potentials!
  • kt-firedrakekt-firedrake Posts: 5
    NerveGear
    Wuhoo I got it working. Although I had my virus checker disabled it seems like it was that that may have been causing the problem. I ran it today but forgot to turn virus checker off and a pop up appeared asking to give Medium access to the internet, as soon as I did that it loaded.
  • LuluViBritanniaLuluViBritannia Posts: 404
    Trinity
    This is all very cool, haven't tried everything yet though.
    I still have memory issues pretty quickly. Granted I've got only 8 GB of RAM, but I still find it weird that the memory would fill in so quickly. There's definitely some optimization to do on that part. Like, why isn't memory cleaned up whenever I load another model (or try to make a new one)?
    My current config : HP Omen laptop, 8 GB RAM, Intel i5-7300HQ @2.5GHz + Nvidia GTX 1050 (2GB VRAM).

    Currently plays on :

    - Beat Saber.
    - Windlands.
    - Skyrim VR.

    I use VR for :
    - Games.
    - Art Software (Tilt Brush, Oculus Medium, Mocu Mocu Dance).
    - Cinema VR (Oculus Desktop or Virtual Desktop).

    "Everything changes. Even the happy or funny things disappear. Can I still enjoy this place anyway?"
  • macatckmacatck Posts: 1
    NerveGear
    Loving the new update although switching the resizing and positioning tools has tripped me up a bit, nothing i can't unlearn though lol but one thing I've noticed that doesn't seem to be working as intended is the lock feature, sure it locks me out of selecting layers but if I have the move tool active and have "only active layer" turned off the move tool still affects the locked layers, which i was hoping it would only affect unlocked layers. the only way i've found around this is to turn off the visibility of the layers i don't want to be affected but than i have no reference when adjusting my pieces.

    No other criticisms aside from that, keep up the great work! :smile:

     
  • jessicazetajessicazeta Posts: 139 Oculus Staff
    @macatck, Great bug! We'll check it out. 

    @LuluViBritannia, Thanks for the description there. Bugging it!
  • naomi.cornmannaomi.cornman Posts: 159 Oculus Staff
    Patch incoming! 

    Medium Ver. 2.2.1 Release Notes

    Bug Fixes:

    • Inconsistent scene origin offset is now repaired.

    • Material slider increments have changed to allow for better granularity.

    • Color now saves across sessions.

  • wahwah1975wahwah1975 Posts: 4
    NerveGear
    Hi, Since updating to 2.2 & 2.2.1 Medium is crashing at random intervals, requiring me to open task manager and kill the process.

    Please see attached log.

    PC Spec:

    Windows 10
    I7 8700k
    1080ti (latest drivers - 417.35)

    Ive tried reinstalling both Medium and Nvidia drivers.

    Any ideas from the log?

    Thanks,


Sign In or Register to comment.