New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Some games won't install - Tried from inside GO and through phone app

KMBKLBKMBKLB Posts: 4
NerveGear
I have bought a bunch of games in the last few days and most of them have installed without problem but several will not install.

Specifically (although I don't think it's game specific) it's RUSH & PET LAB. I go to the library on the GO, select Uninstalled and try clicking the download error... and nothing happens. I chose DETAILS and from there select DOWNLOAD and it greys out but nothing happens. 

I've checked the Downloads under notifications and it says nothing is downloading.

I've tried from the phone for these games and it says "something went wrong" every time I try and install. 

I have restarted the Go multiple times, tried shutting it down and have tried leaving it running for a long time but nothing changes. 

Need immediate help on this since it's for Christmas tomorrow. 

Comments

  • KMBKLBKMBKLB Posts: 4
    NerveGear
    I resolved this buy (for the third time) doing a factory reset on the Go and then starting to install games/apps with the games that wouldn't install previously through the phone and then going to the rest of everything. 

    That seems to have resolved the problem although I have no idea why it didn't work the previous two times. 
Sign In or Register to comment.