How to sign an oculus Go Unity App, really ? — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How to sign an oculus Go Unity App, really ?

PiflyonPiflyon Posts: 21 Oculus Start Member

Hi,
This message above is driving me crazy.
I can not find a real answer to the question in the title of this discussion. Yes, google it ! All you find are documentations throwing you here and there.

Nothing here : https://developer.oculus.com/blog/everything-you-need-to-know-to-develop-for-oculus-go/
Nothing here : https://developer.oculus.com/distribute/latest/concepts/publish-create-app/
Nothing here : https://developer.oculus.com/distribute/latest/tasks/publish-submit-app-review/
OutDated : https://developer.oculus.com/documentation/mobilesdk/latest/concepts/mobile-native-manifest/ (talks about a package name that does not appear in the manifest).

-> I have already released a full game for Oculus RIFT.
-> I'm porting it to Oculus GO.
-> The App works great in Oculus Go when I Build & Run it from Unity
-> I'm NOT in developpement Build in Unity>Build settings
-> I HAVE a package name in player settings>Other settings
-> I have removed any OSIG file (even if I don't know what or why)
-> I have made tools>Oculus>Create store compatible androidManifest (now exists in assets/plugins/android/assets)
-> In player settings>Publishing Settings I have tried "use existing keystore" and "create new keystore" and typing any password

Nothing works, and by the way, seriously, it is already too much stuffs !
What do I miss ? I even have a Google Play Store Dev account, but there I don't find anything that helps.

Do I need to go into Android Studio ?  I tried many things in Android Studio but as I don't know this tool, I'm not sure of what I should do. I tried Build>Generate signed apk, but there is 2 choices : Android App Bundle or APK. The first one throws an error saying I have to update gradle plugin, and the button to update it does nothing (I've searched how to update gradle, but this is a new ocean of crazyness). The second creates a ".jks" but I can not put it in the keystore field.

Can someone Help me ?
Thank you.
Cédric.
Who sadly spends more time googling than making games...
Unity 2018.3.0f2, Oculus Integration 1.32 (I guess, updated it 1 hour ago from asset store, there is nowhere the version information exists in assets folders).

Comments

  • RichooalRichooal Posts: 1,047
    Wintermute
    It seems to be a Unity problem, not an Oculus one. Try Googling Unity things. For example............

    https://forum.unity.com/threads/upload-failed-you-uploaded-an-apk-that-was-signed-in-debug-mode.188537/

    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • RichooalRichooal Posts: 1,047
    Wintermute
    Piflyon said:
    Ok, thank you Richooal,

    No problem I "like" to help.

    Piflyon said:
    Hope that will save time to others. If yes, like me ! :blush:

    Hmmmm, me too @Piflyon :o

    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • dmarfurtdmarfurt Posts: 2
    NerveGear
    Piflyon said:
    Ok, thank you Richooal, that leads me to a new track, then I finally got it to work.
    You saved me. Thanks Piflyon!
  • jrosenquistjrosenquist Posts: 3
    NerveGear
    That is totally insane. Thank you thank you thank you.
Sign In or Register to comment.