New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus won't connect to my laptop

DragonKnarkDragonKnark Posts: 4
NerveGear
I wanna start out by saying that i've been through several other threads to see if anyone else had the exact same problem as me, but despite there being simmiliarities, i couldn't find a solution that works. The issue is that when i run the program to set up my rift it'll only connect the usb part of the cable, not the HDMI. I've tried turning the OVRService on and off in the task manager, which has once in a while caused the light in the rift to go from orange to white (Which is good as far as i can tell). But beyond that, no luck.

My laptop has NVIDIA GTX 1050 TI graphics card, and the oculus compatibility tool registered no issues with the laptops capabilities. Reading other threads lead me to the conclusion that my HDMI output must be connected to the integrated graphics. And, this seems to be true according to the device manager.

However, according to the NVIDIA control panel, the HDMI output is connected to the NVIDIA card, as pictured below.

So, does anyone have any ideas? Could it be that my HDMI is connected to the NVIDIA graphics card, but the Rift or my computer decided to place it within the integrated card instead? I've tried disabling the integrated card, but that just turns of the rift entirely. I've heard people talk about displayport-to-HDMI adaptors, but i don't believe i have the right kind of port to insert it.
.

Comments

  • pierre.jette.62pierre.jette.62 Posts: 12
    NerveGear
    What is the model of the laptop? I have an ASUS GM501GS and at first had many problem connecting. I then discovered that if I put my laptop out of the Optimus mode, it connects flawlessly and instantly. Had to reboot though.
  • DragonKnarkDragonKnark Posts: 4
    NerveGear
    Its SharkGaming 3v15-50. Not quite sure what Optimus mode is, all i can find when looking it up is using the NVIDIA Control panel to change the graphics settings of individual programs, which hasn't been succesful.
  • pierre.jette.62pierre.jette.62 Posts: 12
    NerveGear
    I tried to read specs and software about your computer but the Web site seem to be in Swedish (?) only, and I don't speak your language.
    On my laptop (ASUS) there is a special key (on the keyboard) dedicated to an app called GamingCenter. In that app I can set (amongst a lot of different things) a mode (« Dedicated Graphic mode ») where the graphic card incorporated in the motherboard is switched off. The other mode (Optimus Mode) is supposed to do exactly that at the level of individual programs but it is not successful, exactly as yours.
    When I switch off the Optimus Mode, the laptop reboots, this time with the NVidia card by default. And that is where I can connect my Rift without any problem. If after playing the Oculus I want to go back to Optimus mode, I press the special key, click on the icon, reboot, and voilà. But to my eyes there seems to be only a negligible advantage with Optimus mode, the battery lasts longer between recharging. Marginally longer.
    I suggest you to check the manual of your computer. See if there is a special settings panel that makes the same thing, I mean a mode where the NVIDIA card is the default graphic card by default. And that panel will not be the NVIDIA panel (which "knows" only the dedicated card, not the mother board of the computer). Switching automatically and individualy by software does not seem to do the trick.
    It took me a few hours finding the right setting, but once found it is very easy to use.
    Good luck!
  • RichooalRichooal Posts: 1,196
    Wintermute
     And that panel will not be the NVIDIA panel (which "knows" only the dedicated card, not the mother board of the computer). Switching automatically and individualy by software does not seem to do the trick.


    I'm pretty sure that "Optimus" is actually an NVidia technology. I could be wrong though, I was once before. ;)

    https://www.geforce.com/hardware/technology/optimus

    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • pierre.jette.62pierre.jette.62 Posts: 12
    NerveGear
    You are right, Optimus is NVIDIA specific.
    The ASUS software lets you opt to get out of that technology. I suppose that you have to find how on your own laptop. 
    Investigating further, I found a very simple and clear explanation of how to disable NVIDIA Optimus mode and select the NVIDIA Graphic card by default. Only the few first steps apply to your problem (it is about Autodesk...), but could be interesting to give a try...
    https://forums.autodesk.com/t5/hardware-read-only/disabling-nvidia-optimus-amp-perform-clean-install/td-p/4363279

    and a few explanations, a bit more clear, here:
    http://www.tomsguide.com/answers/id-3332317/optimus-disable-onboard.html

    Be patient, and persist! Once you connect, then put the Oculus on your head, your life will change forever.
  • DragonKnarkDragonKnark Posts: 4
    NerveGear
    edited January 13
    Alright, i've been going through most of these answers, and so far i've had no luck. Opening BIOS, i didn't really find anything. And the guidebook for the laptop didn't help either. I tried contacting the company help line last friday, but it was outside their open hours, but they'll be back monday, so i'll trying asking there. I might go back to BIOS and go through it all again, see if i have any luck.

    EDIT: Actually, i almost forgot, i had managed to talk with one of the people from the computer company, and he had talked about shifting between something called MShybrid and MSdiscreet. Does this ring a bell to anyone? Looking it up didn't present much.
  • pierre.jette.62pierre.jette.62 Posts: 12
    NerveGear
    Did you try the "trick" suggested at the end of one of the links? Connecting your Rift to the HDMI, then disabling the display on the laptop screen? (Maybe...)
  • sford52sford52 Posts: 174
    Art3mis
    edited January 13
    ...  EDIT: Actually, i almost forgot, i had managed to talk with one of the people from the computer company, and he had talked about shifting between something called MShybrid and MSdiscreet. Does this ring a bell to anyone? Looking it up didn't present much.
    "Selecting MSHYBRID the computer's operating system (and some applications) will automatically switch between the integrated UMA (Unified Memory
    Architecture) GPU (iGPU) and the discrete GPU (dGPU) when required by the applications in use.
    Selecting DISCRETE graphics will force the system to use the dedicated Graphics Processing Unit (GPU). MSHYBRID is selected by default"

    I suggest you select DISCRETE to force the use of the dedicated Graphics Processing Unit (GPU)
    ASUS ROG Strix GL702VS-AH73 17.3" Laptop.  I7-7700HQ, GTX1070, 12 GB DDR4 RAM, 500 EVO 970 GB SSD, VS 2017, Oculus rift, Windows 10 home
  • DragonKnarkDragonKnark Posts: 4
    NerveGear
    Ah, so thats what it is. Now i just have to figure out where to go to switch between the two, thanks!
Sign In or Register to comment.