New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus worked for 2 days and now USB disconnects intermittently

Think880Think880 Posts: 2
NerveGear
Like the title says, things were working flawlessly for a while but now I can't get the headset to go two minutes without it disconnecting. In the middle of a game it will kick the video and audio to my computer monitor, only to reconnect a few seconds later. I'm worried about the implications that a device drawing so much power and disconnecting so frequently can have on my machine. The other thing is that this is a brand new unit that worked perfectly for a couple of days of heavy play and then kapoot. I have made sure that the USB settings don't turn off power or anything. 

CPU: Ryzen 5 1600
GPU: R9 390
Ram: 16GB

!!! I have noticed that bending the breakout cable causes the PC to kick out a USB not found error. This is a brand new cable and inspecting it shows no obvious signs of wear or tear. 

Things I am going to try tonight:
Powered USB Hub
Possibly a new PSU, but mine is 850W and gold rated so I'm not sure how this one isn't doing it.

Anyone with similar problems? Has anyone fixed this one? Any input would be helpful because I think my hair is starting to fall out...

Comments

  • falken76falken76 Posts: 2,680 Valuable Player
    I had this problem on my first rift.  I got mine way back in 2016.  I had to get an RMA.  If you got that Rift local retail, I'd take it back and exchange it for a new one, otherwise you'll have to open a support ticket.  On mine, it was a solder joint where the cable plugs into the headset.  If you're lucky it's just the cable.  My brother also has a rift so I was able to use his cable to test so that reduced the time involved in the RMA because I'm sure their first step would be to replace the cable, then they'd probably offer to RMA the item. 
  • Spalman_ytSpalman_yt Posts: 17
    NerveGear
    edited January 12
    I've had this problem too. My solution was a bad 3.0 USB extension cable. It worked fine at first, then started to disconnect and reconnect all my USB stuff (Rift, Sensors, Mouse, Keyboard) I have detached the extension cable and it works fine now.
  • Think880Think880 Posts: 2
    NerveGear
    @falken76, thank you for your reply. Given that it was a brand new unit, I never thought that it would have been the system. Turns out it was an issue with the cable connecting to the headset itself. Given that the unit was a week old, I just took it back to Best Buy and replaced it with a new one. Everything is up and working with no problems! 

    Thanks a ton,
    Think880
Sign In or Register to comment.