BUG - Can't perform mouse actions on virtual desktop in home with standard account. — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

BUG - Can't perform mouse actions on virtual desktop in home with standard account.

Richy_TRichy_T Posts: 7
NerveGear
Through a long series of events that I won't recount here but have documented here https://www.reddit.com/r/oculus/comments/ah5ubq/ok_question_about_virtual_desktop_in_new_home/ I think I have determined that the mouse actions on the desktop in home require some permission that isn't available to standard Windows accounts. Other virtual desktops work so there's no good technical reason for this.

Running in an Administrator account, particularly for gaming, is not good form although it's fairly standard in the Windows world. Hopefully Oculus will fix this but mostly I'm posting up in case anyone else is running into the same issue and is pulling their hair out.

If anyone knows which permission in particular is required, I could apply it individually to that account but I'm not going to give it full-on admin access and will just do without the virtual desktop for now. It would be really nice to be able to use it.

Comments

  • RichooalRichooal Posts: 1,053
    Wintermute
    edited January 18
    Have you done what the Oculus support guy asked you to do?
    Also, your post title, and post, sound like you're unable to use your mouse, but using your Touch Controllers for mouse actions is your problem.
    i5 6600k - GTX1060 - 8GB RAM - 0 PROBLEMS
  • Richy_TRichy_T Posts: 7
    NerveGear
    In the process of submitting a support ticket now. I'll make sure to be more clear about the touch controllers, thanks.
  • Richy_TRichy_T Posts: 7
    NerveGear
    edited January 27
    Well, Oculus support seems to regard it as "not a bug" and suggests that I run in administrator mode (not gonna happen). I pushed back a bit but not sure that counts for much. Hopefully this might be useful for anyone else who also is experiencing this issue.
  • LasceriusLascerius Posts: 4
    NerveGear

    Not sure if this matters to you anymore but through various steps I came to the same conclusion you did.

    Adding the user to Power Users will allow you to click and function within the Virtual Desktop. Through a bit of time and researching, the best I can gather is that Power Users is only there for legacy purposes, pre-Windows 7, and doesn't give more than a standard user (I can't find any real documentation stating it though, only some forum posts). Obviously it grants something as the desktop suddenly works with it. Here is one of those references though: https://www.quora.com/What-is-the-difference-between-a-power-user-and-administrator-in-Windows-7

    Sum up is, I could not find a way short of Power Users to make it work. I reached the peak of time I was willing to devote. I *might* test a couple of minor things to see if I can find real differences in access between Users & Power Users though. Maybe there is some legacy style coding within the app that Power Users helps?

    If you'd like, here are some of the things I tried in attempting to not join it to the Power Users group:
    I used Sysinternals Accesschk.exe and couldn't find any additional folder/file permissions given to power users. I checked the Local Security Policy and found no additional rights given there either. I tried some application compatibility shims to make it work without Power Users but was unsuccessful. I monitored with Procmon to see if there were any access denieds or things easy to identify that might be interfering. I'm not sure which of the multiple Oculus exes operate the virtual desktop, I tried OculusClient.exe the Home...64-shipping one and one other.


  • LasceriusLascerius Posts: 4
    NerveGear
    Actually after more digging I did find an official page supporting the no additional rights thing (making this *possibly* a solution you might be okay with): https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc771990(v=ws.11)

    The excerpt from the above says Power Users get No default user rights:
    By default, members of this group have no more user rights or permissions than a standard user account. The Power Users group in previous versions of Windows was designed to give users specific administrator rights and permissions to perform common system tasks. In this version of Windows, standard user accounts inherently have the ability to perform most common configuration tasks, such as changing time zones. For legacy applications that require the same Power User rights and permissions that were present in previous versions of Windows, administrators can apply a security template that enables the Power Users group to assume the same rights and permissions that were present in previous versions of Windows.

    Note: I did NOT apply any additional security templates to give more permissions. I simply added the user to Power Users.
  • EmpanadasEmpanadas Posts: 2
    NerveGear
    Thank you @Lascerius . I've had the rift since January and I've had the same issue with virtual desktop. I've been in contact with support for nearly 3 weeks and basically it has come to "reinstall windows". It's nothing short of aggravating. I've reinstalled the oculus software (twice before contacting them), updated drivers, and have tried every type of elevated user attempt to the point of giving myself admin rights and it still doesn't work.

    They also stated "Oculus Support does not have the contact information for any other teams within Oculus, we are also unable to transfer you there as they do not offer support, and Oculus Support does not have the ability to transfer people from one team to another."

    I'll add myself as a power user later tonight and see if it works.
  • EmpanadasEmpanadas Posts: 2
    NerveGear
    @Lascerius THANK YOU THANK YOU. A mod needs to sticky this thread.

    I added myself as a power user from netplwiz on the run command and restarted my computer (Windows 10 Pro). I then was able to use virtual desktop without issues! You've saved me a lot of headaches. Not everyone might be able to add themselves as a power user because it's a legacy service.

    I have no clue why a power user is able to use the virtual desktop but it works. It's strange because I added myself as an administrator and it still didn't work. It would be REALLY nice if someone from the Oculus software team could shed some light on this and maybe set up a patch if it's possible for standard users.


Sign In or Register to comment.