New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

MAJOR ISSUE!!! Stuttering, double image when Oculus Home and SteamVR are running simultanuously

WernerHeenopWernerHeenop Posts: 2
NerveGear
I have no issues with any of my Oculus games. I also have no issues with the handful of Steam games that have the option of "Play in Oculus VR Mode". However, any games i play in SteamVR causes Oculus home to automatically start up (This has been the case since late 2018). 

When both are running at the same time it causes a stuttering double image to appear during gameplay. The one image lags slightly behind the other. I am guessing both programs are trying to generate the image simultaneously which causes this blurry image. This makes the games unplayable.

Note: I can not shut down either of them. When I close Oculus OR SteamVR, it automatically causes the game to also shuts down. 

Please help, thank you.
Tagged:

Comments

  • ShocksOculusShocksOculus Posts: 255
    Nexus 6
    edited February 9
    Have you checked the STEAMVR settings? STEAMVR will AUTO supersample your games by default.  It determines the auto SS value based on your GPU. 
    It is a stupid setting, and most VR users disable it (set the value back to 100%). If not disabled (remember it's enabled by default), then it will affect performance in STEAMVR games.

    See this image on how to disable: https://imgur.com/WmdYGGz

    i7-7700k, GTX 1080Ti (11G) || MSI B150m (1 USB controller) + Inateck 4-port USB to PCIe (2nd USB controller)
    Oculus RIFT - 3 sensor Room-scale
    Oculus GO

  • WernerHeenopWernerHeenop Posts: 2
    NerveGear
    Thanks Shocks Oculus.  But that did not help.  
  • WernerHeenopWernerHeenop Posts: 2
    NerveGear
    When I play SteamVR games there is  double image rendered on the screen.  The one image lags slightly behind the other. I am guessing both programs (SteamVR and Oculus Home) are trying to generate the image simultaneously which causes this blurry image.

    MY ANALYSIS:
    -The problem started in late 2018, when Oculus Home's new update requires Oculus Home to start automatically when any VR game is launched (including SteamVR)
    -Any games I play via Oculus Home works 100%
    -SteamVR games with the "Play in Oculus VR mode" work 100%
    -THE PROBLEM HAPPENS WHEN STEAMVR AND OCULUS HOME ARE BOTH RUNNING AT THE SAME TIME
    Note: I can not shut down either of them. When I close Oculus OR SteamVR, it automatically causes the game to also shut down. 

    I HAVE TRIED: "Allow Unknown Sources" in Oculus, "Device Driver Uninstaller" and "switched Supersampling to manual" in steamVR.

    Please help, thank you.
  • WernerHeenopWernerHeenop Posts: 2
    NerveGear
    When I play SteamVR games there is double image rendered on the screen. The one image lags slightly behind the other. I am guessing both programs (SteamVR and Oculus Home) are trying to generate the image simultaneously which causes this blurry image.

    MY ANALYSIS:
    -The problem started in late 2018, when Oculus Home's new update requires Oculus Home to start automatically when any VR game is launched (including SteamVR)
    -Any games I play via Oculus Home works 100%
    -SteamVR games with the "Play in Oculus VR mode" work 100%
    -THE PROBLEM HAPPENS WHEN STEAMVR AND OCULUS HOME ARE BOTH RUNNING AT THE SAME TIME
    Note: I can not shut down either of them. When I close Oculus OR SteamVR, it automatically causes the game to also shut down. 

    I HAVE TRIED: "Allow Unknown Sources" in Oculus, "Device Driver Uninstaller" and "switched Supersampling to manual" in steamVR.

    Please help, thank you.
  • TomCgcmfcTomCgcmfc Posts: 737
    3Jane
    This could be caused by doubling up Steam super sampling.  Go into your SteamVR settings and make sure the slider is set at 1.0.  Also check you don’t have any filters enabled.  Try googling steamVR with oculus for more leads on this.  Good luck.
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!
  • YoLolo69YoLolo69 Posts: 1,106
    Wintermute
    Check OpenComposite (https://gitlab.com/znixian/OpenOVR/blob/master/README.md) and get ride of SteamVR if your games are supported (work fine for my IL-2 Fly sim, lot of other are supported). You'll avoid to run SteamVR and all those filters and "improvements" is trying to make. You just have to drop a DLL file in your game directory (backup the old one). If you were using SteamVR Supersampling, just use OTT or OculusDebug.exe instead.

    “Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

    "Be careful, if you are killed in real life you die in VR too." - TD_4242

    I7 3770K OC 4.6GHz, GTX1080 OC 10%, 16GB DDR3 2448  OC, Oculus Rift CV1

  • MAC_MAN86MAC_MAN86 Posts: 1,452
    3Jane
    edited February 16
    I'm thinking the auto-updates don't go well if anything else is open during Installation. Could this be the issue?
    Does a Repair Install work as suggested by Support?
    https://forums.oculusvr.com/community/discussion/73567/graphics-jitter#latest
Sign In or Register to comment.