New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How do I stop Rift from auto starting at every slight movement?

ChannelJohnChannelJohn Posts: 1
edited February 2019 in Support
First, let me say, I've had my Oculus Rift for several years and I've never had this problem with it. Suddenly, in the past month or so, any time the Rift is slightly touched, it's cord is slightly jiggled, or anything moves anywhere near it, my screen goes black for several seconds and Oculus Home launches. I get annoyed, close Oculus Home, and wait through several more seconds of black screen while it closes before I can go back to what I was doing, only to have it happen again and again and again whenever anything slightly touches the headset or its cord. 

Since I know you'll ask (having read the other discussions here), I keep the Rift headset on the floor, off to the side of my desk, about 3 feet away from me and my chair. I've had it in that spot for years and have only just started having this problem very recently.

TO BE CLEAR: I'm not picking up the headset and not moving the headset (besides MAYBE the tiniest of bumps occasionally, equivalent to a small tap of the finger on its side while it sits, face-down, on my floor).  Most of the time, this happens when, e.g., the cord of my regular headphones brushes up against the cord of the Rift (which causes the Rift to move VERY slightly because physics).

What I'm looking for is either (a) a way to dial down the sensitivity of the headset movement that causes Oculus Home to start (not likely, I know), or (b) a way to tell Oculus Home NOT to launch when the headset is moved (which SHOULD be extremely likely). 

I've searched through the forums and support, but all I'm finding are people who want to stop Home auto-starting when Steam opens (a problem I don't have). The one guy who had a similar question to mine was looking to keep it from auto-starting even though he had the Rift on his head. I just want mine to be able to sit on the floor near my desk without every slight jiggle of cord or movement in the vicinity of the Rift starting Home. It's getting REALLY frustrating.

And, yes, I know there will be some snarky person here who will suggest I move it away from any cords or anything that might touch it. I get that. I could do (and probably will try it) BUT we're not talking about significant movements and, either way, I shouldn't have to. I should be able to tell my computer or the Rift to not launch software every time the cord is bumped.

Am I wrong that it was not this sensitive before? I've not had this problem until sometime in the past 30 days or so.

Any help anyone can offer on this would be most appreciated. After searching these forums for various phrases relating to my issue, I found 100 pages (totaling 1000 results). Reading through as many as I could take, all the ones I saw had to do with stopping auto start on Steam launch, not on movement of the headset. So, here I am. 

Thanks in advance for any advice, help, or helpful fingers pointing in the right direction.


  • DaftnDirectDaftnDirect Posts: 5,805 Volunteer Moderator
    edited February 2019
    The Rift shouldn't launch Oculus Home when it's moved at all, no matter how much you move it. The activation should be via the proximity sensor next to the light inside the headset. That gets activated only when you put the headset on, or you put you finger or something else over or very near to the sensor.

    You say your headset wasnt always that sensitive, but was your headset always being activated by movement instead or by the proximity sensor? If so, then there's always been a problem with your Rift.

    Is there anything in the headset, near that sensor? Are you using a Vr cover for example that has maybe moved too near the sensor?  if not you could try reinstalling the Oculus software/drivers.
    Intel 5820K [email protected], Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v2004 (19041.330)
  • YoLolo69YoLolo69 Posts: 1,132
    I thought it was a combination of the proximity sensor AND a movement. In any case it shouldn't react when you move it, at least mine don't for sure. Possibly you added a Cover to your Rift and the sensor is triggered?

    “Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

    "Be careful, if you are killed in real life you die in VR too." - TD_4242

    I7 3770K OC 4.5GHz, GTX1080 OC 10%, 16GB DDR3 2448  OC, Oculus Rift CV1

  • DaftnDirectDaftnDirect Posts: 5,805 Volunteer Moderator
    As far as I'm aware, the proximity sensor alone is what activates the Rift.

    As well as checking there's nothing near the sensor. Also check that the 'bypass proximity sensor' hasn't been checked in the debug tool.
    Intel 5820K [email protected], Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v2004 (19041.330)
  • kojackkojack Posts: 6,468 Volunteer Moderator
    Movement has never been an activator for the headset. It's purely the proximity sensor.
    The sensor is a pulsing IR light next to an IR sensor. If the pulse bounces off of something back to the sensor, it activates the rift.

    One thing that can affect it is third party covers. I've got the VR Cover (cloth one) on my rift. Often the cover sags down a fraction too far and triggers the headset. Mine used to activate randomly, until I realised it was the cover. When I take the rift off I now automatically push the top part of the cover up so it's away from the sensor.

    Also check that the sensor isn't dirty (or has a hair or something hanging in front of it), it could be triggering itself.

  • nalex66nalex66 Posts: 5,505 Volunteer Moderator
    The overhead strap can also trigger the sensor if it's tucked down into the space between the lenses.
    i7 5820K @ 4.25GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
    SSDs: Intel 660p M.2 2TB, Samsung 860 Evo 1TB, 850 Evo 1TB, 840 Evo 1TB | Startech 4 controller PCIe USB 3.0
  • Rootkit-Rootkit- Posts: 1
    Okay geniuses... So my headset DOES starts the Oculus home program at even the slightest movement. I work with component gyroscopes and accelerators for a living, and I can confirm for a fact that my particular headset is responding solely to movement / rotation on any x, y or z axis. I find this strange because this never occurred before. Running the current version of software. Very annoying when you live with a cat btw. Should  I send this over to NASA?
  • blackswamperblackswamper Posts: 1
    same issue here, been about 6 months now, slightest breeze in the room launches app, doesn't matter if it is covered, uncovered, sitting upright, on a stand, on the floor, behind the tv, inside a box, surgical vacuum, my headstrap is quite rigid and out of the way from the face sensor. If a micro-vibration above .01 Richter occurs my app launches. I have Settings> General > Automatically Launch Oculus Home, turned off. Never used any dev tools, just installed it and ran it for years without an issue. Uninstall, reinstall...that's all we got? Guess I could just leave it on all the time...?...
Sign In or Register to comment.