New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

ASW causing massive judder

PsycosmPsycosm Posts: 6
NerveGear
SO I've been having issues with getting judder for the last several months, mainly while playing elite dangerous, but also whenever going to the oculus menus. Recently it's started with pretty much any game. The frame rate isn't dropping, but the display looks like it's running at about 4 frames a second. Turning ASW off with the tray tool stops the issue, but then I don't have ASW helping out as it should. My pc is an aging beast, i5 4590 and a gtx 980 but the problem doesn't seem to correlate with performance drops, I can be getting 90 fps and have the problem, I can be running below 45 fps and have a reasonably smooth experience, but the problem only happens when I have ASW set to auto, or if I'm not running the try tool at all which I assume also puts it on auto.

I'm not sure if it has something to do with tracking as the games seem to run smoothly if I keep my head dead still, but as soon as I start looking around it jumps around in a shocking fashion, making the rift unusable.

Is there any solution to this (other than the obvious upgrade route, the budget doesn't have the love for that for a while.

Comments

  • LZoltowskiLZoltowski Posts: 6,774 Volunteer Moderator
    When this happens have a look at CPU usage in task manager. See if it's sustaining it's turbo boost frequency and what is the utilisation. Sounds like CPU is struggling (tracking heavily relies on that)

    Just lift your HMD when this happens far up enough to see your monitor, but not high enough to trigger the IR sensor and turn it off and open up windows task manager.

    Let us know what it says!
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    I had the GTX970 before my GTX1080 SC2, even though I used it on a Xeon Quad 3GHz I always needed to disable ASW. Elite is not cpu intensive, try being efficient with Settings: AA=FXAA, SS=1, HMD=1, no Blur, no Depth, default Redraw distance zero (same for terrain), Bloom=Medium, Shadows=Medium, but crank all others as high as you can to really push the gpu (this works better this way!). I use to use Precision X for my 970 on KBOOST which worked very well. Sure it was intended to max out for Bench Marking but your game needs it! With the 9*series cards they need custom fan profiles to actuate them before the game will crash so be sure your fans spin up when running the game. I'd get around 30 to 45fps mostly in Elite without ASW which was fine and it wasn't stuttering.
  • PsycosmPsycosm Posts: 6
    NerveGear
    Thanks for the tips, I'll try them out and report on what happens
  • YoLolo69YoLolo69 Posts: 1,129
    Wintermute
    ASW is a great peace of technology but it have a caveat : the very short moment it decide to kick ON or to turn OFF. So if you're on the edge of maintaining 90fps it could be a judder mess. So you have the choice to live with that, to turn it OFF, or to turn it always ON and have 45fps (translated to 90fps) which is acceptable for lot of games. For others it create too much artifacts. Saying that, check effectively the turbo boost for your GPU. You can push it nearly always ON by changing NVidia setting with the "Power Management" choice, for all your applications (main 3D settings) or for a specific game.

    “Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

    "Be careful, if you are killed in real life you die in VR too." - TD_4242

    I7 3770K OC 4.5GHz, GTX1080 OC 10%, 16GB DDR3 2448  OC, Oculus Rift CV1

  • FrontierSupportFrontierSupport Posts: 120 Oculus Partner
    If the steps above don't help, please do send us a ticket via: https://support.frontier.co.uk/kb/ and we'll be happy to assist. 

    -CMDR Vulcan
  • PsycosmPsycosm Posts: 6
    NerveGear
    Hey guys, sorry I've been slack in replying.

    I'm not so sure that its linked to ASW now, it definitely happens less when it's off, but I still get it. I can't find any reason for it, there's no performance issues indicating anything, cpu and gpu are constant whether the judder is happening or not.

    Ive tried reinstalling, I've even reformatted my pc. Sometime i t happens regularly, sometimes it happens for a few seconds and disappears.

    If I take my headset off for a few seconds it stops and I get smooth performance for a while, but it comes back pretty quickly.

    It only seems to be happening with steam games though, maybe some clash with steam vr?

    I'm at a loss, I don't know where to look top determine whats causing the problem. Any ideas?
  • mcdaniels2k9mcdaniels2k9 Posts: 5
    NerveGear
    edited March 2019
    Just spend my 2 cents here. I am nearly having the same issues. In my case the judder/studder/ghosting happens in flightsims. With ASW auto I get terrible ghosting (if the objects move fast, the propeller for example- which is moving fast - destroys the gunsight - which gets blurry). If I switch off ASW the whole environment in the flightsims is blurry, when oving my head and I get motionsick.

    I just bought an NVIDIA RTX 2080 because I was thinking that my GTX 1070 is  running at too high load (99%) when flying around.
    CPU: AMD RYZEN 1700X @3.8GHZ
    RAM: XMP Profile off (doesnt help), now running at 3096. 32GB
    GPU: NVIDIA Gforce RTX 2080 8GB
    OS: Windows 10 x64 (fresh install / only rift / the drivers of the components and the flightsims)

    Switched through all my USB 3.0 Ports for the rift.
    Disconnected my monitor before flying
    Played around with the settings in the flightsims (all to lowest does not help)
    Getting stable 45 FPS when running with ASW  (judder/ghosting)
    GPU load: 56%
    CPU load: 20%

    The new GPU does NOT HELP at all, The CPU is drinking tea, while calculating the data of the sims, jumping on one leg and juggeling.

    It happens on both flightsims (different publisher).

    So, OCULUS STAFF, what is going on here?
    Is this a OCULUS-Software issue?
    Is this a NVIDIA problem? (are there known issues) -> I can't go back too far concerning the driver, cause the GPU is very "new".
    Why isn't there a possibility to track that kind of issue down? (Diagnostics?)

    Really annoyed, because no one can help and we - the customers - are only investing our money and time...
  • MradrMradr Posts: 3,757 Valuable Player
    edited March 2019
    Getting stable 45 FPS when running with ASW  (judder/ghosting)
    GPU load: 56%
    CPU load: 20%

    is your ASW set to always run? Other wise that doesnt make much sense really. If you are not getting cap - then leave it off - with that said - you might just have to live with the fact there is going to be a bit of ghosting. The game just sounds demanding really. Also, if you are seeing ghosting with it off - it sounds like its not hitting the 90HZ refresh or lower than 90 FPS. IF that is the case - then lower the settings in game. If it seems blurry - you could try lowering the settings and bumping up your SS settings to get a clearer picture. Flight Sims are really picky about every setting in the book honestly. It might take a bit of time and fighting the settings to get everything perfect.
  • mcdaniels2k9mcdaniels2k9 Posts: 5
    NerveGear
    Hi,
    and thank you very much for your comment. If my ASW is always on I always get ghosting concerning faster moving objects (when a plane flies by).

    If I switch it off completely, I get doublepicture when doing a roll (fast moving) coming from the scenery (not when a plane flies by). Neither of the settings give a good experience.

    The settings in game are as low as possible.
    I don't get the point why cpu und gpu are far from being stressed and I am getting this things in both games.



  • MradrMradr Posts: 3,757 Valuable Player

    If I switch it off completely, I get doublepicture when doing a roll (fast moving) coming from the scenery (not when a plane flies by). Neither of the settings give a good experience.



    That sounds like screen tearing to me - something like this?
    Image result for screen tearing

    That usally cause by the fact its not sync correctly - again possible you are drop frame in between draw when you do these fast rolls - so it might be a setting/performance issue in your case. If there is a way to turn on your video card sync - I would try that and see if that helps. Other wise - your best bet is you might just have to live with it for a while.

    Not sure if it is possible-  might take a screenshot
  • mcdaniels2k9mcdaniels2k9 Posts: 5
    NerveGear
    Hi,
    is it possible to take a screenshot of the Rift? Hm, can you please tell me how? :-)

    yes, it is looking very similar, tearing is a better word for it.

    Do you mean V-Sync?
  • mcdaniels2k9mcdaniels2k9 Posts: 5
    NerveGear
    edited March 2019
    just tried a few things in the sim (offline gameplay) now, having oculus debug tool performance monitor running too. The Framerate is at stable 90FPS, suddenly goes to 45 (with ASW OFF!) although there is no change on the screen and jumps back to 90FPS. Most time it runs with 90FPS.

    If I go online Framerate is jumping around, never reaching 90FPS and I get those blurry pictures. Why this is only happening online -> NO IDEA! This might be no oculusproblem, this is a bad implementation of multiplayer, which seems to be a resource hog...

    So the only thing I bought the rift for is "gone" for me. And the best thing about it is, that I upgraded my whole PC for €1200 getting this shi... gameplay and trying to solve this issue!
    Nice!

    Thats really how you push the $$$
  • MradrMradr Posts: 3,757 Valuable Player
    edited March 2019
    Well you could report your findings to the game company and see if they have any tricks or fixes for you. I understand how frustrating that can be, but don't give up hope. I am sure there are other games and software that matches that style and game play. Its possible - not likely - that its your CPU as well or network issue as far as your local network (wireless vs cable) or bad modem/router.
  • mcdaniels2k9mcdaniels2k9 Posts: 5
    NerveGear
    edited March 2019
    CPU upgraded today. No change!
    posted a lot of things at the game company and opened a ticket a few days ago.
    Tested different NICS, different router, direct attached.

    !!!SOLVED!!!
    Unbelievable! Your words about the "network issue" made me think about thinks again.
    1.) Offline it is working pretty good
    2.) Online it breaks down (FPS drop as hell)

    So I decided to try different drivers for my NIC (Intel). I cannot believe it -> Not it is running @90FPS online!

    Thank you man, for "brainstorming"

    AWESOME!!!

    EDIT2: One server which never worked runs now at 90FPS, anotherone is making same troubles.... 45FPS.

    This is no riftproblem, I think.

Sign In or Register to comment.