Issue with ASW turning off and uncapping the framerate, causing stutters — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Issue with ASW turning off and uncapping the framerate, causing stutters

JayRiley_JayRiley_ Posts: 4
NerveGear
I have an issue with ASW and Elite: Dangerous on the Rift. My computer is not powerful enough to run the game at 90fps all the time, so i want ASW always on. However, within Elite ASW keeps turning off a couple seconds after putting the rift on my head, and sends frame rate to 60-70. this of course causes jittering, which is absent for the first 5 seconds when its capped at 45fps. Does anyone else have this issue? What could be causing ASW to randomly turn off even though ive enabled it?

Answers

  • MAC_MAN86MAC_MAN86 Posts: 1,715
    3Jane
    What key are you using? It's Left CNTRL + Numpad 1 = OFF which means it will be free to move. If it locks to 45FPS then it's on auto as that selects 90 or 45 if it can't manage that. If it's on AUTO then it may act different which seems to be your case. On a slow PC I found it best left OFF which keeps it at least smooth for what it manages. If you're pushing your GPU then perhaps consider another 1/4 less HMD SS. I have mine on 1.5 even though it can stick on 45 always at 1.75 Other settings may help e.g. zero Redraw Distance, Medium or High Shadows. Obviously Blur & Depth are OFF. Minimise your AA to FXAA or try none but add DSR in Nvidia 3D Settings instead.
    I have noticed however, once you begin to change ASW bindings they do tend to get caught up in a bottleneck due to the SS as RAM is taken up to make the changes happen. It may be settled upon another Restart. Any 3rd Party Apps add up to eating RAM.
  • JayRiley_JayRiley_ Posts: 4
    NerveGear
    Using ctrl + numpad 3/4 i still dont get the result im looking for. Ive also used the Oculus Debug tool, and tried using OTT to force 45 fps. Whatever i use to try and force ASW, it always turns itself off. I will have to try messing with the settings some more inside Elite though
  • FrontierSupportFrontierSupport Posts: 100 Oculus Partner
    edited February 25
    Hey Jay, 

    If the problem persist, I'd recommend reaching out to Oculus support via: https://support.oculus.com/885981024820727/

    If you find that the problem is specific to Elite Dangerous, please get in touch with us via:
    https://support.frontier.co.uk/kb/

    -CMDR Vulcan
  • MAC_MAN86MAC_MAN86 Posts: 1,715
    3Jane
    edited February 25
    Check Vertical Sync is OFF else it brings it down to 60. Also frame limiter is set to 90. Are you using any VoiceAttack binds that may mix with those binds and maybe LeftCTRL is stuck? 
  • JayRiley_JayRiley_ Posts: 4
    NerveGear
    edited February 25
    MAC_MAN86 said:
    Check Vertical Sync is OFF else it brings it down to 60. Also frame limiter is set to 90. Are you using any VoiceAttack binds that may mix with those binds and maybe LeftCTRL is stuck? 
    Vertical sync is off, yes. No, i dont use Voice Attack. Also, I rarely use the keybinds to turn ASW on, i usually use the Oculus Debug Tool, so ctrl being stuck wouldnt affect me
  • MAC_MAN86MAC_MAN86 Posts: 1,715
    3Jane
    edited February 25
    Perhaps try Oculus Tray Tool instead. Some of the ODT versions may not all continue to work as intended. For me, I always used to bind it to OFF instead. Or check without ODT and use the binds to alter except bear in mind it is default as Auto (4). If it stutters on occasion then surely you need it always OFF or always ON. Something in your 3D settings maybe changing the state, e.g. I thought Adaptive V-Sync but may as well use Nvidia Panel>3D Settings>Elite to V-Sync OFF to be sure in case it's on Adaptive which allows ingame to conflict perhaps.

    CTRL+Numpad1: Disable ASW, go back to the original ATW mode

    CTRL+Numpad2: Force apps to 45Hz, ASW disabled

    CTRL+Numpad3: Force apps to 45Hz, ASW enabled

    CTRL+Numpad4: Enable auto-ASW (default, use this first) 

    If any consolation, I get freezes when close combat with lots of laser fire up close and my gpu dips. No idea why that would cause mini freezes unless it's my audio at 48k causing bottling. It's like I can push it high but it needs much more at those critical moments.


  • TomCgcmfcTomCgcmfc Posts: 890
    3Jane
    Rift headphones should be set (windows sound settings) to 44100hz (cd quality) and no enhancements.
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!
  • JayRiley_JayRiley_ Posts: 4
    NerveGear
    MAC_MAN86 said:
    Perhaps try Oculus Tray Tool instead. Some of the ODT versions may not all continue to work as intended. For me, I always used to bind it to OFF instead. Or check without ODT and use the binds to alter except bear in mind it is default as Auto (4). If it stutters on occasion then surely you need it always OFF or always ON. Something in your 3D settings maybe changing the state, e.g. I thought Adaptive V-Sync but may as well use Nvidia Panel>3D Settings>Elite to V-Sync OFF to be sure in case it's on Adaptive which allows ingame to conflict perhaps.

    CTRL+Numpad1: Disable ASW, go back to the original ATW mode

    CTRL+Numpad2: Force apps to 45Hz, ASW disabled

    CTRL+Numpad3: Force apps to 45Hz, ASW enabled

    CTRL+Numpad4: Enable auto-ASW (default, use this first) 

    If any consolation, I get freezes when close combat with lots of laser fire up close and my gpu dips. No idea why that would cause mini freezes unless it's my audio at 48k causing bottling. It's like I can push it high but it needs much more at those critical moments.


    Thank you for the response. I tried all of these, and i still have an issue with ASW saying it is on, but my framerate isnt actually capped like it should be. Im getting tired of this issue, and might have to give up soon.
Sign In or Register to comment.