I'm having problems with "laggy" hands, any suggestions or tips? — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

I'm having problems with "laggy" hands, any suggestions or tips?

MidgetMullerMidgetMuller Posts: 2
NerveGear
Hello, i've had my Rift for about a month now and it was working perfect. I recently reinstalled Windows 10 and this time after i went through the setup and got into the Oculus Home the virtual hands were lagging around. They also would continue a movement to the point where they would break my guardian boundaries even though i was physically no where close to them. I was just wondering if anyone would know what would cause this problem to come about? 

If it helps to know my setup here it is...
- Oculus Rift
- Touch controllers 
- 3 sensors (2 using USB extenders( https://www.amazon.com/gp/product/B0179MXKU8/ref=ppx_yo_dt_b_asin_title_o04_s02?ie=UTF8&psc=1 ))

I have two sensors plugged into my front panel ports on my case and the third plugged into the back of the case. Also during the setup and also in the Oculus application itself under devices there are no warnings or errors everything was and is green and seems to be working fine. I have a PCIe USB hub coming tomorrow just incase there was some problem with how they were plugged in. If there is anything else you guys need to know that could maybe help you help me let me know, thank you!

Answers

  • AlextendedAlextended Posts: 50
    Brain Burst
    edited March 3
    I have the same issue, my Rift worked perfectly in the past, I even commonly used supersampling of 1.3 in even the most demanding games, but now it seems as if performance is shitty everywhere including Home and the hand (but not the headset) tracking is wonky and drifty and all over the place. If I do an abrupt from up to down motion then the hands will often continue traveling downward for a second disappearing in the distance until they reset to where my hand actually stopped, even the mouse cursor when checking out the desktop window lags way behind the VR pointer dot. Everything is broken I guess.

    The only thing I can think of that actually changed is, perhaps similar to you, the latest Windows10 cumulative update:

    I've tried everything I could think of, I've reinstalled Oculus, reset all OCT settings, reset all my Nvidia Control Panel settings, reverted to the non-beta version of Oculus just in case it was an experimental update pushed on that, nothing changed. The desktop Oculus app doesn't show anything wrong with the devices and their performance but the Home performance indicator shown when you press the left Touch controller's menu button does change from green to worse.

    I have 16GB RAM, an old i7 3770K overclocked to 3.7GHz (pre-Boost, so around ~4GHz or more when gaming, it never throttles) and a GTX1080 (also slightly OCed and it's always fine in temps and such even in the most demanding games like most recently Metro Exodus) so it's not really an actual hardware performance issue and the situation remains in games that were perfectly playable, whether demanding like Onward (where I can't aim for shit) or light like Beat Saber (I can't perform at all). It's been rendered completely unplayable for anything that has motion controls, I haven't tried gamepad games yet...

    Non VR games don't show any difference in behavior so whatever happened only affected whatever I run with Oculus.

    Edit: my setup is a 2-sensor set up and I did have some USB issues in the past but have solved them by removing my less used USB devices like a bluetooth dongle that I only used with my DualShock4 which I can just use wired when I need it, I'm using an inateck 4-port USB 3.0 PCI-E card (I have also tried switching between the fresco logic and the built-in Microsoft drivers which solved the warning in the Oculus software but otherwise didn't really change anything, it worked either way in the past).

    :(
  • MidgetMullerMidgetMuller Posts: 2
    NerveGear
    I was talking with the Oculus Support Staff for a couple of hours today and they were able to fix it. The problem was something in that Windows update. These are the steps the told me to do...

    "Did the Windows update you mention happen between March 1st and now? If yes, or you are unsure, please try the following:

    1. Open the Start menu type the following, and then press enter: Installed Updates
    2. In the window that comes up, click on "Uninstall updates," and in the list that comes up locate update KB4482887.
    3. If update KB4482887 is present, uninstall it, and let me know if that fixes it.
    After i uninstalled that update (Which if you look in the link in your post it matches) it was fixed. I hope this fixes your problems!
  • sford52sford52 Posts: 136
    Art3mis
    Well!  For all the bashing we level at the Oculus staff, kudos to them for resolving this issue for you.
    And, added appreciations to you for coming back and presenting the resolution.
    ASUS ROG Strix GL702VS-AH73 17.3" Laptop.  I7-7700HQ, GTX1070, 12 GB DDR4 RAM, 500 EVO 970 GB SSD, VS 2017, Oculus rift, Windows 10 home
Sign In or Register to comment.