New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Touch Controller Twisting/Rolling Causes Tracking Loss

AiRJacobsAiRJacobs Posts: 2
NerveGear
I am having tracking problems with the Oculus Touch controllers that no one else seems to have. I searched all over the web, but no one has mentioned a problem like this. I think this may be the problem a lot of people are having, but they don't realize it. Hopefully this brings us one step closer to an answer.
Here is a video demonstration of the issue.
https://youtu.be/_dh1QE_vZik
This is what I am calling the "Twist/Roll Test". I have found that if you rapidly twist your wrist with controller in hand, you can cause the positional tracking to cut out. I have found it to be a very consistent problem and easy to recreate. However, as long as I don't do exactly as I stated, my tracking is flawless.
I have tried numerous USB configurations, changed USB cards, updated drivers, reinstalled Windows 10 and even changed motherboards at one point. The problem still persists.
I have a few theories
  1. Oculus Sensors are not fast enough
  2. USB bandwidth is not enough (I ordered a StarTech PEXUSB312A2 to try (the StarTech PEXUSB3S44V I tried never worked)
  3. There is a software problem with the latest Oculus software, the latest Windows 10, or some other drivers
System Specs:
OS: Windows 10 Pro (x64) Build 17763
MOBO: MSI B350 GAMING PLUS
CPU: Ryzen 5 1600
RAM: G.Skill FlareX DDR4 3200Mhz 8Gbx2 (16Gb)
SSD: WD Blue M.2 500Gb
GPU: EVGA GTX 1080
Sensors (all are on different USB Host Controllers, so no shared resources):
- Sensor 1 (Front Left): USB 3.0 - Inateck Superspeed 7 Ports PCI-E to USB 3.0 Expansion Card
- Sensor 2 (Front Right): USB 3.0 - Inateck Superspeed 5 Ports PCI-E to USB 3.0 Expansion Card
- Sensor 3 (Rear Left): USB 2.0 - Mobo USB 3.0 Port
- Sensor 4 (Rear Right): USB 2.0 - Mobo USB 3.1 Port
TPCast with OpenTPCast v2.0.1 installed
NIC for TPCast Router: Rosewill RC-411v3
Sign In or Register to comment.