New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Sideloaded App and Release App - Update Conflict

camtynes_PNNLcamtynes_PNNL Posts: 10
NerveGear
Hey all. I've done some tests, and I just want to confirm if anyone else has experienced this, and/or it's perceived as expected behavior (maybe someone from the Oculus team can comment).

I have an app that has typically been sideloaded onto the Go and that's worked fine, but now we're getting to the point where we're putting the app on many devices for QA and it's not worth the time to sideload, so we have the app in the beta channel so we can distribute easier. When I update the app in the beta channel with a newer version, I get the "Update" button on the app in my library (on device), but when I click on Update, it shows a progress bar as if it's downloading the update and ultimately nothing happens. The download/update bar closes and the "Update" button reappears so the app doesn't update. Internet connection is fine. At first I was puzzled and then suspected it might be because the device still has the older and no-longer-in-use sideloaded version of the app. I completely removed the sideloaded version of the app via ADB, tried running the update again and it still didn't work. Finally, I uninstalled the beta app so now both apps are no longer on the device, and re-installed the beta app to my library. Now when the beta app is updated in the dashboard with a newer version, the "Update" button works and the app updates.

I'm wondering if anyone else has experienced this before; additionally, it seems obvious this would cause a conflict, but I'm curious if this is expected behavior.
Sign In or Register to comment.