New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus games won't install

CleverEagleCleverEagle Posts: 2
NerveGear
Hello,
For about a month, I've been having an issue with the Oculus desktop application. When an update comes out for any one of my games it fails to install, not including Oculus software updates. In the Installation phase, the bar will sit at 0% for 15 seconds or so, and then I will get a notification saying, "Sorry, we couldn't install [This App]. Visit Oculus Support to get help." Oculus will then re-schedule the app update in my Updates tab. The only reason I haven't done anything yet is because moving the app between library locations (Through the Oculus app) allows the app to install and temporarily fixes the issue for that app. Attached are the last two "blocks" of the log file where the issue was present while trying to update RecRoom. I am running Windows 10 with NVIDIA GeFore GTX 1070 and an Oculus Rift.
Any help is appreciated.
Thanks!

Comments

  • OculusSupportOculusSupport Posts: 359 Oculus Staff
    Hey @CleverEagle, I'm sorry to hear you're having problems updating your games. Have you tried disabling any anti-virus software (including Windows Defender)? Looking at the log info you provided, it looks like another process is accessing the needed file. Please contact support with your full Oculus Diagnostic logs so we can look into this further for you. Thanks! -Rick
  • CleverEagleCleverEagle Posts: 2
    NerveGear
    Hello,
    I tried disabling antivirus. It didn't work, although I found the cause of the problem.
    I discovered it during my searching through the log file. In every instance of error 46 (ErrorInstallingStagingFiles), the log mentioned "[Warning] Moving unknown file in old installation to new: [File name]". For RecRoom, it only had 1 file logged as such, Recroom_Oculus.gc.log (C:\Program Files\Oculus\Software\Software\against-gravity-rec-room\Recroom_Oculus.gc.log). Other apps had more, sometimes 60 or 70 files. Since it was clearly a log, I tried removing it from the folder and running the installation. It worked!

    The library service must not recognize these files as being part of the game. This would make sense of the fact that moving the game worked, because the library service would not have moved the unknown files with the game, and thus deleted the unknown files along with the old game directory, allowing future installations to progress. The problem files must be largely unimportant (Such as log files) or I would have a lot of crashing games. I still don't know why those files interfere with installation. Maybe an alternate Oculus program started up to handle the unknown files, and prevented the main process from accessing them? I don't know. The unknown file problem probably originates from a glitch related to the manifests at "C:\Program Files\Oculus\Software\Manifests\[App Name].json" where the unknown files are not listed.
    Attached is the full log file, if anyone wants to have a look at it. The problems start at 1/8/2019 2:22:42 PM, line 68810. I tried temporarily removing the manifests and that is what caused an error 47 (ErrorInstallingStagingDirectory) on lines 105379-105419. I have also included RecRoom's manifests (in txt filetype).
    Thanks!

Sign In or Register to comment.