New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Flashing red led

rwigginsrwiggins Posts: 1
NerveGear
hello,

I’ve been getting a flashing red indicator light on my go when I plug it in to charge, however it does not appear to be charging. I read the indicator light meanings in the faq, but it doesn’t say anything about a  The flashing red light so if anyone could tell me what a red blinking light means that would be very helpful. Also I tried holding down the power button for 20 seconds and that does cause the flashing rate to momentarily change as if it’s considering doing something else but then it goes right back to flashing red. 

Comments

  • OculusSupportOculusSupport Posts: 344 Oculus Staff
    Hey @rwiggins, I'm sorry to hear you're having problems with your Oculus Go. Please try using a different charger and charging cable to see if it will charge. If it still won't charge, your Go may have a hardware issue. Please contact support at https://support.oculus.com so we can help you out. Thanks! -Rick
  • JimDaystarJimDaystar Posts: 1
    NerveGear
    edited August 20
    Changing to a different charger worked for me. Thanks. [SOLVED]
Sign In or Register to comment.