New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

USB 3.0 not Recognized

Wrayth187Wrayth187 Posts: 3
NerveGear
Picked up my Rift S yesterday and started the app and plugged in the USB then the HDMI.  Started and finished firmware update and then got the red X over the USB on setup.  Worked fine on my Rift for months.  Tried the Checkup program and everything was green except USB 3.0 now.  It even stated my ASmedia 3.0 extension Host controller wasnt recognized.  I worked on it for 8 hrs uninstalling and getting new drivers for the USB with no luck.  I ordered a new PCI-E USB 3.0 from Amazon.  Think this will fix the issue?
Tagged:

Comments

  • Satyr604Satyr604 Posts: 5
    NerveGear
    Had the same thing happen to me, man. Except that, at times, the red X would flash to a check mark before immediately disconnecting again. Or, once in every dozen or so times, actually continue on to the sensor check before bumming out again.  Customer support told me the Rift S tends to not play nicely with Asmedia ports. Which, you know, would've been fun to know before buying the headset. 

    A user on Reddit pointed out to me that the exact same problem existed with the Lenovo Explorer, a VR headset by Lenovo. Which Oculus teamed up with to develop the Rift S. Lenovo never formally adressed or fixed the issue. I started digging a little more on Google and found out that most people were able to fix it with a PCI-E to USB 3.0 adapter.

    Went out and bought a PCI-E to USB 3.0 adapter, but that still wasn't exactly flawless. Took me uninstalling some drivers (the Asmedia 3.0 extension host, among others), reinstalling others and making sure I let Windows install drivers for the adapter instead of the drivers that came with it. It's more stable now and actually detected it as USB 3.0, but it still reverted back to not detecting it as USB 3.0 after a while. Still, I actually managed to complete the sensor setup. Which is way farther than I had gotten before. Only to be met with a black screen/no screen when asked to follow the instructions displayed on the headset. 

    I've been trying to get the thing to work for two days now. Honestly, the amount of hoops I'm having to jump through is kind of off-putting and immensely frustrating. 

    Best of luck!
  • Wrayth187Wrayth187 Posts: 3
    NerveGear
    edited May 22
    Oh man...thanks for the response.  Makes me feel a bit better knowing that I'm not the only and I may be on right track.  My PCI-E to USB 3.0 was 37 bucks on Amazon and already shipped this morning and should be here tomorrow.  Keeping my fingers crossed and I'll make sure to delete those old ASmedia drivers like you did.  Thanks again for the response....I felt like I was stumbling in the dark.  :smile:

      Best of luck to you and I hope it works out.
Sign In or Register to comment.