Cannot connect my Rift S to PC after the firmware update — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Cannot connect my Rift S to PC after the firmware update

zongyuzongyu Posts: 9
NerveGear
Hi everyone, I am new to VR and just got my Rift S this morning. Firstly I installed the Oculus software, following the steps to connect my Rift with Displayport and USB 3.0, both connections check are showed Green which is OK, then it says the Rift S need a firmware update, but after updating, the Oculus software crashed and restarted again, each time it restarts, will go to the connection check page, and I never see the Displayport connection and USB 3.0 connection shows Green, they even do not show a red X, just keep rolling, then after a while, crashed again and restarted again... if I unplugged the USB 3.0 end, it will not get crashed but just stay at the connection checking page, once I plugged in the USB 3.0 end, it crashed and restarted again...

I am not sure but it seems related to USB 3.0 driver. I tried reinstalled the USB driver, but this did not work for me.
Could any one here see the problem and help me?
Thanks so much. 

Comments

  • HNRCHHNRCH Posts: 1
    NerveGear
    Same Problems Here. Cant find any helpfull hints.
  • dburnedburne Posts: 2,333 Valuable Player
    Try removing the Rift S in your Oculus Desktop App, then restart Oculus Home and see if will get you set up
    and running properly.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • Soulless512Soulless512 Posts: 78
    Hiro Protagonist
    I just got replacement but I cant set it up after the controllers
  • lenne0815lenne0815 Posts: 100
    Art3mis
    remove all other usb devices.
  • StretchyCMStretchyCM Posts: 8
    NerveGear
    Two users mentioned in various forum posts that there are problems with user accounts whose Windows user name contains umlauts or similar characters. For this reason, I did create a new (second) windows local admin account with a short 1-byte user name ("ocul" in my case) and there installed the Oculus App. WORKED FOR ME!
  • KiipulaKiipula Posts: 1
    NerveGear
    Same here! Any fixes?
  • tempemonkeytempemonkey Posts: 2
    NerveGear
    Same thing is happening to me. Firmware updates do nothing to resolve the black screen issue... This is really starting to get annoying.
Sign In or Register to comment.