New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Quest Appears on PC but Won't Show any Folders on PC

Shadowmask72Shadowmask72 Posts: 4,111 Valuable Player
edited May 2019 in Oculus Quest
When I connect Quest to PC it just shows up as a portable device "quest" in device manager and Windows Explorer. The folder is empty on windows. Currently what I have to do is go to the Phone APP and toggle developer mode OFF then ON again for the message to appear in the headset about accepting the connection. I have updated the drivers (see support message below) but each time I need to connect it requires this dance with the phone app. This is pretty unfeasible seeing as it's not my phone and I don't always have access to it. Any suggestions please?

If your Oculus Quest headset is not appearing as a drive on your Windows PC:

  • Make sure that you use the included USB cable from your Oculus Quest package.
  • Make sure that you select Accept in VR from your headset to allow your computer to access files on your headset.
  • Update your device driver:
  1. From your PC desktop, right-click on This PC or My Computer.
  2. Select Computer.
  3. Select Manage.
  4. Select Device Manager.
  • If you can't see the Manage option, just select Device Manager directly.
  • Click the > next to Oculus Devices or Portable Devices to expand your options.
  • Right-click on Quest and select Update Driver.
  • Select the Browse my computer option, then the Let me pick from a list option.
  • Select MTP USB Device and then select Next to complete the update.


  • System Specs: RTX 2080 ti , i9 9900K CPU, 16 GB DDR 4 RAM, Win 10 64 Bit OS.

    Comments

    • KcovertKcovert Posts: 10
      Brain Burst
      For me it was catching the Allow message box in the Quest at the right time.
    • JollitymeJollityme Posts: 2
      NerveGear
      edited June 2019

      Thanks
    • aleczalecz Posts: 19
      Brain Burst
      Thanks! This is annoying, hopefully it gets fixed soon.
    • pepeezepepeeze Posts: 1
      NerveGear
      Wow! I would of sworn for a good hour if I had not seen your post! Thanks! FYI same on mac. The Android File Transfer app gives you the error message and if Dev mode is enabled, no prompt will ever be triggered on the head set. Took my phone and the second dev mode was disabled, boom, prompt screen showed up...
    • huntercookhuntercook Posts: 1
      NerveGear
      So annoying. In my case I have to turn dev mode off every time; if I plug it in with dev mode on it doesn't show the storage at all.
    • one3rdnerdone3rdnerd Posts: 2
      NerveGear
      I'm having the same issue here. With Developer mode on I'm unable to see any of the files on the Quest when connecting to my PC via USB. 

      I have to

      1 turn developer mode off on the iphone
      2 connect to the PC again
      3 accept the permissions notification in the headset

      Having to use 3 devices to resolve something that should just work once plugged in is annoying.

      Once a device is given permission I shouldn't have to do it every time I connect and go through the above 3 steps.

      Please fix :) 
    • NikorasuNikorasu Posts: 127
      Art3mis
      Mine does this too, but I've never had to worry about it, because running SideQuest seems to fix it. If I plug in my Quest, and the folders don't show up, I can just run SideQuest, which does something that resets the connection and shows the folders. Easier solution, works for me at least.
    • rmib200rmib200 Posts: 4
      NerveGear
      I downloaded the ADB files from the Oculus web and then right click on the .inf file, click install, and it fixed for me.
    • bigballs42069bigballs42069 Posts: 1
      NerveGear
      when i go to device manager it dosent show oculus devises or portable devises
    • Wilson2bWilson2b Posts: 17
      Brain Burst
      edited November 2019
      alecz said:
      Thanks! This is annoying, hopefully it gets fixed soon.

      Yes, agree. Im on NEW Ver 11 update and mount drive still works sometime and have to disable/reenable Developer mode.. a few times a day

    • DanniegoDanniego Posts: 3
      NerveGear
      can confirm loading sidequest makes quest available in file explorer. thx for the tip!
    • Grim2025Grim2025 Posts: 19
      NerveGear
      I haven't been able to get my quest to even show up on my pc or the 3 others i've tested with. Its like the quest doesn't want to communicate with anything now. I'm unsure how to fix but gotten with support and hope they have an answer for me. 
    • krog9999krog9999 Posts: 4
      NerveGear
      (Linux) It worked one day, then the next it did not. Turning off Dev Mode would prompt the "Allow data from this computer", but SideQuest would not connect until I turned back to Dev Mode. Then, SideQuest said to allow data inside Quest -- but since Quest was in Dev Mode, it no longer gave me the prompt !! But I found this page helpful:
      dev.to/jarroo/android-device-debugging-on-linux-mint-error-insufficient-permissions-for-device-udev-requires-plugdev-group-membership-369
      which was helpful in pointing to this page that explained it:
      www.janosgyerik.com/adding-udev-rules-for-usb-debugging-android-devices/
      The key is to add the device (not your users) to the udev rule. I was able to verify with 'adb devices'.
      Then when I connected, it had a new prompt, "Allow debugging from this computer?" with a tick box for "always". 'adb devices' showed my Quest device in the list. Now SideQuest was able to connect. I hope this solves the problem for me going forward, and hope it can help someone else too.

    • reynosotkylereynosotkyle Posts: 1
      NerveGear
      When I connect Quest to PC it just shows up as a portable device "quest" in device manager and Windows Explorer. The folder is empty on windows. Currently what I have to do is go to the Phone APP and toggle developer mode OFF then ON again for the message to appear in the headset about accepting the connection. I have updated the drivers (see support message below) but each time I need to connect it requires this dance with the phone app. This is pretty unfeasible seeing as it's not my phone and I don't always have access to it. Any suggestions please?

      If your Oculus Quest headset is not appearing as a drive on your Windows PC:

      • Make sure that you use the included USB cable from your Oculus Quest package.
      • Make sure that you select Accept in VR from your headset to allow your computer to access files on your headset.
      • Update your device driver:
      1. From your PC desktop, right-click on This PC or My Computer.
      2. Select Computer.
      3. Select Manage.
      4. Select Device Manager.
      • If you can't see the Manage option, just select Device Manager directly.
    • Click the > next to Oculus Devices or Portable Devices to expand your options.
    • Right-click on Quest and select Update Driver.
    • Select the Browse my computer option, then the Let me pick from a list option.
    • Select MTP USB Device and then select Next to complete the update.
    • I turned on "sidequest" while the quest was plugged in, which automatically allowed access to the files. Apparently dev mode messes it up, but the sidequest software makes it right again. Unk why. 
    Sign In or Register to comment.