New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S and Rift 1.38 PTC Release Notes

15791011

Comments

  • FeralReaperFeralReaper Posts: 38
    Brain Burst
    Hahahahaha
    They said they collected enough information and determined it needed replaced. Lmao.
    I already had Amazon replace It and it's still having the same issues. 
    These people have no idea what they're doibg. 
  • TomCgcmfcTomCgcmfc Posts: 2,158 Valuable Player
    Honestly, I do not understand why guys who intend to return for refund or return for replacement from a retail outlet are bothering to start tickets (maybe multiple tickets?) with Oculus Support.  All this is doing is making the Support queue longer for the rest of us imho.  I guess if they are sending in log files it may be somewhat useful but I'd think that Oculus has enough of these already (including mine).

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

  • FeralReaperFeralReaper Posts: 38
    Brain Burst
    It's what they asked me for genius.
    And I wasn't going to return it until they displayed shady behavior. Take your passive agression back to your parents, child.
  • TomCgcmfcTomCgcmfc Posts: 2,158 Valuable Player
    Sorry guys, I did not intend to bag anyone and I see your point(s).  I think it was probably very useful that you sent log files.  Apologies Mates.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

  • Soulless512Soulless512 Posts: 113
    Art3mis
    This patch is a joke. I have had more issues now than ever. No more black screen after getting replacement headset, now I am having nothing but tracking issues. Sorry Oculus, truth hurts but you dropped the ball, should have focused more time on your PC market instead of the quest.
  • RahotepRahotep Posts: 62
    Hiro Protagonist
    edited June 2019
    I got my Rift S last week
    So far, except some white flickering from time to time while in game, no issue
    Oculus-App-Version 1.37.0.245188
    Rift S Firmware 1.67
    Touch Firmware 1.10.5

  • antitrust42antitrust42 Posts: 115
    Art3mis
    edited June 2019
    another update, that is so annoying , they made so many update and need to repeat repair step all the time ! 
  • devoidx360devoidx360 Posts: 3
    NerveGear
    edited June 2019
    Rahotep said:
    I got my Rift S last week
    So far, except some white flickering from time to time while in game, no issue
    Oculus-App-Version 1.37.0.245188
    Rift S Firmware 1.67
    Touch Firmware 1.10.5

    Same experience except when on 1.38 PTC. 1.38 is still a POS (Guess that's what you get in the PTC).
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    In the meantime Quest is getting new features by Carmack! Has he even used this for even 2 hours?
    BATTERY USE
    CONTROLLER OFF STATE
    CONTROLLER LAG TO DROP
    FLASHES
    MONOCHROME AFTER A COUPLE HOURS THEN BLACKSCREEN
    OTHER GAMES CRASH DUE TO USING ONBOARD AUDIO

    BETTER TRACKING TO ACTUALLY PREDICT POSITION RATHER THAN FLIPPING ABOUT SPINNING!
    PULLOUT LOSES FOCUS OF GAME & CAN'T DO SEPERATE WINDOWS SO IS USELESS!
    NO HOME STRAFING
    NO 2 THUMB BUTTON RECENTRE
    NO KEY BIND FOR PASS-THROUGH EXCEPT TOUCH BUTTONx2
    AUDIO WITH NO LIMITER UNTIL AT 100% NOT 50%
    (which reminds me of the Battery Usage is Power OFF at 50% so are linked?)

    Carmack get here right now Boss!
  • Patrn_FlyrPatrn_Flyr Posts: 14
    Brain Burst
    I got lucky except for the flashes. My controller issues were resolved by replacing the unit with one manufactured in 4/19 instead of the original 3/19.  So far no black screens either. I am on 1.38.  
    So if you can return and yours was manufactured in 3/19 I would say try a newer unit.
  • FeralReaperFeralReaper Posts: 38
    Brain Burst
    How can you know when it was manufactured?
  • TomCgcmfcTomCgcmfc Posts: 2,158 Valuable Player
    How can you know when it was manufactured?
    Look at the barcode on the box.  It should say something like 03/2019 or o4/2019.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

  • ian.stallerbrassian.stallerbrass Posts: 10
    NerveGear
    My rift-s is dated 05/2019, running on standard software, I get intermittent screen flash, and have had 3 BSOD's with different messages. Screen flash started from new about 2 days after release date. So issue s with models manufactured 03/2019   04/2019 and 05/2019
  • ShocksVRShocksVR Posts: 486
    Trinity
    It's what they asked me for genius.
    And I wasn't going to return it until they displayed shady behavior. Take your passive agression back to your parents, child.
    "Kevin" could have done a better job communicating what the info was for, but I bet you were already approved for a full RMA of your headset.  That's why he stated "if you plan to instead return it to the retailer let them know".  Ya, what a "shady" thing for Oculus to do . . . .
    i7-7700k, GTX 1080Ti (11G) || MSI B150m (1 USB controller) + Inateck 4-port USB to PCIe (2nd USB controller)
    Oculus Rift S
    Oculus GO
    Oculus RIFT - 3 sensor Room-scale
  • ShocksVRShocksVR Posts: 486
    Trinity
    Rahotep said:
    I got my Rift S last week
    So far, except some white flickering from time to time while in game, no issue
    Oculus-App-Version 1.37.0.245188
    Rift S Firmware 1.67
    Touch Firmware 1.10.5

    Same experience except when on 1.38 PTC. 1.38 is still a POS (Guess that's what you get in the PTC).
    They're already stated 1.38 wasn't going to address the white static screen (which I also have); they're still working on that fix.

    But 1.38 did bring back my Touch haptics; so no it wasn;t a POS update.
    i7-7700k, GTX 1080Ti (11G) || MSI B150m (1 USB controller) + Inateck 4-port USB to PCIe (2nd USB controller)
    Oculus Rift S
    Oculus GO
    Oculus RIFT - 3 sensor Room-scale
  • CrashFuCrashFu Posts: 1,756 Valuable Player
    After sending them logs a week ago from their software. And explaining In depth what I've done to attempt to fix it.

    This is what I get. 

    Hello,

    My apologies for the delay in getting back to you.

    I've had a chance to review your case, and I would like to look into our options further for you. To do that I will need the following:

    • Your full name
    • Your shipping address
    • Your phone number
    • A picture of the headset serial number, it's on the right side of the headset under the facial interface and starts with "1WMGH "
    • A picture of the unit serial number, it's on the bottom of the black box and starts with "1WMVR"
    • A copy of your retail receipt
      • Please make sure your receipt shows the retailer, date of purchase and item

    I see that you had mentioned looking into a refund with the retailer that you purchased the headset from. If you have decided to do that instead, please let me know.

    Regards,

    Kevin
    Oculus Support


    Why do you need any of this? I'm just going to return it for a.refund and consider it later when they fix it.

    This is all completely standard procedure for an RMA.  After reviewing your information, they would have sent you a pre-paid shipping label so that you could send in your Rift-S and get it replaced for free.

    It may have been redundant in your case, since you were still within the 15 days to return to Best Buy or whatever, but Oculus would have done this for you long after that period expired.

    Hell, they replaced my original CV1 for free years after I first got it, well after the warranty period was technically over.  Oculus has some of the best support of any company I've ever dealt with.   You shouldn't get angry at them for following procedures, or because they have probably a hundred people trying to answer probably a hundred-thousand support tickets.. many of which are duplicates or whose senders apparently never wanted a solution to begin with.
    It's hard being the voice of reason when you're surrounded by unreasonable people.
  • OrkelOrkel Posts: 123
    Art3mis
    edited June 2019
    Orkel said:
    Orkel said:
    Tried 1.38 beta again to see if they fixed the recognition issue, still cannot recognize my headset there at all. Both DP and USB cables are not recognized even when redoing the oculus setup in 1.38.
    Leaving PT and going back to 1.37 fixes it and it works again. I hope they fix this 1.38 issue before releasing it out of beta for all.
    Today's attempt at installing 1.38PT still cannot recognize the headset. Both USB and DisplayPort are failing to connect.
    Returning to 1.37 since it works. But god forbid if they release 1.38 before fixing this issue, it'll turn my S into a brick.
    The moment I go back to 1.37 it works. The moment I try 1.38 it becomes unusable/invisible. No matter how many times I switch between 1.37 and 1.38 the results are the same.
    All started after some small update on May 31 on the PT branch.
    When 1.38 first came out, it worked well, but then the 31st update broke it completely
    Today's PT update has fixed this issue (1.38.0.252554) and the headset shows again in 1.38. Will test if it works ingame though.

  • FeralReaperFeralReaper Posts: 38
    Brain Burst
    @Orkel
    Please let me know if it works. because it sounds like we had the same issues.
  • OrkelOrkel Posts: 123
    Art3mis
    @Orkel
    Please let me know if it works. because it sounds like we had the same issues.
    Works, played VRchat and H3VR successfully in 1.38PT.
  • kmw0726kmw0726 Posts: 4
    NerveGear
    I could not connect my headset so I removed my headset from the app and cant get it to re-connect using the PT channel, how do I force a 1.38 update?
  • TomCgcmfcTomCgcmfc Posts: 2,158 Valuable Player
    kmw0726 said:
    I could not connect my headset so I removed my headset from the app and cant get it to re-connect using the PT channel, how do I force a 1.38 update?
    You probably need to run a Repair and make sure your headset is connected.  This should take you back to 1.37.1.  If all works fine you may want to stay with it for now.  Otherwise opt back in to PTC and it should take you to the latest 1.38ptc.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    Did you alter USB Selective Power or USB Power Control in HUBs? If so reset ON again, reconnect USB with 5sec wait, open Oculus and do Guardian Setup/Skip, go to PTC Beta ON.
  • john.zigmontjohn.zigmont Posts: 122
    Art3mis
    After today update  I have black screen and nothing works.

    Thanks,
  • kmw0726kmw0726 Posts: 4
    NerveGear
    I tried running a repair, updating to 1.38, reverting back to 1.37 & ensured my USB ports are always powered....no luck - headset is just dead....
  • dburnedburne Posts: 3,537 Valuable Player
    kmw0726 said:
    I tried running a repair, updating to 1.38, reverting back to 1.37 & ensured my USB ports are always powered....no luck - headset is just dead....
    Maybe not.
    Remove the headset from the devices tab in Oculus Home Desktop.
    Then do a repair of Oculus Home.
    Download the installer from here: https://www.oculus.com/setup/
    Launch the installer and choose Repair.
    It will download the whole thing again and repair.
    Then see if you can get it going.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • kmw0726kmw0726 Posts: 4
    NerveGear
    dburne said:
    kmw0726 said:
    I tried running a repair, updating to 1.38, reverting back to 1.37 & ensured my USB ports are always powered....no luck - headset is just dead....
    Maybe not.
    Remove the headset from the devices tab in Oculus Home Desktop.
    Then do a repair of Oculus Home.
    Download the installer from here: https://www.oculus.com/setup/
    Launch the installer and choose Repair.
    It will download the whole thing again and repair.
    Then see if you can get it going.
    Yup, that is what I did, headset is removed from devices
    Opened apps in Windows and did a repair => which did a full install of 7.18 GB and reinstalled Oculus app

    Still not working....

    Earlier today I uninstalled the Oculus app and re-installed, same result - headset will not connect.

  • TomCgcmfcTomCgcmfc Posts: 2,158 Valuable Player
    kmw0726 said:
    dburne said:
    kmw0726 said:
    I tried running a repair, updating to 1.38, reverting back to 1.37 & ensured my USB ports are always powered....no luck - headset is just dead....
    Maybe not.
    Remove the headset from the devices tab in Oculus Home Desktop.
    Then do a repair of Oculus Home.
    Download the installer from here: https://www.oculus.com/setup/
    Launch the installer and choose Repair.
    It will download the whole thing again and repair.
    Then see if you can get it going.
    Yup, that is what I did, headset is removed from devices
    Opened apps in Windows and did a repair => which did a full install of 7.18 GB and reinstalled Oculus app

    Still not working....

    Earlier today I uninstalled the Oculus app and re-installed, same result - headset will not connect.

    Maybe try disconnecting your headset DP connector and after ~5 seconds re-plugin.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

Sign In or Register to comment.