Rift S connectivity issues — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S connectivity issues

Zuko_de_IrohZuko_de_Iroh Posts: 3
NerveGear
Hey guys,

I'm an absolute VR novice and just bought the rift S.  I had seen that HDMI adapters don't work but thought i was fine as i have usb3 (thunderbolt) on my 2017 Razer blade laptop.  Turns out the usb3 is only connected to the integrated graphics card, and only the hdmi port is connected to my GeForce GTX 1060 graphics card.
Am I interpreting this correctly?


And if so... What work around options do i have?  Can i get an adapter that plugs into usb 2 port at all? No usb2 ports are shown on the above.
And if i bought a razer core to get around this, will i have the same issue as there is no display port on the core?
Any advice would be appreciated.  If you require further info let me know.... please remember... Noob here
Cheers!

Comments

  • TomCgcmfcTomCgcmfc Posts: 1,081
    Wintermute
    I’m no PC expert but I don’t think that panel really tells you anything about whether or not your tb3 usb-c is wired through your integrated intel igpu or not.  If I were you I would contact Razor support and ask them.


    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!
  • Zuko_de_IrohZuko_de_Iroh Posts: 3
    NerveGear
    Cheers for the idea TomCgcmfc... neither do I obviously ;) hoping someone can point me in the right direction
  • TomCgcmfcTomCgcmfc Posts: 1,081
    Wintermute
    If you find that your tb3 is hardwired through your integrated intel igpu then you are out of luck with the Rift S.  You'll then need to either find a nice used Oculus Rift cv1 or maybe a WMR headset.  

    I thought only Alienware and Dell did this, not Razor?  You will only know by contacting Razor support and ask them.  If you list your exact Razor laptop model and specs you may find someone on this forum with the same model and they may be able to help.  You could also try posting on reddit forum as well.  Good luck mate.
    Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!
  • Zuko_de_IrohZuko_de_Iroh Posts: 3
    NerveGear
    edited May 30
    Cheers TomC!! Have contacted Razer... Here are my specs for anyone else watching...
    Razer blade 14" (2017) OS Windows 10 Home 64-bit; Intel Core i7-7700U 2.8GHz / 3.8GHz (Base/Turbo); Chipset Mobile Intel HM175; Storage 512GB NVMe SSD (Samsung PM961); RAM 16GB LPDDR3-2,400 MHz (User upgradable); Display 14-inch IGZO Touch Screen 16:9 aspect ratio 3840 x 2160 4K UHD; Graphics Intel HD Graphics 630; NVIDIA GeForce GTX 1060 (6GB); Ports 1x Thunderbolt 3 (USB-C); 2x USB 3.0 port (SuperSpeed); 1x HDMI 2.0a; 3.5mm headphone/microphone
  • neilsonksneilsonks Posts: 1
    NerveGear
    having this exact same problem as well, tried connecting the headset through a displayport to thunderbolt adapter and didnt work. Can you update the thread if Razer gets back to you?
Sign In or Register to comment.