New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift S connectivity issues

Zuko_de_IrohZuko_de_Iroh Posts: 3
NerveGear
Hey guys,

I'm an absolute VR novice and just bought the rift S.  I had seen that HDMI adapters don't work but thought i was fine as i have usb3 (thunderbolt) on my 2017 Razer blade laptop.  Turns out the usb3 is only connected to the integrated graphics card, and only the hdmi port is connected to my GeForce GTX 1060 graphics card.
Am I interpreting this correctly?


And if so... What work around options do i have?  Can i get an adapter that plugs into usb 2 port at all? No usb2 ports are shown on the above.
And if i bought a razer core to get around this, will i have the same issue as there is no display port on the core?
Any advice would be appreciated.  If you require further info let me know.... please remember... Noob here
Cheers!

Comments

  • TomCgcmfcTomCgcmfc Posts: 3,054 Valuable Player
    I’m no PC expert but I don’t think that panel really tells you anything about whether or not your tb3 usb-c is wired through your integrated intel igpu or not.  If I were you I would contact Razor support and ask them.


    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, PCI-E PCI Express to USB 3.1 Gen 2 card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest 1 w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

  • Zuko_de_IrohZuko_de_Iroh Posts: 3
    NerveGear
    Cheers for the idea TomCgcmfc... neither do I obviously ;) hoping someone can point me in the right direction
  • TomCgcmfcTomCgcmfc Posts: 3,054 Valuable Player
    If you find that your tb3 is hardwired through your integrated intel igpu then you are out of luck with the Rift S.  You'll then need to either find a nice used Oculus Rift cv1 or maybe a WMR headset.  

    I thought only Alienware and Dell did this, not Razor?  You will only know by contacting Razor support and ask them.  If you list your exact Razor laptop model and specs you may find someone on this forum with the same model and they may be able to help.  You could also try posting on reddit forum as well.  Good luck mate.

    Custom built gaming desktop; i9 9900k (water cooled) oc to 5ghz, gtx 1080 ti, 32 gb 3000hz ram, 1 tb ssd, 4 tb hdd.  Asus  ROG Maximus xi hero wifi mb, StarTech 4 port/4 controller sata powered usb3.0 pcie card, PCI-E PCI Express to USB 3.1 Gen 2 card, Asus VG248QE 1080p 144hz gaming monitor, Oculus Rift cv1 w/2x sensors, Vive Pro w/2.0 base stations/controllers, Quest 1 w/Link and VD wireless (good/close 5Ghz wifi and PC with Ethernet cable to my Router).

  • Zuko_de_IrohZuko_de_Iroh Posts: 3
    NerveGear
    edited May 2019
    Cheers TomC!! Have contacted Razer... Here are my specs for anyone else watching...
    Razer blade 14" (2017) OS Windows 10 Home 64-bit; Intel Core i7-7700U 2.8GHz / 3.8GHz (Base/Turbo); Chipset Mobile Intel HM175; Storage 512GB NVMe SSD (Samsung PM961); RAM 16GB LPDDR3-2,400 MHz (User upgradable); Display 14-inch IGZO Touch Screen 16:9 aspect ratio 3840 x 2160 4K UHD; Graphics Intel HD Graphics 630; NVIDIA GeForce GTX 1060 (6GB); Ports 1x Thunderbolt 3 (USB-C); 2x USB 3.0 port (SuperSpeed); 1x HDMI 2.0a; 3.5mm headphone/microphone
  • neilsonksneilsonks Posts: 1
    NerveGear
    having this exact same problem as well, tried connecting the headset through a displayport to thunderbolt adapter and didnt work. Can you update the thread if Razer gets back to you?
  • PhilPhorcePhilPhorce Posts: 1
    NerveGear
    Exact same Razer Blade V6 like Zuko_de_Iroh said:
    Cheers TomC!! Have contacted Razer... Here are my specs for anyone else watching...
    Razer blade 14" (2017) OS Windows 10 Home 64-bit; Intel Core i7-7700U 2.8GHz / 3.8GHz (Base/Turbo); Chipset Mobile Intel HM175; Storage 512GB NVMe SSD (Samsung PM961); RAM 16GB LPDDR3-2,400 MHz (User upgradable); Display 14-inch IGZO Touch Screen 16:9 aspect ratio 3840 x 2160 4K UHD; Graphics Intel HD Graphics 630; NVIDIA GeForce GTX 1060 (6GB); Ports 1x Thunderbolt 3 (USB-C); 2x USB 3.0 port (SuperSpeed); 1x HDMI 2.0a; 3.5mm headphone/microphone
    I am using CableCreation DisplayPort to Thunderbolt Adapter wich is able to work with the Oculus Rift S - as plenty of YT Videos show.

    Is there any Solution so far?
    I am out of further ideas and I wont give Rift S back.

    Cheers...
  • mish240mish240 Posts: 7
    NerveGear
    did you get it working?  Currently having same issue with sons razer laptop.  
Sign In or Register to comment.