New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S microphone issue

Cloud217Cloud217 Posts: 5
NerveGear
I am having an issue with my microphone. I am trying to determine if it is a hardware issue, or if there is some software solution to the problem. I believe it is a hardware issue at this point. Can someone confirm this? I am just about ready to return the unit. I sent in a support request but have not gotten a response.

Issue (Oculus Rift S):
1. The microphone on the headset right after I plug in the USB 3.0 connection and the display port connection typically works for a while.
2. Eventually the microphone sometimes makes a crazy buzzing noise. I can hear it on a Skype test call or on the Sansar feedback option.
3. Eventually the microphone seems to stop making any noise. Windows drivers indicate it is there and functioning, but no sound comes through. I.e. Contona hears nothing and so on. I don't see any errors for the device on the event viewer.
4. Out of everything I have tried the only way to get the microphone back temporarily functioning is typically is to unplug the USB cable. Powering down overnight may also work.

What I have tried:
1. "sfc /scannow"  (from powershell admin mode). This did find and correct some corrupt windows files apparently but did not fix the issue.
2. Connecting to a different USB 3.0 port. As I mentioned, when I disconnect and reconnect the unit it seems to function for a while. I have also tried connecting to USB 3.1 and USB 2.0 ports. When I do this the microphone again does seem to work, but I have no idea for how long and since Oculus Rift S doesn't support this port type it doesn't really help.
3. It just seemed to randomly stop working after an hour or so. Normally starts the buzzing noise first and then makes no noise usually.
4. I have tried uninstalling the driver from the devices page and letting windows automatically reinstall it.
5. Restarting sound services (there were two related services). AutoStart is selected for these.
6. I have checked the windows privacy settings and allow programs to use the microphone is selected.
7. Went through the Windows 10 sequence to fix the microphone.
8. Installed USB drivers for my motherboard (Asus ROG MAXIMUS VIII HERO LGA1151 DDR4)
9. I have tried enabling and disabling the microphone device.
10. Checked that the microphone is not muted under the sound settings in windows
11. My Oculus Rift S is quite new (obviously). There is no visible damage to the cables.

Any help resolving this would be appreciated.










Answers

  • KevinakiKevinaki Posts: 222
    Nexus 6
    I've been having an issue with my mic too. No one can hear me and everything seems to be fine. I've tried pretty much everything you have and more. My Rift works fine too just not my Rift S.
  • girsnoopygirsnoopy Posts: 2
    NerveGear
    I also have this issue. So far I have not been able to reproduce the issue on my desktop but only my Overpowered 15 laptop has the issue. I updated all the drivers i can and tried unplugging all other USB ports. I am at a loss as to what could be causing this but I am wondering if its a problem with my usb controller in this laptop?

    Please let me know if you figure this one out.
  • Cloud217Cloud217 Posts: 5
    NerveGear
    Good to know I am not the only one seeing this issue. I was trying to rule out if this mic issue was caused by the motherboard (i.e. the USB controller) or the Rift S. I talked with tech support and so far they didn't have any solution. I don't have another system to test the Rift S on, but since all other USB functionality seems fine I am thinking it is an issue with the Rift S. I assume the audio is digitized before being send over the USB cable, meaning it should be indistinguishable (at the hardware level) from the other data that is being sent, and the other data seems fine. There could be some error or weird timeout that the Rift S mic controller doesn't handle as well as other hardware, but without more information I don't see any obvious reason it would be an issue with the USB controller or MB.
  • girsnoopygirsnoopy Posts: 2
    NerveGear
    edited June 3
    So there was a post today on reddit about a gain issue and the mic clipping. I am going to play around with that and see if it fixes the issue. Ill let you know what i find out.

    https://www.reddit.com/r/oculus/comments/bvyu67/anyone_have_solutions_for_the_insane_amounts_of/
  • satykillersatykiller Posts: 1
    NerveGear
    @cloud217 do you think this issue is probably due to the power draw of the usb port ? are you having these blackscreen issues many rift s users have been talking about ? 
  • Cloud217Cloud217 Posts: 5
    NerveGear
    satykiller. All other USB activity seems fine. I have not had any blackscreen issues, or any other issues during the times when the microphone stops working. Also, it works for something like an hour before failing. If it was a power issue I would expect it to just not work at all, or fail right away.
  • NiceMitchNiceMitch Posts: 13
    NerveGear
    I've been having this same issue. It's getting really really frustrating! After about 20-40 minutes of gameplay the mic just turns off and no sound until I unplug-replug the headset!
  • Cloud217Cloud217 Posts: 5
    NerveGear
    Sounds like the same issue. Tech. support eventually said I needed to have the unit replaced. What kind of computer or motherboard do you have?
  • NiceMitchNiceMitch Posts: 13
    NerveGear
    I'm using an Asus P8Z68-V running Windows 10 Professional edition. The onboard USB 3 headers don't work at all, so I have been using the Inatek USB 3.0 PCI-E card that Oculus recommended for the CV-1. One of my suspicions is that there isn't enough USB bandwidth to run all of the devices, and if something goes astray with power or bandwidth, the first thing that will cut out is the microphone. I don't think it's a hardware issue since the mic works just fine, and my headset doesn't exhibit the same issue on my wife's PC. 

    Of course I've done all the usuals... update PC drivers, make sure selective power suspend is disabled, ensure 'Allow Windows to turn off this device to save power" is turned OFF for all the USB ports. I've even gone into my BIOS to ensure there wasn't anything funny happening there. 

    I've ordered a PCI USB 3.1 card from Amazon for about $30, which has two type A ports. I'll see if this resolves the issue, otherwise I'll have to try other solutions.

    In the mean time, I've also uninstalled bigscreen audio drivers which also didn't have an impact on the issue, and I've also tried switching out the mic driver for the generic one that Windows 10 has for it. I'll have to do some more testing to see if using the generic driver has an impact on the problem at hand.
  • ProudVetProudVet Posts: 1
    NerveGear
    I am having the same issue mic will work for a little while then all of a sudden just stop working. I have even tested on my other pc same thing happens mic works for a little while then just stops working. I have to unplug the usb cable and re-plug it back in and then again it only works for a few then stops again. This is really upsetting as this is my very first VR headset and I am having this issue. 
  • NiceMitchNiceMitch Posts: 13
    NerveGear
    Update; Mic issue still happening. My wife has a Rift S and she doesn't have the issue whatsoever. I'm going to try out her headset to see if it's an issue somewhere on my computer. If the issue happens again I suppose I'll just return this headset until Oculus can release some type of PCI card compatibility list. It's getting annoying having to do all the troubleshooting for them. 
  • KwkidderKwkidder Posts: 1
    NerveGear
    I had same Issue.  I plugged in a standard headset with Mic and noticed mic was working fine.  When I unplugged headset the mic on Rift S started working again.
  • Cloud217Cloud217 Posts: 5
    NerveGear
    edited July 2
    NiceMitch please let us know how it turned out. Did you wife's Rift S running on your computer have the same microphone issue? If not I think that pretty much proves there is a hardware defect with the unit.
  • NiceMitchNiceMitch Posts: 13
    NerveGear
    Cloud217 said:
    NiceMitch please let us know how it turned out. Did you wife's Rift S running on your computer have the same microphone issue? If not I think that pretty much proves there is a hardware defect with the unit.
    So I went out to the Microsoft store and did an exchange on my headset. So far I haven't run into the issue but I haven't had time to play extensively. If I do run into the issue again I'll be sure to post here. 
  • iargoiargo Posts: 2
    NerveGear
    I have this same issue too. I would be very interested to hear any fix or if a replacement is required. Asus  Prime Z390 mobo. Unplugging gets it working for a short time too!
  • FangzhouFangzhou Posts: 45
    Brain Burst
    Same issue here, this was not happening before the latest update of 1.39PTC, so I believe this is a software issue that caused by Oculus service bug.
    After the "voice become noise" happened once, it will keep happening more frequently until restart computer. Just restarting Oculus software does not fix. 
    The latest update fix zero bugs, removes the previous tracking improvement, brings new bugs like tracking drifting and microphone noise. I don't understand why Oculus developer do this, are they just make bugs to annoy users for fun?
  • KenSniperKenSniper Posts: 184
    Art3mis
    This is happening to me too, mic would suddenly stop working until I unplug and plug back my USB, can get pretty annoying over time
  • Dragon_LostDragon_Lost Posts: 2
    NerveGear
    ASUS M5A78L-M/USB3 and Windows 10 Professional here: I have the problem where my mic isn't working at all if it's connected to a USB 3.0 port. However once it's in a USB 2 port the microphone works perfectly.
    I formatted my PC running Windows 7 few days ago, the microphone worked flawlessly when plugged into USB 3.0.
    Just something is changing on the USB 3 ports between Windows 7 and 10.
    I'm thinking of buying a PCI to USB 3 card as well, to see if that fixes the problem.
  • RattyUKRattyUK Posts: 986
    3Jane
    @Dragon_Lost  - it may be worth checking that when you put Win 10 on that microsoft didn't replace your manufacturer drivers with generic Microsoft ones, you can check with Device Manager.  Just a suggestion :)
    PC info: AMD Ryzen 7 2700X, MSI MPG X570 Edge, 16GB Tforce Pro Dark DDR4 3200, KFA2 RTX 2080 Super, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Antec Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15.1 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD)
  • Dragon_LostDragon_Lost Posts: 2
    NerveGear
    @RattyUK I just read somewhere else that my mainboard doesn't even support drivers for Windows 10 anymore. I guess that will be the explanation to my problem. Thanks for help, though :)
  • MisterRogersMisterRogers Posts: 8
    NerveGear
    Same issue here. I have to keep resetting my USB connection to get the mic to work again. 
  • WarpRulezWarpRulez Posts: 2
    NerveGear
    This seems to be an extremely common problem.
    I had the problem at first that the microphone recorded a really distorted and quiet sound, like a robot. Unplugging and plugging the Rift's USB cable fixed that problem. But now I'm having this exact problem. It will work for a while, and then it picks absolutely nothing. Unplugging and plugging the USB cable fixed the problem for a while.
    Well, I suppose this means no Rift microphone for me. It's not like I'm using it for anything anyways. Even if it turned out to be a hardware problem (which I doubt), I'm too lazy to seek a replacement.
  • dburnedburne Posts: 2,879 Valuable Player
    Now all of a sudden my Rift S microphone is not working at all. Tried a repair of the Oculus software, and still nada. Confirmed I had mic volume all the way up.

    Troubleshooting some more, will advise - will try the unplug USB also.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • dburnedburne Posts: 2,879 Valuable Player
    Ok so unplugging the USB and plugging back in seems to have resolved the issue.
    Will see how long it lasts.
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |
  • CallMeSpitFireCallMeSpitFire Posts: 1
    NerveGear
    Same problem. No solution. I even plugged in antoher mic directly into the rift under the face cushion ... not working. I've tested the mic beforhand on my PC. There seems to be an issue with the Driver.
  • InfectedAlloyInfectedAlloy Posts: 1
    NerveGear
    I believe I have found a solution, First I went into device manager and scrolled down to usb, opened that and than I right clicked usb root hub 3.0, hit properties or whatever and shut off the let windows shut this device off for power saving. After I did that I went to control panel, power,power saving, clicked on advanced settings and disabled USB power management.
    Fyi, I'm not currently at my computer right now, I will fix any errors/locations in this comment later.
  • Alek-Ce117Alek-Ce117 Posts: 1
    NerveGear
    @NerveGear  I'm pretty interested to see if this is gonna fix my friend's headset. I mean the pc doesn't detect any input sounds for the headset. I told him to try unplug/replug usb3 to either ports (he's got only 2), update windows 10, update usb drivers, go into privacy settings and allow everything that has to do with oculus or SpeechRuntime.exe, and double check that any and all input devices were set to "Rift S Headset". Nothing works and I don't think his headset is still under warrranty..

  • RattyUKRattyUK Posts: 986
    3Jane
    Just in case:
    The newest PTC installs both Virtual headphones and Microphone, then sets them as default - which I discovered the hard way trying to have a conversation, in-game, the day after the update :)
    PC info: AMD Ryzen 7 2700X, MSI MPG X570 Edge, 16GB Tforce Pro Dark DDR4 3200, KFA2 RTX 2080 Super, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Antec Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15.1 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD)
Sign In or Register to comment.