Oculus Quest pairs with phone, but the app will not connect to my Wi Fi — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Quest pairs with phone, but the app will not connect to my Wi Fi

Mr_Oculus_Mr_Oculus_ Posts: 38
Brain Burst
I bought an Oculus Quest the other day, but i can't get the Oculus App on my phone to connect to my Wi Fi, i'm posting this here just in case someone knows what the issue is or if someone has very good knowledge with wireless routers because i think that is the issue rather than the app itself. My phone is a galaxy s6 and is running Android 7.0.

The headset pairs up fine with the phone, but when the app tries to connect to Wi Fi, it just doesn't do it. It keeps coming back with errors saying,

Something went wrong
Headset Not connected
Asks me to re enter the Wi Fi password.


Below is a few settings that i've experimented with in my wireless router.

tried changing the channels of my BT Hub 5 numerous times.

Changed my Wi Fi password to something more simple.

Turned off my routers firewall momentarily to see if that was affecting it.

Turned off my routers smart set up.

Split my 5ghz from my 2.4ghz connection and tested the above on the new 5ghz connection.

Is there anything at all that i can try? Because i really don't know what else i can test.


Any help would be greatly appreciated.
«13

Comments

  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    Here is someone else who has the same problem and has gone into more detail about what happens during every step. 

    Did you get any solution for this issue. yet..??? I am facing the exact same issue with my new Quest delivered 5 days ago... I am not able to complete the initial setup here is what happens..

    -It pairs fine with app

    -on the next step when provided wifi password... it says the password is incorrect.. Thats just not true.. the password is correct.

    -it just wont go any further and then says head set is disconnected.. In this situation If I restart headset.. after restart It says "headset is updating.. and you will be notified on your phone when your headset is ready.." and I can see on my wi-fi it shows connected.. But the update process never completes.. I waited many times more than 20 hours just to see what it does.. at the end Again I goes to defaults and shows the 5 digit code to do the setup all over again

    -If I try connecting again it again stuck on the wi-fi password stating the username or password is incorrect..

    -tried all the possible things.. I am using 2.4ghx router tried changing setting, tried with different phone, tried connecting to entirely new wi-fi as well.. still facing the same issue..

    -I have created support ticket with Oculus but still did not get any response yet.

  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    I'm starting to wonder whether or not there is an issue with our actual headsets. How long does it take for Oculus support to reply? Because i don't want to leave it too long before returning it to Amazon.
  • ojuujoojuujo Posts: 19
    NerveGear
    Same problem here. "Headset not connected" or "Something went wrong". 

    Tried different Wifi Networks, the Oculus Quest won't connect. 
  • ojuujoojuujo Posts: 19
    NerveGear
    I have also tried to set up a connection using hotspot. 
    I can see that "Personal Hotspot: 1 Connection" but yet the app still shows "Headset not Connected"
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    ojuujo said:
    I have also tried to set up a connection using hotspot. 
    I can see that "Personal Hotspot: 1 Connection" but yet the app still shows "Headset not Connected"
    I was considering buying some phone credit so that i could test the hotspot, but i've seen a few people try this with no luck now. 
  • ojuujoojuujo Posts: 19
    NerveGear
    I'm starting to wonder whether or not there is an issue with our actual headsets. How long does it take for Oculus support to reply? Because i don't want to leave it too long before returning it to Amazon.
    I might not be your headset.
    I have two Quests, both arrived a couple of hours ago, both cannot connect to Wifi. 
    What are the odds that both are actually broken?

    We tried to connect with two different router, hotspot and changed the phone to start the initial set up. 

    All failed. 
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    Yeah true. I hope it's something to do with the app or Wi Fi. What router do you have? I have a BT Hub5. 
  • OculusQuestDayOneOculusQuestDayOne Posts: 21
    Brain Burst
    edited June 3
    Its totally possible the new batch of headsets we received having this issue... some kind of bug may be.. I have tried all the possible things. setting up using different phone, different wifi, modifying wi-fi settings and also tested with mobile and PC hot spots.. nothing works.. waiting on response from Oculus on my  support ticket
  • ojuujoojuujo Posts: 19
    NerveGear
    @Mr_Oculus_ : I'm using Netgear
    @OculusQuestDayOne : please let us know when your ticket received a response. 
    As of your name, please don't tell me that you are having this problem since 2 weeks...
  • ojuujoojuujo Posts: 19
    NerveGear
    What I figured: When connecting to Hotspot on the iPhone the iPhone will show if a connection is established. 
    Even though the Oculus App says that it doesn't work (something went wrong / headset disconnected), the hotspot connection will stay. If I switch the hotspot off and on it will soon afterwards again have a connection. So somehow the Oculus Quest does connect, but it cannot download etc.

    What is it saying on your Quest when you are actually looking through it? Mine shows ""Updating your headset - You will be notified on your phone when your headset is ready - Downloading"" - but it's not downloading anything, I can check the used MB on my iPhone and those doesn't change at all. 
    The App continues to say "Something went wrong - Headset Not connected "
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    Its totally possible the new batch of headsets we received having this issue... some kind of bug may be.. I have tried all the possible things. setting up using different phone, different wifi, modifying wi-fi settings and also tested with mobile and PC hot spots.. nothing works.. waiting on response from Oculus on my  support ticket
    Yeah, i had to wait until Amazon got a new batch of Quests in, so maybe this new batch is faulty.
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    edited June 3
    ojuujo said:
    What I figured: When connecting to Hotspot on the iPhone the iPhone will show if a connection is established. 
    Even though the Oculus App says that it doesn't work (something went wrong / headset disconnected), the hotspot connection will stay. If I switch the hotspot off and on it will soon afterwards again have a connection. So somehow the Oculus Quest does connect, but it cannot download etc.

    What is it saying on your Quest when you are actually looking through it? Mine shows ""Updating your headset - You will be notified on your phone when your headset is ready - Downloading"" - but it's not downloading anything, I can check the used MB on my iPhone and those doesn't change at all. 
    The App continues to say "Something went wrong - Headset Not connected "
    Mine also says the same thing and a couple of times it did start to download the update randomly, but it will only go to 99% which is when you must enter your Wi Fi password in the app. The fact that the app remembers my Wi Fi now and then for the Quest proves that the app can find my Wi Fi and accepts the password at some point, even though it says "something went wrong" 
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    edited June 3
    ojuujo said:
    @Mr_Oculus_ : I'm using Netgear
    @OculusQuestDayOne : please let us know when your ticket received a response. 
    As of your name, please don't tell me that you are having this problem since 2 weeks...
    So it's not an actual issue with the same brand of router, although it could still be some sort of setting. I'm starting to think it's not a router setting though, considering how many things i have tried changing in there and how many things others have tried too. 
  • OculusQuestDayOneOculusQuestDayOne Posts: 21
    Brain Burst
    edited June 3
    @ojuujo I am having this issue sine its got delivered on 29th June. since then I have been spending hours everyday troubleshooting to setup this device.. Sure as soon as I receive any update on my ticket I will post here..
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    Do you guys have an Oculus Go set up on your same Oculus account? I'm wondering if my Oculus Go is interfering somehow? If you do have an Oculus Go, ill try setting up a new account for the quest, it's a long shot, but really running out of ideas here lol
  • ojuujoojuujo Posts: 19
    NerveGear
    No, this is my first VR experience ever. 
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    ojuujo said:
    No, this is my first VR experience ever. 
    Ah kk, that's not the issue then :(
  • ojuujoojuujo Posts: 19
    NerveGear
    ojuujo said:
    What I figured: When connecting to Hotspot on the iPhone the iPhone will show if a connection is established. 
    Even though the Oculus App says that it doesn't work (something went wrong / headset disconnected), the hotspot connection will stay. If I switch the hotspot off and on it will soon afterwards again have a connection. So somehow the Oculus Quest does connect, but it cannot download etc.

    What is it saying on your Quest when you are actually looking through it? Mine shows ""Updating your headset - You will be notified on your phone when your headset is ready - Downloading"" - but it's not downloading anything, I can check the used MB on my iPhone and those doesn't change at all. 
    The App continues to say "Something went wrong - Headset Not connected "
    Mine also says the same thing and a couple of times it did start to download the update randomly, but it will only go to 99% which is when you must enter your Wi Fi password in the app. The fact that the app remembers my Wi Fi now and then for the Quest proves that the app can find my Wi Fi and accepts the password at some point, even though it says "something went wrong" 
    That download screen isn't moving by me nor does it show any percentage. It's starting exactly in the middle and it doesn't move at all. 
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    ojuujo said:
    ojuujo said:
    What I figured: When connecting to Hotspot on the iPhone the iPhone will show if a connection is established. 
    Even though the Oculus App says that it doesn't work (something went wrong / headset disconnected), the hotspot connection will stay. If I switch the hotspot off and on it will soon afterwards again have a connection. So somehow the Oculus Quest does connect, but it cannot download etc.

    What is it saying on your Quest when you are actually looking through it? Mine shows ""Updating your headset - You will be notified on your phone when your headset is ready - Downloading"" - but it's not downloading anything, I can check the used MB on my iPhone and those doesn't change at all. 
    The App continues to say "Something went wrong - Headset Not connected "
    Mine also says the same thing and a couple of times it did start to download the update randomly, but it will only go to 99% which is when you must enter your Wi Fi password in the app. The fact that the app remembers my Wi Fi now and then for the Quest proves that the app can find my Wi Fi and accepts the password at some point, even though it says "something went wrong" 
    That download screen isn't moving by me nor does it show any percentage. It's starting exactly in the middle and it doesn't move at all. 
    It's only done it for me twice and i've been trying to get it to work every day since it got here (last Thursday) It happened when i quit the app whilst it was saying "something went wrong" when i restarted the app, my wireless router randomly popped up under neath The Quest and it started downloading the update up to 99%, but once again, you then have to go into "finish set up" and then it still says something went wrong.
  • OculusQuestDayOneOculusQuestDayOne Posts: 21
    Brain Burst
    @ojuujo
    This is the first device I am configuring.. and yes I noticed the same behavior about quest being updated and the update never completes.. after long hours of waiting it goes back to default screen where it shows 5 digit code again to pair the device.. below is the post where I mentioned details steps about the issue.. its exactly the same you guys are facing..

    https://forums.oculusvr.com/community/discussion/76606/oculus-app-wont-connect-to-wi-fi-after-pairing-oculus-quest-getting-misleading-incorrect-message/p1?new=1

    https://www.reddit.com/r/OculusQuest/comments/bw2fvb/oculus_app_wont_connect_to_wifi_after_pairing/
  • ojuujoojuujo Posts: 19
    NerveGear
    https://www.androidcentral.com/how-set-your-oculus-quest

    Based on this after entering the wifi password there should be other steps before the Oculus Quest should try to download the update. 

    Maybe the Oculus App is faulty for some devices and need an update from Oculus?


  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    @ojuujo
    This is the first device I am configuring.. and yes I noticed the same behavior about quest being updated and the update never completes.. after long hours of waiting it goes back to default screen where it shows 5 digit code again to pair the device.. below is the post where I mentioned details steps about the issue.. its exactly the same you guys are facing..

    https://forums.oculusvr.com/community/discussion/76606/oculus-app-wont-connect-to-wi-fi-after-pairing-oculus-quest-getting-misleading-incorrect-message/p1?new=1

    https://www.reddit.com/r/OculusQuest/comments/bw2fvb/oculus_app_wont_connect_to_wifi_after_pairing/
    Like you said in your reddit post, it very well could be a fault with our headsets. I wish i knew what was going on behind the scenes when we enter our wireless password, is it trying to connect to the headset during this stage or is it simply trying to connect to our router, the error messages we receive don't help us at all and the longer we wait for Oculus supprt to reply, the harder it will be for us to return these.
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    A little update, its not much but it must mean something. I am now trying to connect it when my phone is very close to the router, i now never receive incorrect password errors pr wi fi errors, but i do constantly receive the headset is not connected error.
  • OculusQuestDayOneOculusQuestDayOne Posts: 21
    Brain Burst
    edited June 3
    Yes I do suspect its some kind of issue with the hardware itself..

    I checked.. when we enter wi-fi password.. I reviewed form the wi-fi console statistics the Quest try to connect to the wifi and then disconnects within 2-3 seconds..  when we restart it shows up connected in the wifi statistics..

    Regarding wi-fi range as someone suggested on Oculus forum.. an hour ago I kept both Headset and the mobile phone literally a feet away form the wi-fi router and tried to connect and I found the same issue..

    one more thing I would like to test is using phone with latest android OS may be Android  Pie 9 OR Android Oreo 8.x.. unfortunately I dnt have the device at the moment.. and my PC as well dont support virtualization for me to try Android Pie emulator on my PC.. this is something I would like to confirm..
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    edited June 3
    Hmm i cant help with the android part as i dont have one of then phones either. Considering oculus support has told other people with the same issue to try it around a friends house and use their wi fi, i dont think there is much point in waiting for my support ticket to go through considering that has already been done, i'm seriously considering sending it back to amazon tomorrow, i really don't see any other option.
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    Is there a way to bypass the initial set up? a short cut command to the main menu? I remember with the Oculus Go, you could press some buttons on the headset to get to the main menu, you still have to eventually do the initial set up to use the Oculus Store, but i think with the go, you could use the web browser.
  • byang164byang164 Posts: 2
    NerveGear
    I've tried using my phone, android pi, and the same issue keeps happening. Probably an issue with the hardware
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    I am in touch with Oculus Support now, although their first email did only cover basic troubleshooting, which we have already tried. I'm hoping with the more detail i went into in the reply, they will figure something out. Has anyone else had any more progress today? 
  • OculusQuestDayOneOculusQuestDayOne Posts: 21
    Brain Burst
    Thanks..
    Nope.. I have not been contacted by Oculus support yet.. please do update any progress you make
  • Mr_Oculus_Mr_Oculus_ Posts: 38
    Brain Burst
    Thanks..
    Nope.. I have not been contacted by Oculus support yet.. please do update any progress you make
    Will do, they reply very quickly when you get through, but i haven't made any progress. They asked me to do a factory reset and have now left it as they will look into it and get back to me. I have asked roughly how long it will take because i dont want to leave it too long before returning it. 
Sign In or Register to comment.