My oculus Rift S DisplayPort on headset is disconnecting when i play — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

My oculus Rift S DisplayPort on headset is disconnecting when i play

dadzi10dadzi10 Posts: 2
NerveGear
After about 10 minutes of playing my screen goes black and in oculus app pops information that my displayport on headset isnt connected and after  few seconds it connects back.Help  

Comments

  • Submerged445Submerged445 Posts: 5
    NerveGear
    Sounds like the same issue as me, getting really frustrated.

    What is really annoying is that for me it works fine for 5 minutes or so then it's like somebody keeps turning the TV off and on over and over again. The Oculus home is fine as well it's just the games that are causing the blackouts. Static flash and 2 second black screen, display comes beck for 1-2 seconds, cut to black again... Repeat.

    Have repaired software, uninstalled in safe mode and reinstalled, purchased powered usb hub, turned off power saving settings, updated drivers, tried all different ports, unplugged everything from pc including monitor and usb devices, turned off all other software, reinstalled usb drivers, opted into test firmware, downsampled severely, turned it off and on again...

    Totally ridiculous - finally got a response from my support ticket and they suggested trying the test firmware despite the fact I stated I had already tried that. I did submit an error log that seems to be ignored for now.

    At this point I'm just fed up with the whole thing.

    Do you only get the issue when trying to play games? It definitely doesn't occur for me in Oculus home or watching videos
  • Submerged445Submerged445 Posts: 5
    NerveGear
    Oh I disabled sound entirely and tried headphones too! Nothing works!
  • dadzi10dadzi10 Posts: 2
    NerveGear
    Yea I only get it when playing games, in oculus home everything works fine and I am still waiting for respons from support :<
  • MJehle01MJehle01 Posts: 29
    Brain Burst
    I get black screens as well. The Rift S works for maybe 5 minutes, then flickers and eventually goes black. Happens in Oculus Home as well as in games. I've been trying everything now for the last two weeks. Now the Oculus support said they would send me a new cable. Sounds a bit like fishing in the dark to me.
  • Submerged445Submerged445 Posts: 5
    NerveGear
    I'm just hoping the reason support can't help is that it is a firmware issue so there's nothing that can fix except an update.

    If it was hardware you'd think it would be blacking out constantly not just in games although Mjehle01 just said it gets him in home as well...

    I might try another older Nvidia driver tonight although I have already tried a couple
  • sraurasraura Posts: 589
    Trinity
    edited June 4

    Taking a shot into dark here. If oculus home works flawlessly and you're sure that it is not the cable/loose connector - this starts to be interesting. Technically between oculus home and some game there shouldn't be much of a difference expect probably higher load on the computer processors and on PSU. Would you mind posting your computer specs - including the brand of the power supply unit and type of the casing your computer is in.
  • Submerged445Submerged445 Posts: 5
    NerveGear
    I'm not home atm to check but I believe it's a 600W PSU. I'll take a closer look later today.
  • sraurasraura Posts: 589
    Trinity
    edited June 4
    Yep... some people have reported that after getting new replacement Rift S - the black screen issues have been fixed.  Some say that even turning down the volume helps. For some it has been the cable and for some something else. For some nothing seems to help.

    Seems like rather odd problem so trying to figure out is there some common denominator (similarity) behind these "partially working" devices.
  • Submerged445Submerged445 Posts: 5
    NerveGear
    It's definitely a weird one. The CV1 also works fine on this same setup so I'm extra perplexed.
  • AbyssalSmokeAbyssalSmoke Posts: 13
    NerveGear
    Do you have a gsync monitor connected to your PC? Try unplugging any other display port cables and try it on its own.
    Also once the game is loaded try unplugging and reconnecting the display cable.
    I had this issue with a gsync monitor I had. just a thought might be unrelated.
  • shaepauloshaepaulo Posts: 1
    NerveGear
    Had to go to my Control Panel > Hardware and Sound > Devices and Printers > from here right click on your VR Desktop device > Display Settings > Power and Sleep > When plugged in, turn off after = NEVER!!!!!
    Mine was automatically set to 15 minutes for some random reason and I'm hoping that's what was causing the blackouts and the orange standby light coming on while I was in the middle of a game
  • GaveDrohlGaveDrohl Posts: 1
    NerveGear
    Did any of you ever solve this problem?  I have the same problem.  Thinking of returning.  This is ridiculous.
  • sraurasraura Posts: 589
    Trinity
    edited July 18
    For most reported solved cases of these problems with rift going black after x period of time have been power related issues.
    • Either entire PSU has been end of it's lifespan or under powered (most commonly 550W supplies) or
    • Computers USB ports were unable to provide enough power or/and
    • Too many devices were connected to computer.
    Solutions may include (and are not limited to)
    • Trying other 3.x usb port. Also keep in mind that front panel 3.x connectors are often different than the variants on back panel.
    • Unplugging all non essential devices from the computer (including secondary monitors).
    • New PSU (I would recommend at least 650W plus gold or better)
    • Externally powered USB hub
    • Usb card which gets power directly from PSU
    • Usb ports on self powered device like monitor or external harddisk
    It is good to keep in mind that also if the cable connector is loose from HMD's end, it may cause the same issue.

    This information is based on nothing official so if you go and buy new hardware to fix your issue, be prepared also to the possibility that it doesn't fix the issue you're trying to fix.
  • Nathanael_Nathanael_ Posts: 11
    NerveGear
    I havnt even been able to set mine up. During set up, I plug in USB > get green checkmark, then plug in display port>get green check mark FOR 3 SECONDS then it disconnects. 
  • erik.hougaard.35erik.hougaard.35 Posts: 1
    NerveGear
    Me too. It disconnects after 3-10 seconds. The Rift S worked well for a week or so (with the same computer) and suddenly started behaving like this. Any new on the issue?
  • JohnM52JohnM52 Posts: 5
    NerveGear
    The same on my Palit 1080ti blower style (the black one) , but works fine on my Zotacl 1060 6gig mini
Sign In or Register to comment.