Oculus Rift S Issue: Some New Steam titles screen flashing polygons at launch - unplayable — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift S Issue: Some New Steam titles screen flashing polygons at launch - unplayable

Anyone else having an issue with some of their Steam games? Both Swords of Gargantua and Trover Saves the Universe purchased from Steam load fine, but the screen is a wreck with flashing polygons all over the place obfuscating the game beneath. This happens as soon as the game launches (during the title screens and all). The game otherwise appears to be running fine in the background, and is SOMEWHAT visible if you look at the monitor mirror, though barely.  I am not sure if it is a coincidence or not, but it all happened right after I had done a Reset Location on the Rift  menu while playing Trover Saves the Universe (screen went corrupt right after and never got it back). Swords of Gargantua I had not done a reset on, though had just recently downloaded. I have done all the standard reboots, resets, etc. and nothing seems to fix it.I of course tried going back and doing multiple location resets to no avail as well. Both games above work perfectly fine when I play them on my Vive and Samsung WMR headsets on the same machine and Steam instance... so I know the games are fine. Of course it  had to be the two new games... I'm sure there are others as well but these are the 2 which are failing 100% at the moment... Any ideas welcome, or better, solutions if others have had and resolved this problem!

Comments

  • EventlessHorizonEventlessHorizon Posts: 8
    NerveGear
    Still no solution for this problem, other than switching to a different headset, which is a huge pain. Nobody else seeing this, or are there fewer Oculus users using Steam than I expected? :(
Sign In or Register to comment.