Your headset displayport isn't plugged in — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Your headset displayport isn't plugged in

AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
NerveGear
My new Rift S keeps getting a black screen while using it and this is the error that comes up every time. I checked device manager and under Camera > Rift S it said "This device cannot start (Code 10)".

 If I restart the software I can get it to come back on but only or another 10 minutes or so, then the same thing happens. I know it's not the headset as it works fine connected on a friend's computer. The GPU is an Asus Geforce RTX 2080. I'm not sure if it's a driver issue or the card at this point but I've only had the card for a few months and my monitor works fine whether it's using the HDMI or DP port.

Comments

  • sraurasraura Posts: 208
    Nexus 6
    Try updating GPU drives... you can find new ones from www.geforce.com
    Also windows settings -> privacy -> camera -> allow apps to access your camera -> on

  • AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
    NerveGear
    I did update the GPU to the latest driver from their website. Camera is already set to on, so no go there. The Rift does work for a little while but loses the connection for some reason. At least, that's what it says even though I have disconnected and reconnected it.
     I notice in Device Manager it keeps disappearing and reappearing while this is going on. I would hope it's a driver issue and not the card but I would need another to try it out on to verify that.
  • sraurasraura Posts: 208
    Nexus 6
    edited June 11
    Sorry to hear that it didn't help.
    Your cable might be loose on HMD's end... here is instructions howto check that: https://support.oculus.com/347068065953251/#faq_374097939874292
    When reseating cable back to HMD, make sure to push it all the way in. You can hear tiny "click" when it does.
    If these will not solve your problem, I would recommend gathering the logs and submitting official ticket to Oculus support. Instructions here: https://forums.oculusvr.com/community/discussion/76264/please-do-not-submit-duplicate-support-tickets
  • RattyUKRattyUK Posts: 671
    Neo
    My new Rift S keeps getting a black screen while using it and this is the error that comes up every time. I checked device manager and under Camera > Rift S it said "This device cannot start (Code 10)".
    Have you tried uninstalling the camera from Device Manager, then searching for new devices?
    I did this when other odd things were happening prior to the second update, the camera was appearing and disappearing...
    PC info: AMD Ryzen 7 2700X, Asus ROG Crosshair VII Hero, 16GB Tforce Pro Dark DDR4 3200, Gigabyte GTX 1080, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Corsair Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15 Linux) 32" AOC 4K Monitor.

    Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD 3K screen)
  • AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
    NerveGear
    sraura said:
    Sorry to hear that it didn't help.
    Your cable might be loose on HMD's end... here is instructions howto check that: https://support.oculus.com/347068065953251/#faq_374097939874292
    When reseating cable back to HMD, make sure to push it all the way in. You can hear tiny "click" when it does.
    If these will not solve your problem, I would recommend gathering the logs and submitting official ticket to Oculus support. Instructions here: https://forums.oculusvr.com/community/discussion/76264/please-do-not-submit-duplicate-support-tickets
    Unfortunately, I've already tried reseating the cable. I didn't think that was it as the headset does work without any problems on a friends' PC. I'm trying to figure out if it is just a driver issue or the card itself.
  • AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
    NerveGear
    RattyUK said:
    My new Rift S keeps getting a black screen while using it and this is the error that comes up every time. I checked device manager and under Camera > Rift S it said "This device cannot start (Code 10)".
    Have you tried uninstalling the camera from Device Manager, then searching for new devices?
    I did this when other odd things were happening prior to the second update, the camera was appearing and disappearing...
      I did that last night, tried uninstalling and then scanning for new hardware and then uninstalling/reinstalling using the oculus-driver file, but they both had the same result.
     That does sound like my issue, though, the camera disappears and reappears from DM.
  • sraurasraura Posts: 208
    Nexus 6
    Ok... hopefully support team comes up with some easy solution or explanation.
    All I could find is this link and that surely isn't easy solution - if it even is a solution :)
  • AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
    NerveGear
    I'm actually going to try another video card, a friend of mine has an older one I can borrow when I see them in a day or two (still good for VR). If it works fine with that one installed, I'm chalking it up to the card itself.
  • sraurasraura Posts: 208
    Nexus 6
    Sounds like a great plan. Let us know how it goes. Might help some1 else in the future.
  • AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
    NerveGear
    So...I'm at a loss. I have now tried it on two different computers and get the same error that come up (Displayport not connected), yet it worked fine on my friends' PC. I guess I'll try resetting the connection on the headset again but I've got nothing else for this problem.
  • sraurasraura Posts: 208
    Nexus 6
    edited June 14
    Logs didn't show nothing?

    It might be that you need cable replacement.
  • AnneSurelyOverdriveAnneSurelyOverdrive Posts: 7
    NerveGear
    So...it's been working. I did try another reset of the cable that is connected to the headset and it's been good. I'll put that as the fix since it hasn't happened again since I did that this weekend.
Sign In or Register to comment.