Win10 PageFile with Oculus Rift — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Win10 PageFile with Oculus Rift

TomCgcmfcTomCgcmfc Posts: 1,086
Wintermute
edited June 15 in Oculus Rift S and Rift
I found it interesting that in the latest Oculus Tray Tool (OTT) manual (I'm not actually using OTT right now btw) it states the following, regarding Win10 page file considerations;

"Page file considerations
I recommend having a page file as this seems to increase stability at least when running VR games. By default Windows manages the page file, but I’ve found that manually setting Minimum and Maximum values to match that of your graphics card memory size has helped with game crashes. Might just be me, but in either case, below are the details for how to manage the Windows page file.
1) Use an administrator account to log on to Windows 10.
2) From the desktop screen, right-click the Start button to open its context menu.
3) Click System.
4) From the right panel (it incorrectly says left) of the System window, click Advanced system settings.
5) On the System Properties box, ensure that you are on the Advanced tab.
6) Click the Settings button from under the Performance section.
7) On the Performance Options box, go to the Advanced tab.
8) Click the Change button from under the Virtual memory section.
9) On the Virtual Memory box, uncheck the Automatically manage paging file size for all drives
checkbox.
10) From the available list, click to select the drive on which Windows 10 is installed. (C:)
11) From below the list, click to select the Custom size radio button.
12) In the now-enabled fields, type the minimum and maximum size of the Pagefile in megabytes
(MB). I would recommend setting the Minimum size to at least the same as the amount of
memory your graphics card has. For Maximum size increase this value by 2GB.
13) Click Set and then click OK.
14) Restart your computer when you're done."

I'm not sure why this would help, esp. if you already have a lot of Ram onboard (32gb in my case)?  But, heh, it seems to help smooth out my X-Plane 11 a bit.  With my gtx1080ti w/11gb Vram I selected 11000mb min, 13000mb max.  It does take up more disk space (win10 auto uses ~4800mb) and probably is only effective with a SSD drive.

Probably worth trying and easy to undo imho.  Since I'm only currently using a cv1, I cannot say for sure, but maybe this would help reduce Rift- S flashes.

Any thoughts from PC gurus as to why this should or should not work?  Thanks.
Alienware 17r4 Laptop with i7-7700hq 2.8/3.6, 32 gb ram, gtx1060 w/6gb ram, 256gb ssd, 1tb hdd, Oculus Rift w/2x sensors.  Now using an Alienware Graphics Amplifier (AGA) with Zotac gtx1080ti Blower and Asus vg248qe 144hz external monitor.  All works great!

Comments

  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    For Audio Sequencers (Cubase etc.) they recommend 1.5x the size of your RAM to playback the hungry Samples for Instruments. As VR is heavy on graphics then that may help your sound thus relieve the PC RAM that bit further.
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    Trying this now with my 8GB RAM so min=8192, max=10240
Sign In or Register to comment.